Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006431TestLinkNew Featurepublic2014-07-09 14:452014-07-27 10:02
Reporterdomenik 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0006431: Reuse of test case steps
DescriptionIn large software projects it often happens that in many test cases is necessary to do certain steps to reach the desired test scenario. That means you often write the same steps over and over again for similar test cases.

It could be possible that you have some kind of glossar or keywords which you can choose via a dropdown list to add a "keyword" in the testcase description. Behind those keywords there are some steps you want to reuse also in other test cases as well.

After saving the test case and another tester opens this case and is maybe not so familiar with this, he could click and the keyword and sees in a small new window all the required steps behind those "keyword".

We would be very happen to have such functionality. If you have any questions don't hesitate to contact me. I would like to hear your opinion.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
duplicate of 0005763closedfman Test Case Reuse - Ghost - Possibility to get generated ghost string 

-  Notes
(0021232)
fman (administrator)
2014-07-10 07:45
edited on: 2014-07-10 07:46

this feature already exists => GHOST STEPS and GHOST TEST CASES
give a look to the phantom icon

please do some searches on forum.testlink.org and also here before reporting (REMOVE STATUS FILTER because closed issue are not displayed)
Also read README provided with each release where new feature are indicated

(0021311)
fman (administrator)
2014-07-27 10:02

released

- Issue History
Date Modified Username Field Change
2014-07-09 14:45 domenik New Issue
2014-07-10 07:45 fman Note Added: 0021232
2014-07-10 07:45 fman Relationship added duplicate of 0005763
2014-07-10 07:46 fman Note Edited: 0021232 View Revisions
2014-07-10 07:46 fman QA Team - Task Workflow Status => TBD
2014-07-10 07:46 fman Status new => resolved
2014-07-10 07:46 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2014-07-10 07:46 fman Resolution open => fixed
2014-07-10 07:46 fman Assigned To => fman
2014-07-27 10:02 fman Note Added: 0021311
2014-07-27 10:02 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker