Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006405TestLinkTest Execute - Filterspublic2014-06-26 11:002015-01-26 12:54
Reporterjcppkkk 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusassignedResolutionreopened 
PlatformAnyOSAnyOS VersionAny
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version 
Summary0006405: TC execution filter - (Result = NOT Run, ON=All Builds, with Keyword) shows executed TCs
DescriptionSituation:

After a new build released, we want to continue testing TCs not executed before, so we use TC execution filter(Result = NOT Run, ON=All Builds, Keyword="RAT") to choose unexecuted TCs. but the some of the filter results are executed.
Steps To ReproduceCreate Test Plan
Create Test project
Create keyword "RAT"
Create and use platform
Create TCs with keyword "RAT" and add into Test project/platform
Create Build 0001
Exec some of TCs
Create Build 0002
At TC execution list of Build 0002, use TC execution filter (Result = NOT Run, ON=All Builds, Keyword="RAT")

Actual ==> Some of the filter results are executed TCs.
Expected ==> All filter results are unexecuted TCs.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome 36.0.1985.84 beta-m
PHP VersionHipHop VM 3.0.1 (rel)
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon 2014-06-26.18_35_17.png [^] (44,132 bytes) 2014-06-26 11:00


png file icon 2014-06-26.18_45_03.png [^] (16,580 bytes) 2014-06-26 11:01

- Relationships

-  Notes
(0021173)
fman (administrator)
2014-06-26 12:13

>> Exec some of TCs
>> Create Build 0002
>> At TC execution list of Build 0002,
>> use TC execution filter (Result = NOT >> Run, ON=All Builds, Keyword="RAT")
>> Actual ==> Some of the filter results are executed TCs.
>> Expected ==> All filter results are unexecuted TCs.

I need better details, use just 2 or 3 test cases, but provide very clear steps by steps to reproduce, is only way we can be sure we are doing exactly SAME TESTS.

When this info will be available, I can try to add this ticket to the working queue
(0021310)
fman (administrator)
2014-07-27 09:52

unfortunately user did not provided requested information
(0021429)
jcppkkk (reporter)
2014-08-12 13:43
edited on: 2014-08-12 14:23

I have traced code and found some bug.

getHitsNotRunFullOnPlatform(at lib/functions/testplan.class.php) does not handle the case "$buildSet is not null":

function getHitsNotRunFullOnPlatform uses $buildsCfg['statusClause'] set in helperGetHits,
but helperGetHits does not setup $buildsCfg['statusClause'] when $buildSet is not null, in my case the arg $buildSet contains build ids.

This patch fixed my problem in this case:

From 28b1c31c81c56a5072776c8844a8ec0c5ba94a4e Mon Sep 17 00:00:00 2001
From: Jethro Yu <jethro.yu@hopebaytech.com>
Date: Tue, 12 Aug 2014 21:27:08 +0800
Subject: [PATCH] fix Build notrun filter

---
 lib/functions/testplan.class.php | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/functions/testplan.class.php b/lib/functions/testplan.class.php
index b879525..c5379bb 100644
--- a/lib/functions/testplan.class.php
+++ b/lib/functions/testplan.class.php
@@ -4361,7 +4361,7 @@ class testplan extends tlObjectWithAttachments
         " SELECT COUNT(0) AS COUNTER ,NHTCV.parent_id AS tcase_id" .
         " FROM {$this->tables['testplan_tcversions']} TPTCV " .
         " JOIN {$this->tables['builds']} B ON B.testplan_id = TPTCV.testplan_id " .
- $buildsCfg['statusClause'] .
+ ($buildSet ? " AND B.id IN ({$buildsCfg['inClause']}) " : $buildsCfg['statusClause']) .

         " JOIN {$this->tables['nodes_hierarchy']} NHTCV ON " .
         " NHTCV.id = TPTCV.tcversion_id " .
--
1.8.3.2

(0021430)
fman (administrator)
2014-08-12 13:47

OK, thanks for code.
Anyway in addition an scenario to allow to reproduce it, is a must

- Issue History
Date Modified Username Field Change
2014-06-26 11:00 jcppkkk New Issue
2014-06-26 11:00 jcppkkk File Added: 2014-06-26.18_35_17.png
2014-06-26 11:01 jcppkkk File Added: 2014-06-26.18_45_03.png
2014-06-26 12:13 fman Note Added: 0021173
2014-06-27 16:49 fman Assigned To => fman
2014-06-27 16:49 fman Status new => feedback
2014-07-27 09:52 fman QA Team - Task Workflow Status => TBD
2014-07-27 09:52 fman Note Added: 0021310
2014-07-27 09:52 fman Status feedback => resolved
2014-07-27 09:52 fman Resolution open => unable to reproduce
2014-07-28 20:31 fman Status resolved => closed
2014-08-12 13:43 jcppkkk Note Added: 0021429
2014-08-12 13:43 jcppkkk Status closed => assigned
2014-08-12 13:43 jcppkkk Resolution unable to reproduce => reopened
2014-08-12 13:47 fman Note Added: 0021430
2014-08-12 14:23 jcppkkk Note Edited: 0021429 View Revisions



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker