Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006388TestLinkMigration/Upgrade Testlinkpublic2014-06-13 13:502014-07-27 10:02
Reporterivo.landa 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0006388: Test Suite Assignment to Build presents problems
DescriptionHi everyone,
After to migrate Testnk 1.9.3 to 1.9.10, we realized that the feature: Test Suite Assignment to a Build is presenting problems when the amount of Test Cases on the Test Suite is huge (0000294:0000500 TCs).
The behavior is as follows:
* Selection of all TCs and click to assign.
* The assignment occurs for a part of the selected total.
* The issue is that after that, it is not possible even to assign one by one the pending ones.
Any idea over this issue?

Based on that behavior, we put back to our version 1.9.3 but now, we lose the advances done over last 2 days...is it feasible to use the database of the new version 1.9.10 over the operative environment-site of the old version 1.9.3?

Thanks a lot in advance
Kind Regards,
- Ivo Landa
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0021107)
fman (administrator)
2014-06-14 08:36
edited on: 2014-06-14 08:44

1. issue subject is to general that becomes useless
2. this issue has been reported and solved => is a PHP.INI configuration issue.
regarding POST SIZE
have you checked for similar issue before reporting?


============================================================
- max_input_vars in php.ini = 10000
- Web server stopped and started after ini change
You have to have PHP 5.3.10 or GREATER
============================================================


You can not go back to 1.9.3.

(0021108)
fman (administrator)
2014-06-14 08:46

please apply changes and provide feedback
======================================================================
From forum
Hi mchinery,

We experienced this problem, too. At first, we tried set max_input_vars in php.ini to 5000 and then to 10000 which increased the number of test cases added to the test plan but did not solve the problem.
For us, the solution was to update PHP. You need PHP 5.3.10 or higher.

See Mantis: TestLink 0005953 >> http://mantis.testlink.org/view.php?id=5953#c19788 [^]
==========================================================================

ATTENTION ALSO to .htaccess SETTINGS (thanks to gianmaria)
(0021109)
fman (administrator)
2014-06-14 08:59

Just found note on our README FILE present on each testlink distribution


*** CRITIC PHP.INI Settings ***
max_input_vars, Available since PHP 5.3.9. Default value:1000
If you are going to have test plans with more that 100 test cases, it will be CRITIC
to increase this value in order to avoid issues (CRASH or MALFUNCTIONS) when adding
test cases to test plan.
See:
http://forum.testlink.org/viewtopic.php?f=11&t=7124&p=17284&sid=e3552aca223ac1f6b3676812aa02f04c#p17284 [^]
http://mantis.testlink.org/view.php?id=5372 [^]
(0021312)
fman (administrator)
2014-07-27 10:02

released

- Issue History
Date Modified Username Field Change
2014-06-13 13:50 ivo.landa New Issue
2014-06-14 08:36 fman Note Added: 0021107
2014-06-14 08:44 fman Note Edited: 0021107 View Revisions
2014-06-14 08:44 fman Note View State: 0021107: public
2014-06-14 08:46 fman Note Added: 0021108
2014-06-14 08:46 fman Assigned To => fman
2014-06-14 08:46 fman Status new => feedback
2014-06-14 08:59 fman Note Added: 0021109
2014-06-14 08:59 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-06-14 08:59 fman Status feedback => resolved
2014-06-14 08:59 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2014-06-14 08:59 fman Resolution open => fixed
2014-07-27 10:02 fman Note Added: 0021312
2014-07-27 10:02 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker