Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006370TestLinkTest Specificationpublic2014-06-07 03:332014-07-28 20:33
Reporterhitek_kirilova 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version1.9.11 (2014 Q2 - bug fixing) 
Summary0006370: DB Access Error appear while I try to assign keyword to non existing test case
DescriptionDB Access Error appear while I try to assign keyword to non existing test case.
Steps To Reproduce1. Login to TestLink and navigate to TestSpecification
2. Create a test suite without test cases
3. Create a keyword and click 'Assign to Test cases'
3. Choose different options from the filters - randomly, multiple times
4. Click the 'Apply' button
5. DB Access Error appear
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserGoogle Chrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Capture5.PNG [^] (47,173 bytes) 2014-06-07 03:33

- Relationships
child of 0006313closedfman Availables hot-fixes for 1.9.10 & How To get full fixed package from gitorious 

-  Notes
(0021063)
fman (administrator)
2014-06-07 07:55

Thanks
Good issue report
(0021064)
fman (administrator)
2014-06-07 08:12
edited on: 2014-06-07 08:16

Tested using LATEST CODE FROM GITORIOUS

TC 6370.01
1. Login (user admin with role admin) to TestLink.
2. Create a new test project (FLOWER)
3. Create test suite (TS-100) without test cases
4. Create a keyword (WINTER) and click 'Assign to Test cases'
   you will access a new screen
5. click on left side tree on TS-100
   nothing work happens.
   You get: on right side =>
   There are no Test Cases in this Test Suite => keyword assignment is not possible

6. Click Apply button on filters
   No issue

(0021065)
fman (administrator)
2014-06-07 08:18

IMPORTANT missing detail => You are using Custom Fields
(0021066)
fman (administrator)
2014-06-07 08:20

Tested on demo on test project root => unable to reproduce.
(0021184)
fman (administrator)
2014-06-28 09:57

unfortunately no more user feedback was provided
(0021189)
hitek_kirilova (reporter)
2014-06-29 20:40

1. Login to TestLink as Admin
2. Create a new test project'Hkirilova_testlink2'
3. Create test suite 'SG-U' without test cases
4. Create a keyword 'Stark' and click 'Assign to Test cases'
   you will access'Navigator - Test Specification'
5. Choose 'without keywords' from filters
6. Click Apply
7. DB Access Error appears.
(0021198)
fman (administrator)
2014-06-30 19:44

https://gitorious.org/testlink-ga/testlink-code/commit/df1f84ee18fb31b8339c87d0cbb38a7296ce7a42 [^]

- Issue History
Date Modified Username Field Change
2014-06-07 03:33 hitek_kirilova New Issue
2014-06-07 03:33 hitek_kirilova File Added: Capture5.PNG
2014-06-07 07:55 fman Note Added: 0021063
2014-06-07 08:12 fman Note Added: 0021064
2014-06-07 08:16 fman Note Edited: 0021064 View Revisions
2014-06-07 08:16 fman Note View State: 0021064: public
2014-06-07 08:16 fman Note Edited: 0021064 View Revisions
2014-06-07 08:18 fman Note Added: 0021065
2014-06-07 08:20 fman Note Added: 0021066
2014-06-07 08:20 fman Assigned To => fman
2014-06-07 08:20 fman Status new => feedback
2014-06-28 09:57 fman QA Team - Task Workflow Status => TBD
2014-06-28 09:57 fman Note Added: 0021184
2014-06-28 09:57 fman Status feedback => closed
2014-06-28 09:57 fman Resolution open => unable to reproduce
2014-06-29 20:40 hitek_kirilova Note Added: 0021189
2014-06-29 20:40 hitek_kirilova Status closed => assigned
2014-06-29 20:40 hitek_kirilova Resolution unable to reproduce => reopened
2014-06-30 19:44 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-06-30 19:44 fman Note Added: 0021198
2014-06-30 19:44 fman Status assigned => resolved
2014-06-30 19:44 fman Fixed in Version => 1.9.11 (2014 Q2 - bug fixing)
2014-06-30 19:44 fman Resolution reopened => fixed
2014-06-30 19:44 fman Relationship added child of 0006313
2014-07-28 20:33 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker