Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006321TestLinkReports - Req. Based Reportpublic2014-05-05 10:202014-09-27 16:42
Reportergagliam 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version1.9.12 (2014 Q3) 
Summary0006321: Can't choose options in Requirement Specification Report
DescriptionIn this version there is no longer the option to select:

1) the type of output document (word, openoffice html)
2) The fields that you wish to select and then print (author, body, links to other concrete requirements)

in the window “Requirement Specification Report - Document options”
Steps To Reproduce1) Create a requirement
2) Try to generate Requirement Specification Report - Document options
TagsReport
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesjpg file icon 44.jpg [^] (72,756 bytes) 2014-05-05 11:24


jpg file icon testlink1.9.3 Requirement Spec.JPG [^] (170,281 bytes) 2014-07-23 14:35


patch file icon fix_export_instructions.patch [^] (3,841 bytes) 2014-09-20 01:51 [Show Content]

- Relationships
child of 0006457closedfman Availables hot-fixes for 1.9.11 & How To get full fixed package from gitorious 

-  Notes
(0020943)
fman (administrator)
2014-05-05 20:12

1. Output option has been removed because no real work or oppenoffice document where generated

2. Document content Output options, has been also removed, (same apply to test specification document), trying to make things simpler

Need to understand if in next version can be an option to enable of disable it.
(0021148)
jloutsch (reporter)
2014-06-19 20:38

Hi Fman,

This feature is fairly useless now without being able to choose output, as the formatting goes completely out the window when I copy and paste into a word doc. I think enabling it in the current version is definitely the correct way to go rather than waiting for the next version.
(0021289)
rituraj.s.academic@gmail.com (reporter)
2014-07-23 14:31

Hello fman,

It will be great if a option is provided to the administrator to enable or disable the export button.

Thanks.
(0021290)
rituraj.s.academic@gmail.com (reporter)
2014-07-23 14:35

image testlink 1.9.3 specifies what export method might be needed.
(0021293)
fman (administrator)
2014-07-23 17:17

As stated:
>> 1. Output option has been removed because no real work or oppenoffice
>> document where generated

and will not be reintroduced on next version
(0021295)
rituraj.s.academic@gmail.com (reporter)
2014-07-23 17:31

I totally understand that open office was not working in exports, but Microsoft word export was perfectly working.

is that functionality also deprecated?
(0021296)
fman (administrator)
2014-07-23 18:08

As stated:
>> 1. Output option has been removed because no real word or oppenoffice
>> document where generated

this means ONLY HTML.
(0021595)
fman (administrator)
2014-09-13 07:25

Added again COMBO BOX to select output type:
HTML
PSEUDO WORD
(0021596)
fman (administrator)
2014-09-13 07:27

https://gitorious.org/testlink-ga/testlink-code/commit/7351ba69003d8767d75b149773618725183ad27c [^]
(0021638)
twelveeighty (reporter)
2014-09-19 21:01

Hey, @fman, thanks for the patch. I tested it and it works. I took the liberty of updating the instructions in the en_GB file, since they weren't really correct (you have to first pick the format and then click the node to generate). I'm not sure how I can send you this - here is the patch (let me know if you want me to email you this instead).
===============
---
 locale/en_GB/strings.txt | 6 +++---
 locale/en_GB/texts.php | 19 +++++++++----------
 2 files changed, 12 insertions(+), 13 deletions(-)

diff --git a/locale/en_GB/strings.txt b/locale/en_GB/strings.txt
index 9755f4d..dd00cec 100644
--- a/locale/en_GB/strings.txt
+++ b/locale/en_GB/strings.txt
@@ -2134,8 +2134,8 @@ $TLS_testsuite_is_empty = 'Test suite has no test cases. Nothing can be done';
 
 
 // ----- gui/templates/printDocOptions.tpl -----
-$TLS_doc_opt_title = 'Document options';
-$TLS_doc_opt_guide = 'Click on tree root to generate full doc, or an specific folder for branch doc ';
+$TLS_doc_opt_title = 'Generate Document';
+$TLS_doc_opt_guide = 'Pick your desired format and then select either the top level Project node or a Requirement Specification node in the tree';
 
 $TLS_tr_td_show_as = "Show as";
 $TLS_check_uncheck_all_options = "check / uncheck all";
@@ -3830,4 +3830,4 @@ $TLS_demo_usage = "This is a DEMO SITE, use it with RESPECT.
" .
                   "Site will be re-installed at randmon intervals WITHOUT warning.
" .
                   "All data will be deleted at each install.
" .
                   "If you find TestLink useful think about supporting our work
";
-// ----- END ------------------------------------------------------------------
\ No newline at end of file
+// ----- END ------------------------------------------------------------------
diff --git a/locale/en_GB/texts.php b/locale/en_GB/texts.php
index 74acec0..077dccb 100644
--- a/locale/en_GB/texts.php
+++ b/locale/en_GB/texts.php
@@ -26,9 +26,9 @@
 
 // --------------------------------------------------------------------------------------
 $TLS_htmltext_title['error'] = "Application error";
-$TLS_htmltext['error'] = "

Unexpected error happens. Please check event viewer or " .
+$TLS_htmltext['error'] = "

An unexpected error happened. Please check the event viewer or " .
                "logs for details.

You are welcome to report the problem. Please visit our " .
- "<a href='http://www.teamst.org'>website</a>. [^]

";
+ "<a href='http://www.testlink.org'>website</a>. [^]

";
 
 
 
@@ -215,19 +215,18 @@ with name defined in configuration (default is: \$tlCfg->req_cfg->default_tes
 // ------------------------------------------------------------------------------------------
 $TLS_htmltext_title['printReqSpec'] = "Print Requirement Specification"; //printReq
 $TLS_htmltext['printReqSpec'] = "<h2>Purpose:</h2>
-

You can generate document with the requirements within a requirement specification,
-or all the requirements in a test project.


-<h2>Get Started:</h2>
+

Use this page to generate a document for a single requirement specification,
+or all the specifications in the project.


+<h2>Instructions:</h2>
 

    -

  1. -

    Select the parts of the requirements you want to display, and then click on a
    -requirement specification, or the test project. A printable page will be displayed.


    -

  2.  
  3. Use the \"Show As\" drop-box in the navigation pane to specify whether you want
    -the information displayed as HTML, or in a Pseudo Micosoft Word document.
    +the information rendered as HTML, or as a Micosoft Word document.
     See <span class=\"help\" onclick=\"javascript:open_help_window('printFilter',
     '{$locale}');\">help</span> for more information.


     

  4. +

  5. +

    In the tree, select a requirement specification, or the top-level project. A printable page will be displayed.


    +

  6.  
  7. Use your browser's print functionality to actually print the information.

     Note: Make sure to only print the right-hand frame.


     

  8. --
    2.1.0
(0021641)
fman (administrator)
2014-09-19 21:06

Please provide full files, it will be a lot easier to update.
in the future if you want to provide patches, please provide it as attachment not as notes.

regards
(0021642)
twelveeighty (reporter)
2014-09-20 01:52

Yeah - I didn't see the upload button - thought it was locked out or something and I couldn't edit my previous comment.

Anyway, I've attached the patch instead.
(0021643)
twelveeighty (reporter)
2014-09-20 16:58

Actually - I just now noticed that I missed a couple of typos in en_GB/texts.php: can you s/Micosoft/Microsoft in there? I can get you a patch too, if needed.
(0021695)
fman (administrator)
2014-09-27 16:42

Release done

- Issue History
Date Modified Username Field Change
2014-05-05 10:20 gagliam New Issue
2014-05-05 11:24 gagliam File Added: 44.jpg
2014-05-05 20:12 fman Note Added: 0020943
2014-06-19 20:38 jloutsch Note Added: 0021148
2014-07-23 14:30 rituraj.s.academic@gmail.com Tag Attached: Report
2014-07-23 14:31 rituraj.s.academic@gmail.com Note Added: 0021289
2014-07-23 14:35 rituraj.s.academic@gmail.com File Added: testlink1.9.3 Requirement Spec.JPG
2014-07-23 14:35 rituraj.s.academic@gmail.com Note Added: 0021290
2014-07-23 17:17 fman Note Added: 0021293
2014-07-23 17:31 rituraj.s.academic@gmail.com Note Added: 0021295
2014-07-23 18:08 fman Note Added: 0021296
2014-09-13 07:25 fman Note Added: 0021595
2014-09-13 07:25 fman QA Team - Task Workflow Status => TBD
2014-09-13 07:25 fman Fixed in Version => 1.9.12 (2014 Q3)
2014-09-13 07:27 fman Note Added: 0021596
2014-09-13 07:27 fman Status new => resolved
2014-09-13 07:27 fman Resolution open => fixed
2014-09-13 07:27 fman Assigned To => fman
2014-09-13 07:27 fman Relationship added child of 0006457
2014-09-19 21:01 twelveeighty Note Added: 0021638
2014-09-19 21:06 fman Note Added: 0021641
2014-09-20 01:51 twelveeighty File Added: fix_export_instructions.patch
2014-09-20 01:52 twelveeighty Note Added: 0021642
2014-09-20 16:58 twelveeighty Note Added: 0021643
2014-09-27 16:42 fman Note Added: 0021695
2014-09-27 16:42 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker