Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006318TestLinkTest Plan - Add/Remove Platformspublic2014-04-29 11:092014-07-28 20:33
ReporterRab 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.11 (2014 Q2 - bug fixing) 
Summary0006318: "Add / Remove Platforms" link does nothing
Descriptionwhen a user has no rights for platform management, they are still presented with the link on the right hand side under "Test Plan contents" to "Add / Remove Platforms".

Clicking the link does nothing, but there is an event generated:
User 'XXXXX' has insufficient rights for 'any' action on 'platformsAssign.php'. Exit forced
Steps To ReproduceCreate user with no platform management roles. Login with user. Link is visible on screen. Clicking link generates the event.
Additional InformationWhat should happen here? I can see a case for having platform management by a senior and allowing a junior to assign platforms to a test. But the two seemed to be linked by the same user permission.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browserchrome and firefox
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006313closedfman Availables hot-fixes for 1.9.10 & How To get full fixed package from gitorious 

-  Notes
(0020923)
fman (administrator)
2014-04-29 17:25
edited on: 2014-04-29 17:28

1. update to 1.9.10 and retest
2. provide a clear step by step to reproduce
i.e.
2.1 create test project TPRJ1
2.2 create user U01 with role with this grants ...
2.3 create user U02 with role with this grants ...
and so on

(0020925)
fman (administrator)
2014-04-29 17:31

No specific right exists to cope with your request.
A new fine grain grant is needed.

Anyway issue subject is no good, because the system is doing right thing when to try to access feature.
What is wrong is that this link exists there.
(0020926)
fman (administrator)
2014-04-29 18:56
edited on: 2014-04-29 18:58

>> when a user has no rights for platform management,
>> they are still presented with the link on
>> the right hand side under "Test Plan contents" to "Add / Remove Platforms".

You are not telling the whole story.
In order to view this link user role has to have following right:

testplan_add_remove_platforms

Issue is that check on feature (when you click the link) requires two grants in AND mode and one is wrong.

(0020927)
fman (administrator)
2014-04-29 19:00

To solve this you have to replace on platformsAssign.php
the function checkRights, with this


function checkRights(&$db,&$user)
{
  return $user->hasRight($db,'testplan_add_remove_platforms');
}

- Issue History
Date Modified Username Field Change
2014-04-29 11:09 Rab New Issue
2014-04-29 17:25 fman Note Added: 0020923
2014-04-29 17:28 fman Note Edited: 0020923 View Revisions
2014-04-29 17:31 fman Note Added: 0020925
2014-04-29 18:56 fman Note Added: 0020926
2014-04-29 18:57 fman Note View State: 0020926: public
2014-04-29 18:58 fman Note Edited: 0020926 View Revisions
2014-04-29 19:00 fman Note Added: 0020927
2014-04-29 19:00 fman QA Team - Task Workflow Status => TBD
2014-04-29 19:04 fman PHP Version not sure, using Bitnami Testlink distro 1.9.9 =>
2014-04-29 19:04 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-04-29 19:04 fman Status new => resolved
2014-04-29 19:04 fman Fixed in Version => 1.9.11 (2014 Q2 - bug fixing)
2014-04-29 19:04 fman Resolution open => fixed
2014-04-29 19:04 fman Assigned To => fman
2014-04-29 19:32 fman Relationship added child of 0006313
2014-07-28 20:33 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker