Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006314TestLinkExport/Importpublic2014-04-25 20:022016-06-25 16:28
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.10 (2014 Q1 - bug fixing) 
Fixed in Version1.9.11 (2014 Q2 - bug fixing) 
Summary0006314: Export TestPlan XML with FULL Testcase External ID to permit TO THIRD PARTY TOOL generation of Execution Result XML file
DescriptionIn a TestLink XML testplan export :
- testproject is defined by "name" and "internal_id".
- testcase is defined by a number (called "externalid") and others fields
As an example, file "ExportTestPlanExample.xml" is a file generated by "Test Plan Export".


To import results into TestLink, XML file must provide "external_id" to identify each testcase.
"external_id" is the concatenation of the testproject "prefix" and the "externalid"
As an example, file "ImportTestsPlanExecResultsIntoTestLink.xml" is a file that match the XML format used to import results into TestLink.


Because the "external_id" or the "prefix" information are not provided by the TestLink testplan export, it is not possible to generate a file that respect XML import Format from a third part tool that handles TestPlan Export.
Additional Informationhttps://gitorious.org/testlink-ga/testlink-code/merge_requests/13 [^] is a merge request that provide the way to add the prefix information in the XML Test Plan Export

An other way to fix the problem should be to export the external_id information for each testcase in the Test Plan Export XML file.
TagsNo tags attached.
Database (MySQL,Postgres,etc)All (Tested with MySQL)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon ExportTestPlanExample.xml [^] (1,585 bytes) 2014-04-25 20:02
xml file icon ImportTestsPlanExecResultsIntoTestLink.xml [^] (340 bytes) 2014-04-25 20:02

- Relationships
related to 0007609closedfman Unable to update existant testcase data from XML file if detection is done with External ID containing prefix 
child of 0006313closedfman Availables hot-fixes for 1.9.10 & How To get full fixed package from gitorious 

-  Notes
(0020901)
fman (administrator)
2014-04-27 15:29

On 1.9.10 a new option : export for results import has been provided.
Please check if this new option cover this issue (IMHO answer is yes).
(0020902)
Mr.Bricodage (updater)
2014-04-27 15:58

I'm sorry but IMHO, the answer is No.
The new export provide the following information :
    <testcase external_id="pro-17">
        <result>X</result>
        <notes>test link rocks </notes>
        <tester>put login here</tester>
        <!-- if not present now() will be used -->
        <timestamp>YYYY-MM-DD HH:MM:SS</timestamp>
        <bug_id>put your bug id here</bug_id>
    </testcase>

The external_id is provided in this export (and that is a good thing because it's needed during import), but the test content is not exported.


The need is to provide the external_id with all information needed to execute the test ("Export Test Plan"). Right now, the external_id is not provided by TL 1.9.10 in the export :
<testcase internalid="90" name="A first TestCase">
    <node_order><![CDATA[1]]></node_order>
    <externalid><![CDATA[14]]></externalid>
    <version><![CDATA[1]]></version>
    <summary><![CDATA[The summary of the First TestCase]]></summary>
    <preconditions><![CDATA[]]></preconditions>
    <execution_type><![CDATA[1]]></execution_type>
    <importance><![CDATA[1]]></importance>
    <estimated_exec_duration>5.00</estimated_exec_duration>
    <status>1</status>
<steps>
<step>
    <step_number><![CDATA[1]]></step_number>
    <actions><![CDATA[The first Step]]></actions>
    <expectedresults><![CDATA[Expected result for the first step]]></expectedresults>
    <execution_type><![CDATA[1]]></execution_type>
</step>

<step>
    <step_number><![CDATA[2]]></step_number>
    <actions><![CDATA[A second Step]]></actions>
    <expectedresults><![CDATA[And an expected result for the second step]]></expectedresults>
    <execution_type><![CDATA[1]]></execution_type>
</step>
</steps>
</testcase>
(0020903)
fman (administrator)
2014-04-27 16:04
edited on: 2014-04-27 16:08

Issue summary said: ... to permit Execution Result XML file generation

result file does not require nothing more that what is generated with new feature.

Then your request is different a related EXCLUSIVELY to the use of Third Party tools.
OK this is mentioned in following sentence:
Because the "external_id" or the "prefix" information are not provided by the TestLink testplan export, it is not possible to generate a file that respect XML import Format from a third part tool that handles TestPlan Export.

I will change issue summary to reflect this important missin info 'THAT IS REQUIRED BY A THIRD PARTY TOOL', an then this is some kind of 'FEATURE REQUEST' and not an issue.

Side Effect ?
Check on import feature that use this export (if feature exists) need to be done to be sure that this change to this export format, will not create an issue on import.

(0020905)
fman (administrator)
2014-04-27 16:21

https://gitorious.org/testlink-ga/testlink-code/commit/378d419ae94b6cb8fe2384181190c6567ce54a99 [^]
(0020906)
Mr.Bricodage (updater)
2014-04-27 16:31
edited on: 2016-06-25 16:28

"Side Effect ?
Check on import feature that use this export (if feature exists) need to be done to be sure that this change to this export format, will not create an issue on import."
feature exists (Excel macro file 03-, see http://mantis.testlink.org/view.php?id=4945 [^]). Already tested with code provided in https://gitorious.org/testlink-ga/testlink-code/merge_requests/13. [^]

"https://gitorious.org/testlink-ga/testlink-code/commit/378d419ae94b6cb8fe2384181190c6567ce54a99" [^] : Thank you

(Github
https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/378d419ae94b6cb8fe2384181190c6567ce54a99 [^])


- Issue History
Date Modified Username Field Change
2014-04-25 20:02 Mr.Bricodage New Issue
2014-04-25 20:02 Mr.Bricodage File Added: ExportTestPlanExample.xml
2014-04-25 20:02 Mr.Bricodage File Added: ImportTestsPlanExecResultsIntoTestLink.xml
2014-04-27 15:29 fman Note Added: 0020901
2014-04-27 15:29 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-04-27 15:29 fman Status new => resolved
2014-04-27 15:29 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-04-27 15:29 fman Resolution open => no change required
2014-04-27 15:29 fman Assigned To => fman
2014-04-27 15:58 Mr.Bricodage Note Added: 0020902
2014-04-27 16:04 fman Note Added: 0020903
2014-04-27 16:06 fman Severity major => feature request
2014-04-27 16:06 fman Summary Export TestPlan XML Format doesn't provide required information to permit Execution Result XML file generation => Export TestPlan XML with FULL Testcase External ID to permit TO THIRD PARTY TOOL generation of Execution Result XML file
2014-04-27 16:06 fman Note Edited: 0020903 View Revisions
2014-04-27 16:08 fman Note Edited: 0020903 View Revisions
2014-04-27 16:21 fman Status resolved => assigned
2014-04-27 16:21 fman Note Added: 0020905
2014-04-27 16:21 fman Status assigned => resolved
2014-04-27 16:21 fman Fixed in Version 1.9.10 (2014 Q1 - bug fixing) => 1.9.11 (2014 Q2 - bug fixing)
2014-04-27 16:22 fman Resolution no change required => fixed
2014-04-27 16:22 fman Relationship added child of 0006313
2014-04-27 16:31 Mr.Bricodage Note Added: 0020906
2014-07-28 20:33 fman Status resolved => closed
2016-06-23 14:08 Mr.Bricodage Relationship added related to 0007609
2016-06-25 16:28 fman Note Edited: 0020906 View Revisions



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker