Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006303TestLinkCustom fieldspublic2014-04-18 10:062014-04-25 17:38
Reporterspacomp 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006303: Facility for linking the Custom field to Builds only
DescriptionWhen we create Custom Fields, we have option to link to -

1. Test Suite
2. Test Plan
3. Test Case
4. Requirements Specification &
5. Requirements

We have a requirement of custom field to be tagged with BUILDs that are executed,

Typical custom fields are as follow -

1. Multi selection Drop down list with details of Registered Users

I.e. Name of the owner of the build, who would have integrated it for further integration at the client's place. We would be interested in fetching the details from the Registered Users of TESTLINK instance

2. Other can typically a Geographical Region where in the version of software shall be applicable and


TagsNo tags attached.
Database (MySQL,Postgres,etc)MY SQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon Custom fields for Builds.JPG [^] (32,479 bytes) 2014-04-18 10:06

- Relationships
child of 0006048closedfman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 

-  Notes
(0020744)
fman (administrator)
2014-04-18 17:34
edited on: 2014-04-18 17:41

>> We would be interested in fetching the details
>> from the Registered Users of TESTLINK instance

as you can understand your requirement is not clear expressed on issue subject.
Because having custom fields for Builds is a thing, and having this kind of special CF is a completely different one.

on 1.9.10 (next release) CF for builds will be available.
You can get latest code from gitorious and test it

What is the usefulness of the image you have uploaded?

(0020747)
fman (administrator)
2014-04-18 17:48

Standard Custom fields will be available for Builds and displayed on EXECUTION FEATURE
(0020748)
fman (administrator)
2014-04-18 17:54

IMPORTANT NOTICE:
Cortado (http://www.cortado.com [^]) has sponsored this development and allowing this feature be available for all users.
It will be great if other companies follow cortado example, supporting TestLink development
(0020806)
fman (administrator)
2014-04-25 17:38

1.9.10 released

- Issue History
Date Modified Username Field Change
2014-04-18 10:06 spacomp New Issue
2014-04-18 10:06 spacomp File Added: Custom fields for Builds.JPG
2014-04-18 17:34 fman Note Added: 0020744
2014-04-18 17:41 fman QA Team - Task Workflow Status => TBD
2014-04-18 17:41 fman Summary Facility for linking the Custom filed to Builds only => Facility for linking the Custom field to Builds only
2014-04-18 17:41 fman Note Edited: 0020744 View Revisions
2014-04-18 17:48 fman Note View State: 0020744: public
2014-04-18 17:48 fman Note Added: 0020747
2014-04-18 17:49 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-04-18 17:49 fman Status new => resolved
2014-04-18 17:49 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-04-18 17:49 fman Resolution open => fixed
2014-04-18 17:49 fman Assigned To => fman
2014-04-18 17:54 fman Note Added: 0020748
2014-04-19 08:11 fman Relationship added child of 0006048
2014-04-25 17:38 fman Note Added: 0020806
2014-04-25 17:38 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker