Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006275TestLinkAssign Test Case Executionpublic2014-03-31 19:402014-07-27 10:02
Reporteranthony.rizzolo 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0006275: On 1.9.7 Testlink when I add steps to a test case it deletes all the information and custom fields
DescriptionWhen I have created a test case with information and custom fields, if I then go to create steps for the test case, once I complete it and click save and exit, all my custom tags and information is gone.
Steps To Reproduce1. Create a test case in testlink
2. Enter information in the custom fields
3. Click Save
4. Click Create Step
5. Create a couple of steps for the test case
6. Click save and exit

Notice that all the information from the custom fields is now clear.
a
TagsNo tags attached.
Database (MySQL,Postgres,etc)Not sure
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0020643)
fman (administrator)
2014-03-31 19:45

as you can see you can not report anymore issues on 1.9.7 (version is not present on combo to choose version).
Because 1.9.9 has been released, I only work on issues that are present on 1.9.9.

My suggestion is:
1. get latest code from gitoriuos (will be next stable release) from branch 1.9
2. retest if you can reproduce provide feedback

till we provide feedback, no action will be taken
(0020645)
anthony.rizzolo (reporter)
2014-03-31 19:52

Thanks for your quick response.

This is a production environment so I can't just update to the latest stable release branch.

Wouldn't you normally verify if the issue is present in the current release and either mark it as fixed if it is, or fix it if it is not. I did check to make sure that there is not an identical issue in the bug database already.
(0020646)
fman (administrator)
2014-03-31 19:58

You do not need to install on your production environment, just do a fresh install on a sandbox.
Unfortunately I've not time enough to do this kind of test, that's why I ask for help to people that have the issue, in order to decrease amount of work on dev team.
Dev Team and users work this way help each other.
Will wait for your feedback
(0020648)
fman (administrator)
2014-03-31 20:32

you can do same tests on demo.testlink.org
(0020650)
anthony.rizzolo (reporter)
2014-04-01 00:36

Thank you so much for the help and the link.

I just created an account on demo.testlink.org and it has me as "guest". Is there a procedure for elevating my level so that I can create a project and try to duplicate the problem on that machine.

Thanks,
Anthony Rizzolo
(0020651)
fman (administrator)
2014-04-01 05:18

do not use a new user, just use admin/admin
(0020653)
Reinhold Bentele (reporter)
2014-04-01 07:24
edited on: 2014-04-01 07:29

We have the same problem on our installation of 1.9.7. Just found out that this is fixed in 1.9.8 (Issue 0006168). So I guess this issue can be closed as Duplicate.

(0020655)
anthony.rizzolo (reporter)
2014-04-01 11:49

Thank you Reinhold, I will ask our operations folks to upgrade to 1.9.8 or the latest release. I was trying to duplicate the problem in 1.9.9 and was not able to so thought it might be fixed.
(0021313)
fman (administrator)
2014-07-27 10:02

released

- Issue History
Date Modified Username Field Change
2014-03-31 19:40 anthony.rizzolo New Issue
2014-03-31 19:45 fman Note Added: 0020643
2014-03-31 19:45 fman Status new => feedback
2014-03-31 19:52 anthony.rizzolo Note Added: 0020645
2014-03-31 19:52 anthony.rizzolo Status feedback => new
2014-03-31 19:58 fman Note Added: 0020646
2014-03-31 20:32 fman Note Added: 0020648
2014-04-01 00:36 anthony.rizzolo Note Added: 0020650
2014-04-01 05:18 fman Note Added: 0020651
2014-04-01 07:24 Reinhold Bentele Note Added: 0020653
2014-04-01 07:29 Reinhold Bentele Note Edited: 0020653 View Revisions
2014-04-01 09:11 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-04-01 09:11 fman Status new => resolved
2014-04-01 09:11 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2014-04-01 09:11 fman Resolution open => fixed
2014-04-01 09:11 fman Assigned To => fman
2014-04-01 11:49 anthony.rizzolo Note Added: 0020655
2014-07-27 10:02 fman Note Added: 0021313
2014-07-27 10:02 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker