Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006259TestLinkReports - Test report matrixpublic2014-03-23 09:172014-03-26 12:39
Reporterfman 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006259: Test report matrix - Spreadsheet output - display more info that on HTML output
DescriptionIMHO layout used to display on web broswer can contain less information in order to avoi screen clutter.
But because users always want more and more info, choice is provide additional info on the spreadsheet output format (execution date, tester and execution notes)


See attached images and sample XLS
TagsNo tags attached.
Database (MySQL,Postgres,etc)N/A
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon test-result-matrix-web.png [^] (47,363 bytes) 2014-03-23 09:17


png file icon test-matrix-xls.png [^] (33,439 bytes) 2014-03-23 09:17


xls file icon resultsTC_AAQ_ddd-4.xls [^] (7,680 bytes) 2014-03-23 09:18
jpg file icon Excel-Execution Notes.JPG [^] (13,438 bytes) 2014-03-25 23:55

- Relationships
child of 0006048closedfman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 

-  Notes
(0020610)
fman (administrator)
2014-03-23 09:22

https://gitorious.org/testlink-ga/testlink-code/commit/a2010cf3cf7b832a0a6a425dab61d084cde6b0bd [^]
(0020611)
hmah (reporter)
2014-03-24 16:56
edited on: 2014-03-24 16:56

@Fman
Thanks for this.
IMHO adding execution duration column on the spreadsheet will be intresting too.

(0020612)
fman (administrator)
2014-03-24 19:08

execution duration added
(0020613)
fman (administrator)
2014-03-24 19:10

https://gitorious.org/testlink-ga/testlink-code/commit/9b2e1a78cde065016d346043b2477754bd1aa707 [^]
(0020632)
hmah (reporter)
2014-03-25 23:47
edited on: 2014-03-25 23:55

I've tested it and it works ok the only thing I noticed is that the note execution is still in html format and contains some none desired symbols like tabulation as shown in the attached image.

(0020633)
fman (administrator)
2014-03-26 07:07

>> thing I noticed is that the note execution is still in html format
spreadsheet export is not intended to be WYSIWYG, if you have added (or the webeditor) some formatting that can be rendered by default on browser, rendering will not be honered on this export.
(0020636)
hmah (reporter)
2014-03-26 12:15

There is something I omited to say is that I'm using ckeditor fore note execution:
$tlCfg->gui->text_editor['execution'] = array('type' => 'ckeditor','toolbar' => 'TestlinkMini','configFile' => 'cfg/tl_ckeditor_config.js', 'height' => 200);

the note execution rendering is OK witout any text editor :
$tlCfg->gui->text_editor['execution'] = array( 'type' => 'none');

So do you think it's on issue rather than browser formating because I didn't find any problem in that side.
PS:
I'm using MsExcel 2010
(0020638)
fman (administrator)
2014-03-26 12:39

answer still is the same provided on note (0020633)
export will not do formatting on excel.
issue is closed.

- Issue History
Date Modified Username Field Change
2014-03-23 09:17 fman New Issue
2014-03-23 09:17 fman Status new => assigned
2014-03-23 09:17 fman Assigned To => fman
2014-03-23 09:17 fman File Added: test-result-matrix-web.png
2014-03-23 09:17 fman File Added: test-matrix-xls.png
2014-03-23 09:18 fman Description Updated View Revisions
2014-03-23 09:18 fman File Added: resultsTC_AAQ_ddd-4.xls
2014-03-23 09:19 fman Relationship added child of 0006048
2014-03-23 09:22 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-03-23 09:22 fman Note Added: 0020610
2014-03-23 09:22 fman Status assigned => resolved
2014-03-23 09:22 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-03-23 09:22 fman Resolution open => fixed
2014-03-24 16:56 hmah Note Added: 0020611
2014-03-24 16:56 hmah Note Edited: 0020611 View Revisions
2014-03-24 19:08 fman Note Added: 0020612
2014-03-24 19:10 fman Note Added: 0020613
2014-03-25 23:47 hmah Note Added: 0020632
2014-03-25 23:55 hmah File Added: Excel-Execution Notes.JPG
2014-03-25 23:55 hmah Note Edited: 0020632 View Revisions
2014-03-26 07:07 fman Note Added: 0020633
2014-03-26 12:15 hmah Note Added: 0020636
2014-03-26 12:39 fman Note Added: 0020638
2014-03-26 12:39 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker