Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006255TestLinkRequirement to Test Case Assignmentpublic2014-03-18 18:262014-09-27 16:42
Reportergnustavo 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSRHELOS Version6.4
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.12 (2014 Q3) 
Summary0006255: Requirements Bulk Assignment does not respect Test Case filter
DescriptionWhen I perform a Requirements Buld Assignment with a Test Case filter enabled the requirements are assigned to all Test Cases below the selected Test Suite and not just to the Test Cases matching the current filter.

This is counter intuitive and the Test Case filter ends up being useless in this context.
Steps To Reproduce* Click Assign Requirements
* Apply a filter to the Test Case tree so that some test cases are filtered out from a Test Suite.
* Select the Test Suite.
* Note that on the right panel the message says that "This operation will assign selected requirements to (maximun number of) N test cases" where N is the number of all test cases below the selected Test Suite and not the number of the Test Cases matching the current filter.
* Select one Requirement.
* Click Assign.
* Note that all N test cases where assigned to the requirement and not just the test cases matching the current filter.
Additional InformationI'm unable to confirm this behaviour on TestLink 1.9.9 because I don't have it installed.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browserany
PHP Version5.3.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0006457closedfman Availables hot-fixes for 1.9.11 & How To get full fixed package from gitorious 

-  Notes
(0021692)
fman (administrator)
2014-09-27 16:42

Release done

- Issue History
Date Modified Username Field Change
2014-03-18 18:26 gnustavo New Issue
2014-09-22 20:18 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-09-22 20:18 fman Status new => resolved
2014-09-22 20:18 fman Fixed in Version => 1.9.12 (2014 Q3)
2014-09-22 20:18 fman Resolution open => fixed
2014-09-22 20:18 fman Assigned To => fman
2014-09-22 20:18 fman Relationship added child of 0006457
2014-09-22 20:34 fman Issue cloned: 0006591
2014-09-27 16:42 fman Note Added: 0021692
2014-09-27 16:42 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker