Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006250TestLinkUsers and Rightspublic2014-03-13 20:162014-04-25 17:38
Reportergnustavo 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006250: Cannot set new rights after upgrade to 1.9.8
DescriptionIt seems that issue 0005746 was closed but not fixed. I tried to comment on it but couldn't find a way. I assume I cannot comment on closed issues, so I'm opening a new one. Sorry if this isn't the correct protocol.

I've upgraded from TestLink 1.9.4 to 1.9.8 and noticed that I couldn't change some specific rights on specific roles. This is exactly the problem reported on 0005746, which was closed with a message implying that the bug had been fixed on TL 1.9.8.

However, it doesn't seem to have been. I had to make the following adjustments in the database (MySQL) by hand to fix it:

insert into rights (id,description) values (35,'exec_edit_notes');
insert into rights (id,description) values (36,'exec_delete');
insert into rights (id,description) values (37,'testplan_unlink_executed_testcases');
insert into rights (id,description) values (38,'testproject_delete_executed_testcases');
insert into rights (id,description) values (39,'testproject_edit_executed_testcases');
insert into role_rights (role_id,right_id) values (8,35);
insert into role_rights (role_id,right_id) values (8,36);
insert into role_rights (role_id,right_id) values (8,37);
insert into role_rights (role_id,right_id) values (8,38);
insert into role_rights (role_id,right_id) values (8,39);

These SQL statements should be present on the database upgrade scripts on lib/sql/alter_tables/1.9.*/*/DB*/step1/db_schema_update.sql but I coudn't find them.

It seems they aren't there on TL 1.9.9 also...
Steps To ReproduceThe same reported on 0005746.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0005746closedfman Cannot set new rights after upgrade 
child of 0006048closedfman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 

-  Notes
(0020577)
fman (administrator)
2014-03-13 21:16
edited on: 2014-03-13 21:26

Issue has been fixed in this way:
Fresh install of 1.9.8 has all needed records.
I suppose a better explanation was needed explained the resolution
Solution was: on 1.9.7 some records were missing, then they were added on 1.9.8 COMPLETE INSTALL => the issue will not be present on 1.9.8.


Fresh install of 1.9.9 has all records, and because is supposed that upgrade to 1.9.9 is done from an 1.9.8, there is no need to provide this inserts.

Remember we request manual and incremental upgrade from one minor version to the next one.


May be adding the missing inserts is needed on 1.9.8, avoid the issue.

(0020578)
fman (administrator)
2014-03-13 21:27

>> I assume I cannot comment on closed issues, so I'm opening a new one. Sorry if >> this isn't the correct protocol.
you can try to reopen it
(0020579)
fman (administrator)
2014-03-13 21:28

Do not use 1.9.8, when a newer stable release exists.
(1.9.9 with latest fixes)
(0020580)
gnustavo (reporter)
2014-03-14 11:22

I upgraded from 1.9.4 to 1.9.8. I had to postpone the upgrade to 1.9.9 because it requires PHP > 5.4 but I'm using CentOS 6.5 which still ships PHP 5.3.3. Going to 1.9.8 was easier and already brought most of the fixes and improvements since 1.9.4.

As for the upgrade procedure, I followed the instructions under the "Automatic upgrading with DB schema changes" section of the Installation Manual and applied the SQL upgrade scripts for 1.9.6 and 1.9.8. I understood that this should bring the database to the 1.9.8 level. But since those records are missing the upgrade wasn't complete. Shouldn't those records have been inserted by the SQL upgrade scripts?
(0020584)
fman (administrator)
2014-03-14 19:16

https://gitorious.org/testlink-ga/testlink-code/commit/60d6ea1ef2f3c510669a5ec61038307bc43a9a3f [^]
(0020585)
gnustavo (reporter)
2014-03-14 19:27

Great! Thanks.
(0020817)
fman (administrator)
2014-04-25 17:38

1.9.10 released

- Issue History
Date Modified Username Field Change
2014-03-13 20:16 gnustavo New Issue
2014-03-13 21:16 fman Note Added: 0020577
2014-03-13 21:17 fman Note View State: 0020577: public
2014-03-13 21:22 fman Note Edited: 0020577 View Revisions
2014-03-13 21:24 fman Note Edited: 0020577 View Revisions
2014-03-13 21:25 fman Note Edited: 0020577 View Revisions
2014-03-13 21:26 fman Note Edited: 0020577 View Revisions
2014-03-13 21:27 fman Note Added: 0020578
2014-03-13 21:27 fman Relationship added related to 0005746
2014-03-13 21:28 fman Note Added: 0020579
2014-03-13 21:29 fman QA Team - Task Workflow Status => TBD
2014-03-14 11:22 gnustavo Note Added: 0020580
2014-03-14 19:15 fman Summary Cannot set new rights after upgrade => Cannot set new rights after upgrade to 1.9.8
2014-03-14 19:16 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-03-14 19:16 fman Note Added: 0020584
2014-03-14 19:16 fman Status new => resolved
2014-03-14 19:16 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-03-14 19:16 fman Resolution open => fixed
2014-03-14 19:16 fman Assigned To => fman
2014-03-14 19:16 fman Relationship added child of 0006048
2014-03-14 19:27 gnustavo Note Added: 0020585
2014-04-25 17:38 fman Note Added: 0020817
2014-04-25 17:38 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker