Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006218TestLinkReportspublic2014-02-19 15:202014-04-25 17:38
ReporterMoulin Agora 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006218: Report Metrics Dashboard - Test Project Progress Section is always empty
DescriptionWhen I click on "Metrics Dashboard", no report is product.

The index page is dislayed with only topMenu and list-box of project.
Steps To Reproduceclick on "Metrics Dashboard"
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
BrowserIE8 or Firefox
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon PJ_6218.odt [^] (71,754 bytes) 2014-02-26 14:57

- Relationships
related to 0006223closedfman Metrics dashboard doesn't show up 
child of 0006048closedfman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 

-  Notes
(0020466)
Moulin Agora (reporter)
2014-02-19 15:24

php 5.3.8
(0020471)
fman (administrator)
2014-02-22 20:00

Unfortunately very clear and detailed steps to reproduce where not provided.
give a look to forum where a clear explanation regarding what kind of info and what is the level of details has been provided. Without this info only possible action will be close - unable to reproduce
(0020479)
Moulin Agora (reporter)
2014-02-26 15:00

I select a testproject with testplan.
I select a testplan with execution testcases.
I click on "Metrics Dashboard" in block "test execution".
The screen displayed is blank with only the navbar.
See thie file join.
(0020483)
fman (administrator)
2014-02-26 18:31

Give a look to related issue
(0020502)
Moulin Agora (reporter)
2014-02-28 06:51

I think I solved this issue, by changing code in "gui/tepmplates/results/metricsDashboard.tpl" file, on line 22 and 25.

The problem is that variable, between double cote, are not interpreted.

To solve it, remove double cote :

{assign var="tplan_metric" value="$gui->tplan_metrics"} => {assign var="tplan_metric" value=$gui->tplan_metrics}


{foreach key="key" item="value" from="$gui->project_metrics"} => {foreach key="key" item="value" from=$gui->project_metrics}
(0020504)
fman (administrator)
2014-02-28 14:58

Great!
(0020517)
fman (administrator)
2014-03-04 14:00

https://gitorious.org/testlink-ga/testlink-code/commit/7fc87914ade5d9d1d2d662082210ad5a719a70ee [^]
(0020825)
fman (administrator)
2014-04-25 17:38

1.9.10 released

- Issue History
Date Modified Username Field Change
2014-02-19 15:20 Moulin Agora New Issue
2014-02-19 15:24 Moulin Agora Note Added: 0020466
2014-02-22 20:00 fman Note Added: 0020471
2014-02-26 14:57 Moulin Agora File Added: PJ_6218.odt
2014-02-26 15:00 Moulin Agora Note Added: 0020479
2014-02-26 18:30 fman Relationship added related to 0006223
2014-02-26 18:31 fman Note Added: 0020483
2014-02-26 18:31 fman Assigned To => fman
2014-02-26 18:31 fman Status new => feedback
2014-02-28 06:51 Moulin Agora Note Added: 0020502
2014-02-28 06:51 Moulin Agora Status feedback => assigned
2014-02-28 14:58 fman Note Added: 0020504
2014-03-04 13:48 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-03-04 13:48 fman Status assigned => resolved
2014-03-04 13:48 fman Resolution open => fixed
2014-03-04 13:58 fman Summary Report Metrics Dashboard non product => Report Metrics Dashboard - Test Project Progress Section is always empty
2014-03-04 14:00 fman Note Added: 0020517
2014-03-04 14:00 fman Relationship added child of 0006048
2014-03-04 14:01 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-04-25 17:38 fman Note Added: 0020825
2014-04-25 17:38 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker