Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006184TestLinkNew Featurepublic2014-01-31 20:442014-04-25 17:38
Reporterneozonka 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006184: Add a new api call to enable assigning of Tester to the test case execution to the entire test suite or the test case or both
DescriptionCurrently there's no way to do an api call to assign a tester to the test case in test case execution so that better report metrics is avail. I'm mostly concerned about the testlink-python api version 4.7.

If this feature can be added to the api then it would be really convenient to assing the tester to the test case while or after reportTCresult.
TagsNo tags attached.
Database (MySQL,Postgres,etc)All
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006185closedfman reportTCResults() - new parameter 'user' (user login) 

-  Notes
(0020380)
fman (administrator)
2014-02-01 11:04
edited on: 2014-02-01 11:07

>> POINT 1 after reportTCresult.
rejected, because at GUI level operation is not possible.
API have to follow GUI.
In addition is not good from audit process.

Just checked available API, we allow an OVERWRITE option on reportTCresult()
that also is not good from audit process..
If POINT 2 (see below) is implemented using OVERWRITE you will have both options.


>> POINT 2 to assing the tester to the test case while reportTCresult.
Tester is assigned to execution using the script key used to make the call
to reportTCResult.

Want can be done is add an addition parameter to provide user id to be used instead of standard behaviour.

Bulk execution (multiple test cases inside test suite) is not provided via API
and will not be implemented.

(0020403)
fman (administrator)
2014-02-08 08:55

resolved with related issue.
no more user feedback anyway
(0020842)
fman (administrator)
2014-04-25 17:38

1.9.10 released

- Issue History
Date Modified Username Field Change
2014-01-31 20:44 neozonka New Issue
2014-02-01 10:19 fman QA Team - Task Workflow Status => TBD
2014-02-01 10:19 fman Severity major => feature request
2014-02-01 11:04 fman Note Added: 0020380
2014-02-01 11:06 fman Note Edited: 0020380 View Revisions
2014-02-01 11:07 fman Note Edited: 0020380 View Revisions
2014-02-02 11:17 fman Issue cloned: 0006185
2014-02-02 11:17 fman Relationship added related to 0006185
2014-02-08 08:55 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-02-08 08:55 fman Note Added: 0020403
2014-02-08 08:55 fman Status new => resolved
2014-02-08 08:55 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-02-08 08:55 fman Resolution open => fixed
2014-02-08 08:55 fman Assigned To => fman
2014-04-25 17:38 fman Note Added: 0020842
2014-04-25 17:38 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker