Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006179TestLinkTest Executepublic2014-01-29 11:292014-04-25 17:38
Reporternarsu 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006179: Cannot remove already executed test case (demo.testlink.org)
DescriptionI tried to test 1.9.9 demo.testlink.org site and I cannot remove already executed testcase from specification. Is it possible there is still something odd ?
Steps To Reproduce1. Login in to demo.testlink.org as a admin
2. select project QA Demo Project
3. Try to remove already executed test case http://demo.testlink.org/latest/linkto.php?tprojectPrefix=qadp&item=testcase&id=qadp-1 [^]
4. You will see message "Your role has no right to delete executed test cases or test case versions"
5. If you check your role rights you will see there is delete/edit rights enabled for admin.....

Any ideas?




Additional InformationReason for demo tryout is because I have been solving same problem with earlier 1.9.7. I have noticed there is lot of discussion on forums and tracker. I have added all missing Database values for rights and role_rights tables according reports:

http://mantis.testlink.org/view.php?id=5746 [^]
http://mantis.testlink.org/view.php?id=5731 [^]

I am still finding a way forward. But I thing it's more wise to update when we find a fix
..
TagsNo tags attached.
Database (MySQL,Postgres,etc)demo site
BrowserChromium
PHP Versiondemo site
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
child of 0006048closedfman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 

-  Notes
(0020373)
fman (administrator)
2014-01-29 22:08

https://gitorious.org/testlink-ga/testlink-code/commit/dc86838045638d121dcfcf45d66bf4bad32989d9 [^]
(0020845)
fman (administrator)
2014-04-25 17:38

1.9.10 released

- Issue History
Date Modified Username Field Change
2014-01-29 11:29 narsu New Issue
2014-01-29 22:07 fman QA Team - Task Workflow Status => TBD
2014-01-29 22:07 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-01-29 22:07 fman Description Updated View Revisions
2014-01-29 22:08 fman Note Added: 0020373
2014-01-29 22:08 fman Status new => resolved
2014-01-29 22:08 fman Resolution open => fixed
2014-01-29 22:08 fman Assigned To => fman
2014-01-29 22:09 fman Relationship added child of 0006048
2014-04-25 17:38 fman Note Added: 0020845
2014-04-25 17:38 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker