Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006174TestLinkReportspublic2014-01-27 04:352014-04-25 17:38
Reportersnowyfu 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006174: Requirements based Report - No execute content display when clicking "exec_icon.png" icon
DescriptionNo execute content display when clicking "exec_icon.png" icon
Steps To Reproduce1. Login testlink
2. Get into "Test Reports"page
3. Click "Requirements based Report "
4. Clicking "exec_icon.png" icon


Expected reult:
Matched execute content display

Actual result:
No execute content display
Additional InformationSolutions:
Update file: resultsReqs.php

$exec_link = "<a href=\"javascript:openExecutionWindow(" .
                                     "{$tc_id}, {$testcases[$tc_id]['tcversion_id']}, {$testcases[$tc_id]['exec_on_build']} , " .

should update to:

                        $exec_link = "<a href=\"javascript:openExecutionWindow(" .
                                     "{$tc_id}, {$testcases[$tc_id]['tcversion_number']}, {$testcases[$tc_id]['exec_on_build']} , " .
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0020371)
fman (administrator)
2014-01-28 21:06

ok, thanks I'm going to check
(0020405)
fman (administrator)
2014-02-08 11:19

code seems ok since 1.9.7 version
please confirm what version are you using
(0020430)
snowyfu (reporter)
2014-02-13 01:42
edited on: 2014-02-13 01:55

I am using 1.9.9, the issue occurs in 1.9.9. I also tested from linkage: http://demo.testlink.org/latest/index.php [^]
the issue can be reproduced.

(0020838)
fman (administrator)
2014-04-25 17:38

1.9.10 released

- Issue History
Date Modified Username Field Change
2014-01-27 04:35 snowyfu New Issue
2014-01-27 19:16 fman QA Team - Task Workflow Status => TBD
2014-01-27 19:16 fman Summary No execute content display when clicking "exec_icon.png" icon => Requirements based Report - No execute content display when clicking "exec_icon.png" icon
2014-01-28 21:06 fman Note Added: 0020371
2014-02-08 11:19 fman Note Added: 0020405
2014-02-08 11:19 fman Assigned To => fman
2014-02-08 11:19 fman Status new => feedback
2014-02-13 01:42 snowyfu Note Added: 0020430
2014-02-13 01:42 snowyfu Status feedback => assigned
2014-02-13 01:55 snowyfu Note Edited: 0020430 View Revisions
2014-02-13 08:09 fman Status assigned => resolved
2014-02-13 08:09 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-02-13 08:09 fman Resolution open => fixed
2014-04-25 17:38 fman Note Added: 0020838
2014-04-25 17:38 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker