Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006112TestLinkTest Execute - Filterspublic2013-12-23 16:042014-04-25 17:39
Reporterh2oh3o 
Assigned Tofman 
PriorityhighSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformPCOSWindows (client) Ubuntu ServerOS Version7, 13.04
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006112: Filter by "bug" when execute tests
DescriptionIs absolutely essential for a tester to filter by a bug ID in order to re-run the test affected by a bug once that bug is resolved.
Steps To ReproduceN/A
Additional InformationThe query could be something lik:

select tc.tc_external_id,tc.summary,eb.bug_id
from execution_bugs eb inner join executions e on e.id = eb.execution_id
inner join tcversions tc on tc.id = e.tcversion_id
where bug_id = '26';
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome/Firefox/IE
PHP Version5.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0020236)
fman (administrator)
2013-12-23 16:38

Just for the records: a more or less solution is useless.
If you want to contribute => ok, provide full working solution
Otherwise provide the best requirements you can and leave solution in hands of development team.
(0020250)
fman (administrator)
2013-12-26 18:21

https://gitorious.org/testlink-ga/testlink-code/commit/9aa2361d6294253481c76255695ef2ec3ef37a88 [^]
(0020256)
h2oh3o (reporter)
2013-12-30 14:22

After try the solution i have to say: good and quick solution, thanks.

Because i think what i ask is done in this feature, i open a new one to aks for more improvements that i figured out after try the solution.
(0020865)
fman (administrator)
2014-04-25 17:39

1.9.10 released

- Issue History
Date Modified Username Field Change
2013-12-23 16:04 h2oh3o New Issue
2013-12-23 16:38 fman Note Added: 0020236
2013-12-26 18:21 fman Note Added: 0020250
2013-12-26 18:22 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-12-26 18:22 fman Status new => resolved
2013-12-26 18:22 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2013-12-26 18:22 fman Resolution open => fixed
2013-12-26 18:22 fman Assigned To => fman
2013-12-30 14:22 h2oh3o Note Added: 0020256
2014-04-25 17:39 fman Note Added: 0020865
2014-04-25 17:39 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker