Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006057TestLinkBug Tracking System - JIRA Integrationpublic2013-11-21 07:502013-11-23 13:57
Reporterdrakulavich 
Assigned Tofman 
PrioritylowSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006057: Jira integration via SOAP is broken due to changes in jirasoapInterface.class.php (not true just debug message printed)
DescriptionJira integration via SOAP is broken in 1.9.9.
Steps To Reproduce1. Open project management and click on "issue tracker management" to create and configure jira issue tracker.
2. Test connection by clicking on the key icon beside the name of jira issue tracker.

=> Connection is broken. It worked in version 1.9.8. I've got an exception like this:
object(SimpleXMLElement)0000147 (10) { ["username"]=> string(6) "123" ["password"]=> string(8) "456" ["uribase"]=> string(30) "http://jira.site.net/" [^] ["uriwsdl"]=> string(62) "http://jira.site.net/rpc/soap/jirasoapservice-v2?wsdl" [^] ["uriview"]=> string(39) "http://jira.site.net/browse/SL" [^] ["uricreate"]=> string(61) "http://jira.site.net/secure/CreateIssue!default.jspa" [^] ["comment"]=> array(4) { [0]=> object(SimpleXMLElement)0000151 (0) { } [1]=> object(SimpleXMLElement)0000150 (0) { } [2]=> object(SimpleXMLElement)#149 (0) { } [3]=> object(SimpleXMLElement)#148 (0) { } } ["projectkey"]=> string(3) "FTS" ["issuetype"]=> string(3) "Bug" ["resolvedstatus"]=> object(SimpleXMLElement)#153 (1) { ["status"]=> array(2) { [0]=> object(SimpleXMLElement)0000154 (2) { ["code"]=> string(1) "5" ["verbose"]=> string(8) "Resolved" } [1]=> object(SimpleXMLElement)0000155 (2) { ["code"]=> string(1) "6" ["verbose"]=> string(6) "Closed" } } } }
Additional InformationI've replace file jirasoapInterface.class.php with version from TL 1.9.8 and now it works.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 25
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon demo01.png [^] (37,174 bytes) 2013-11-23 08:46

- Relationships

-  Notes
(0020108)
fman (administrator)
2013-11-21 09:31

without the XML you have used to configure I can do nothing
(0020109)
drakulavich (reporter)
2013-11-21 09:37

My XML looks like:
<issuetracker>
<username>user</username>
<password>pass</password>
<uribase>http://jira.mysite.net/</uribase> [^]
<uriwsdl>http://jira.mysite.net/rpc/soap/jirasoapservice-v2?wsdl</uriwsdl> [^]
<uriview>http://jira.mysite.net/browse/</uriview> [^]
<uricreate>http://jira.mysite.net/secure/CreateIssue!default.jspa</uricreate> [^]
<projectkey>XXX</projectkey>
</issuetracker>
(0020112)
fman (administrator)
2013-11-23 08:46

Dear user:
There is a bug difference bewteen getting an exception, and DEBUG code that has not been removed.
In your opinion what can be the meaning of a lighted bulb light?
All is WRONG?
All is OK?
in addition if you move the mouse over the icon you are going to get the message Connection is OK.
I've just checked on our demo site with a REAL jiraOnDemand instance
You can see result on attached image?


Another question.
what are the objective elements that allow you to said:
 Connection is broken

have you tested to create an issue and do you have problems?
have you tested to link an existent issue and do you have problems ?

As you understand, I've to do some guessing (I'm going to do the tests I'm asking to you also), just because you issue report is incomplete.
(0020113)
fman (administrator)
2013-11-23 09:21

Test Add existent BUG => OK.
(0020114)
fman (administrator)
2013-11-23 09:22

Interface WORKS, issue is just an annyoing debug message
(0020115)
fman (administrator)
2013-11-23 09:22

https://gitorious.org/testlink-ga/testlink-code/commit/489863046f81bd07ca7fc8dd9eba08df4bb09795 [^]
(0020116)
drakulavich (reporter)
2013-11-23 13:13

Sorry for bad issue report. I misunderstood. And I decided, that this was an exception and created the issue.

Thanks for fixing.
(0020117)
fman (administrator)
2013-11-23 13:57

ok,
hope you are going to enjoy TestLink

- Issue History
Date Modified Username Field Change
2013-11-21 07:50 drakulavich New Issue
2013-11-21 09:31 fman Note Added: 0020108
2013-11-21 09:37 drakulavich Note Added: 0020109
2013-11-23 08:46 fman Note Added: 0020112
2013-11-23 08:46 fman File Added: demo01.png
2013-11-23 09:21 fman Note Added: 0020113
2013-11-23 09:22 fman Note Added: 0020114
2013-11-23 09:22 fman Status new => resolved
2013-11-23 09:22 fman Resolution open => fixed
2013-11-23 09:22 fman Assigned To => fman
2013-11-23 09:22 fman Note Added: 0020115
2013-11-23 09:22 fman Priority high => low
2013-11-23 09:22 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2013-11-23 09:23 fman Summary Jira integration via SOAP is broken due to changes in jirasoapInterface.class.php => Jira integration via SOAP is broken due to changes in jirasoapInterface.class.php (not true just debug message printed)
2013-11-23 13:13 drakulavich Note Added: 0020116
2013-11-23 13:57 fman Note Added: 0020117
2013-11-23 13:57 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker