Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006035TestLinkTest Executepublic2013-11-11 10:042019-04-02 20:41
Reportervdd 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version 
Summary0006035: Execution order of TCs does not match with setted order
DescriptionOrder of TCs in the tree on the "Test Execution" page does not match with setted execution order on the "Add/remove TCs" page.
Steps To Reproduce1. Create several TCs (3 in my case)
2. Put one of them in the sub-suite
3. Change the order of TCs manually (d-n-d in the tree)
(see the attached tc-spec.jpg - Test Spec tree on the left)

4. Add TCs to the test plan
5. Set the execution order of TC (see the attached tc-add.jpg)
6. Go to the test execution

 RESULT: Order of TCs in the tree is not the same as on the "Add/Remove TCs" page. See the attached tc-exec.jpg - on the right.
Additional InformationI also tried to reset order on the Test Spec page by default (by "Sort alphabetically" and "Sort by external ID" btns). Then I set correct execution order on the "Add/Remove TCs" page. But TCs on the "Test Execution" page are not sorted correctly again.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
BrowserFF 25.0 / Chrome 30.0 / IE 9
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesjpg file icon tc-spec.jpg [^] (51,426 bytes) 2013-11-11 10:04


jpg file icon tc-exec.jpg [^] (75,037 bytes) 2013-11-11 10:05


jpg file icon tc-add.jpg [^] (143,674 bytes) 2013-11-11 10:05

- Relationships
related to 0006088new Sort tests alphabetically in test navigation-tree during test execution 

-  Notes
(0019996)
fman (administrator)
2013-11-11 11:30

In addition to images that are easy for you please explain CLEARLY in few words what is the issue, this way misunderstanding will be reduced to zero.
without this info issue will be closed

Reported DO NOT NEED to add himself to monitoring
(0019999)
vdd (reporter)
2013-11-11 13:53

Sorry for the misunderstanding.
I set the execution order of TCs on the "Add/Remove TCs" page as it shown on the tc-add.jpg, i.e.
TST-13:Test Case 001 (0)
TST-14:Test Case 001-1 (10)
TST-15:Test Case 002 (20)

Then I open "Test Execution" and TCs are sorted in tree in the following order:
- Test Suite 01
-- TST-13:Test Case 001
-- Test Suite 01-01
--- TST-15:Test Case 002
-- TST-14:Test Case 001-1

But I expect the following order:
- Test Suite 01
-- TST-13:Test Case 001
-- TST-14:Test Case 001-1
-- Test Suite 01-01
--- TST-15:Test Case 002

Is that the info you needed?
(0020004)
fman (administrator)
2013-11-11 20:05
edited on: 2013-11-11 20:36

issue happens because Test Suites are also nodes that have an order and EXEC ORDER can not be assigned to TEST SUITES.

Suppose:
- Test Suite 01 (order on Test Spec: automatically assigned 0)
-- TST-13:Test Case 001 (order on Test Spec: automatically assigned 100)
-- TST-14:Test Case 001-1 (order on Test Spec: automatically assigned 101)
-- Test Suite 01-01 (order on Test Spec: automatically assigned 102)
--- TST-15:Test Case 002 (order on Test Spec: automatically assigned 100)

Now On EXECUTION
- Test Suite 01 (order 0 - CAN NOT BE CHANGED on EXEC)
-- Test Suite 01-01 (order 102 - CAN NOT BE CHANGED on EXEC)
--- TST-15:Test Case 002 (order on Test Spec: 100 on EXEC 20)

When getting data
Step 1 - Children on Test Suite 01 will result in
-- Test Suite 01-01 (order 102 - CAN NOT BE CHANGED on EXEC)
-- TST-13:Test Case 001 (order on Test Spec: 100 on EXEC 1000)
-- TST-14:Test Case 001-1 (order on Test Spec: 101 on EXEC 1001)

There is no simple way to fix this.
Workaround => display order on Test Suite in the ADD test cases to test plan,
this way user can have a hint.

(0020027)
vdd (reporter)
2013-11-14 11:50
edited on: 2013-11-14 11:59

Hello, fman! Sorry for delay.

Ok, it will be great if you add this. It solves the problem partially.
But we have a lot of manual TCs, dozens and hundreds, with 2-3 nested levels of test suites.
And when we'll add these TCs for execution it will be a lot of monkey work to reset order for all TCs in the sub-suites.

In addition the system sets order for TCs of some sub-suites again from zero (perhaps it is another issue, and should I report it as seperate issue?).
Ideally the order of TCs in the Test Execution should be the same as in the Test Specification (as it was in TL 1.7).
Is there any possible way to implement this in the future versions?

(0020028)
fman (administrator)
2013-11-14 12:23

with minimun dig in code I think you can solve this quickly by yourself
(0020029)
vdd (reporter)
2013-11-14 13:41

solve what exactly?
- display order in Test Suite in the ADD test cases
- system sets order for TCs of some sub-suites again from zero
- correspondence of the order of the TCs in the Test Execution to the Test Specification
(0020030)
fman (administrator)
2013-11-14 14:49

>> Ideally the order of TCs in the Test Execution
>> should be the same as in the Test Specification (as it was in TL 1.7).
this
(0020175)
ntr (reporter)
2013-12-09 16:46

I've somme feedback to provide too.
I would enjoy having possibility to sort testcases alphabetically during test execution, as it is possible to sort it in test specification.
That could be really usefull when you want to set a result for a particular test among your test campaign (or look for the result while you're executing tests). Do not need to re-order the test execution sequence, but only the display in the tree.


I've tried to look in the code, but seems more complex than I thought.
(0020176)
fman (administrator)
2013-12-09 19:48

@ntr
IMHO your request is different issue / feature request then you need to open a new issue.

Please work this way, because yours is feature request, while this issue is an issue
(0020181)
ntr (reporter)
2013-12-10 10:36

ok, I've written a dedicated issue for this feature request : 0006088: Sort tests alphabetically in test navigation-tree during test execution

- Issue History
Date Modified Username Field Change
2013-11-11 10:04 vdd New Issue
2013-11-11 10:04 vdd File Added: tc-spec.jpg
2013-11-11 10:05 vdd File Added: tc-exec.jpg
2013-11-11 10:05 vdd File Added: tc-add.jpg
2013-11-11 10:09 vdd Note Added: 0019995
2013-11-11 10:26 vdd Note Edited: 0019995 View Revisions
2013-11-11 11:30 fman Note Added: 0019996
2013-11-11 13:53 vdd Note Added: 0019999
2013-11-11 20:05 fman Note Added: 0020004
2013-11-11 20:21 fman Note Edited: 0020004 View Revisions
2013-11-11 20:23 fman Note Edited: 0020004 View Revisions
2013-11-11 20:27 fman Note Edited: 0020004 View Revisions
2013-11-11 20:29 fman Note Edited: 0020004 View Revisions
2013-11-11 20:30 fman Note Edited: 0020004 View Revisions
2013-11-11 20:31 fman Note Edited: 0020004 View Revisions
2013-11-11 20:36 fman Note Edited: 0020004 View Revisions
2013-11-11 20:36 fman Note View State: 0020004: public
2013-11-11 20:36 fman Summary ?xecution order of TCs does not match with setted order => Execution order of TCs does not match with setted order
2013-11-11 20:36 fman Note Deleted: 0019995
2013-11-14 11:50 vdd Note Added: 0020027
2013-11-14 11:59 vdd Note Edited: 0020027 View Revisions
2013-11-14 12:23 fman Note Added: 0020028
2013-11-14 13:41 vdd Note Added: 0020029
2013-11-14 14:49 fman Note Added: 0020030
2013-11-14 14:52 fman Status new => feedback
2013-11-16 15:02 fman File Added: DE.pdf
2013-11-16 15:02 fman File Deleted: DE.pdf
2013-12-09 16:46 ntr Note Added: 0020175
2013-12-09 19:48 fman Note Added: 0020176
2013-12-10 10:36 ntr Note Added: 0020181
2015-01-06 10:23 fman Relationship added related to 0006088
2019-01-19 15:08 fman Status feedback => resolved
2019-01-19 15:08 fman Resolution open => unable to reproduce
2019-01-19 15:08 fman Assigned To => fman
2019-04-02 20:41 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker