Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006032TestLinkRolespublic2013-11-08 01:132013-11-08 16:51
Reportersubitdas 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.8 (2013 Q3 - bug fixing) 
Summary0006032: [Testlink 1.9.7]Can't update admin role permission to enable delete/edit executed test cases
DescriptionPlease check the attached screenshot.
In the role edit page, the admin role is readonly, we want to update it to enable delete or edit exectuted test cases.
We're cleaning up test cases, so it's priority to us.Please help take a look at this.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon Role edit.png [^] (43,769 bytes) 2013-11-08 01:13


png file icon Delete case.png [^] (33,325 bytes) 2013-11-08 09:59


png file icon Updated rights.png [^] (44,587 bytes) 2013-11-08 14:31

- Relationships

-  Notes
(0019987)
fman (administrator)
2013-11-08 06:30

1. detaile steps to reproduce not provided
2. testlink version not provided in the Product Version Field
3. update to 1.9.8 with latest fixes and retest
(0019989)
subitdas (reporter)
2013-11-08 08:10

Hi fman
It's testlink 1.9.7 which described in summary.
To upgrade to 1.9.8, which is a real a great effort and process for our company.Need to take several month, we just upgrade it from 1.9.0 to 1.9.7 2 month ago. So could you take a look at this and help figure how and where to resolve this issue.
Steps to reproduce:
1.Click Users/Roles tab
2.Click view roles
3.Select admin role
Acutal result:
1. The rights can't be edited
2.'Delete Executed Test Cases' and 'Edit Executed Test Cases' are unchecked

Expected result:
1. The rights should be edtitable or 'Delete Executed Test Cases' 'Edit Executed Test Cases' rights should be checked by default.
(0019992)
fman (administrator)
2013-11-08 09:38

>> It's testlink 1.9.7 which described in summary.
I've said and is true
>>2. testlink version not provided in the Product Version Field
that is the right place when version exists

>> To upgrade to 1.9.8, which is a real a great effort and process for our
>> company.Need to take several month, we just upgrade it from 1.9.0 to 1.9.7
upgrading from 1.9.7 to 1.9.8 is not an effort
Give a look to all issues fixed for 1.9.7 and 1.9.8 in order to understand if yours is described.

if you need personalized support you can buy it.
Let me know and I can send you and offer
(0019993)
subitdas (reporter)
2013-11-08 14:30

Hi fman
I checked the fixed issue in 1.9.8 release, there's one related with this ticket.
0005746: [Users and Rights] Cannot set new rights after upgrade (fman)
But I'd like to know is it OK to fix it only insert data in DB, not upgrade to 1.9.8?
I tried following sqls
INSERT Testlink197.rights VALUES (38,'testproject_delete_executed_testcases');
 INSERT INTO Testlink197.role_rights (role_id,right_id) VALUES (8,38);
...

After that, the rights are checked and added, plase refer to attched 'update right.png'
But the problem is actually delete executed test cases still doesn't work.
Here're the steps:
1.Create a test case
2. Create a test plan
3. Add test case to plan
4.Execute test case
5.Delete test case under test specfication
Acutal result:
1.It can't be deleted, says 'Your role has no right to delete executed test cases and case versions', please refer to the attached 'delete case.png'

So does any other code on some files need to add to fix it or need to restart server?
(0019994)
fman (administrator)
2013-11-08 16:51

As said before you have to upgrade to 1.9.8 with latest fixes. I can not provide the help you are requesting

Closing issue

- Issue History
Date Modified Username Field Change
2013-11-08 01:13 subitdas New Issue
2013-11-08 01:13 subitdas File Added: Role edit.png
2013-11-08 06:30 fman Note Added: 0019987
2013-11-08 06:30 fman Status new => closed
2013-11-08 06:30 fman Assigned To => fman
2013-11-08 06:30 fman Resolution open => fixed
2013-11-08 08:10 subitdas Note Added: 0019989
2013-11-08 08:10 subitdas Status closed => assigned
2013-11-08 08:10 subitdas Resolution fixed => reopened
2013-11-08 09:38 fman Note Added: 0019992
2013-11-08 09:59 subitdas File Added: Delete case.png
2013-11-08 14:30 subitdas Note Added: 0019993
2013-11-08 14:31 subitdas File Added: Updated rights.png
2013-11-08 16:51 fman Note Added: 0019994
2013-11-08 16:51 fman Status assigned => closed
2013-11-08 16:51 fman Resolution reopened => fixed
2013-11-08 16:51 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker