Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006028TestLinkBug Tracking System - JIRA Integrationpublic2013-11-07 08:162014-04-25 17:39
Reporteradnkoks 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0006028: Integration with Jira 6.1 broken. - Due to JIRA schema changes
DescriptionAfter upgrading Jira to version 6.1, jira integration with testlink is broken.
Communication with jira server is still ok, but jira bug information can't be retrieved.
Additional InformationInterface : jira (interface:db)
TagsNo tags attached.
Database (MySQL,Postgres,etc)postgres
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon jiradbInterface.class.php [^] (4,889 bytes) 2013-11-07 15:26

- Relationships
child of 0006048closedfman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 

-  Notes
(0019977)
fman (administrator)
2013-11-07 10:30
edited on: 2013-11-07 11:21

have you checked for similar issues ?
Have you checked list of fixes for 1.9.7 and 1.9.8 ?
upgrade and retest

provide detailed step by step to reproduce
and any information you find in TestLink logs

(0019978)
adnkoks (reporter)
2013-11-07 14:38
edited on: 2013-11-07 14:38

No info in testlink logs. Problems lies in the fact that since jira 6.1 the jiraissue.pkey column is made obsolete. Testlink uses this column to find the requested issue.
Query needs to be modified.

Snippet from jira migration notes :

"To implement this change, we have made a change to the entity model: The Issue object (jiraissue table in the database) has now a new property called number (issuenum column in the database). The number property contains the numerical part of the issue key and the issue key is now represented by the number and project properties, rather than the key property (pkey column)."

(0019979)
adnkoks (reporter)
2013-11-07 15:27

Working jiradbinterface file attached.
(0019980)
fman (administrator)
2013-11-07 18:56

ok thanks
issue is that we need to understand how it will be possible to get info about jira version in order to have a different set of queries.
(0019990)
adnkoks (reporter)
2013-11-08 08:54

An option would be to query on content of pkey column, if empty, use new query.
(0019991)
fman (administrator)
2013-11-08 09:36

can be a solution, thanks
(0020202)
radoslaw.sporny (reporter)
2013-12-13 13:09

hi,
fman do you have any plans to fix this issue?
(0020203)
fman (administrator)
2013-12-13 13:26

Target version assigned => there are plans to fix it => will be fixed when 1.9.10 will be released.
no ETA
(0020211)
fman (administrator)
2013-12-14 19:00

new MANDATORY config parameter will be added <jiraversion></jiraversion>
in order to understand if a single field or two fields need to be used to getIssue().
This (IMHO) is better that do one query to understand if pkey column is empty or not.
(0020212)
fman (administrator)
2013-12-15 09:03

Need support to test implementation (Have no local jira installed)
get jiradbInterface.class.php FROM COMMIT

https://gitorious.org/testlink-ga/testlink-code/commit/e29b417beed04df8882872c88dc9e9e6eb5aed9a [^]
(0020871)
fman (administrator)
2014-04-25 17:39

1.9.10 released

- Issue History
Date Modified Username Field Change
2013-11-07 08:16 adnkoks New Issue
2013-11-07 10:30 fman Note Added: 0019977
2013-11-07 11:20 fman Note Edited: 0019977 View Revisions
2013-11-07 11:20 fman Status new => feedback
2013-11-07 11:21 fman Note Edited: 0019977 View Revisions
2013-11-07 14:38 adnkoks Note Added: 0019978
2013-11-07 14:38 adnkoks Status feedback => new
2013-11-07 14:38 adnkoks Note Edited: 0019978 View Revisions
2013-11-07 15:26 adnkoks File Added: jiradbInterface.class.php
2013-11-07 15:27 adnkoks Note Added: 0019979
2013-11-07 18:56 fman Note Added: 0019980
2013-11-07 19:01 fman Summary Integration with Jira 6.1 broken. => Integration with Jira 6.1 broken. - Due to JIRA schema changes
2013-11-08 08:54 adnkoks Note Added: 0019990
2013-11-08 09:36 fman Note Added: 0019991
2013-12-13 13:09 radoslaw.sporny Note Added: 0020202
2013-12-13 13:26 fman Note Added: 0020203
2013-12-14 19:00 fman Note Added: 0020211
2013-12-15 09:03 fman Note Added: 0020212
2013-12-15 09:03 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-12-15 09:03 fman Status new => resolved
2013-12-15 09:03 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2013-12-15 09:03 fman Resolution open => fixed
2013-12-15 09:03 fman Assigned To => fman
2013-12-15 09:04 fman Relationship added child of 0006048
2014-04-25 17:39 fman Note Added: 0020871
2014-04-25 17:39 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker