Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006013TestLinkAPI - XMLRPCpublic2013-10-31 03:172013-11-17 09:53
Reporterredpiyo 
Assigned Tofman 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSXPOS VersionProfessional SP3
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0006013: Missing build number parameters for testcase execution status
DescriptionThis method in the RPC should be corrected "tl.getTestCasesForTestPlan"
when i use this method "tl.getLastExecutionResult", it does not allow to send build number as a parameter

The API provide a method to fetch latest test results. But it not send build the number as a parameter
Steps To Reproduce1) When fetching the test results for some test cases there can be multiple results
2)first marked Test Case 1 as fail
3)then marked Test Case 1 as pass
4)Within the same build"
5)When fetching the results via the API, I get the results using results using the latest time stamp
6) If I get the result using the build filter, there is not time stamp information
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0005996closedfman Need XMLRPC api for getExecutionResult that takes a build paramter 
related to 0006021closedfman getLastExecutionResult () - new parameters platform and build 
child of 0005897closedfman Availables hot-fixes for 1.9.8 & How To get full fixed package from gitorious 

-  Notes
(0019931)
fman (administrator)
2013-10-31 15:11

I found very hard to understand your issue reporting.
Please can you provide detailed steps to reproduce (very detailed),
I can do same request on each issue you write, I suppose you are able to already understand that you do not provide, all details needed
(0019943)
redpiyo (reporter)
2013-11-01 02:53

Ok i tried to be as descriptive as possible here, hoped it had helped you to visualize:
1 first we fetch the results of the test cases belonging to a build number with test status i.e, Pass, Fail , Blocked , Not Run
2 then it fetch the latest execution results of the test cases that belong to that build
3 that means if there are 10 test cases belong to a specific build i.e "1.0" it will show the reults of these 10 test cases.
4 but it will show only the latest execution results.
5 /*build 1.0*/
6 test case A = pass
7 test case B = fail
8 /*build 2.0*/
9 test case A = blocked
10 test case B = pass
11 if you run the build one again I will get the results of build 2 because those are the latest results.
12 2nd example
13 /*build 1.0*/
14 test case A = pass
15 test case B = fail
16 test case C = fail
17 /*build 2.0*/
18 tet case A = fail
19 test case B = pass
20 Now I try to retrieve the results for build 1.0
21 test case A = fail
22 test case B = pass
23 test case C =fail
24 ==========================
25 the XMLRPC API provide a method to fetch latest test result. But it not allows to send build number as a parameter
26 When get the results using the build and test status filters without considering the execution time, I am only reading the first run of the test case, I,e. test case A first result = fail, 2nd time = pass. I am always seeing fail for Test Case A.
27 Alternatively if I retrieve results based on last execution results as seen. in the above example, I do not get 1) build Info 2) "Not Run" status is not showing
28 this method in the RPC should be corrected "tl.getTestCasesForTestPlan"
29 when i use this method "tl.getLastExecutionResult", it does not allow to send build number as a parameter, we need to change one of the two methods to get this done
30 The better choice will be changing the original method "tl.getTestCasesForTestPlan", to return the latest execution result using timestamp and build information
(0019947)
fman (administrator)
2013-11-01 09:23

IMHO requests has been done in the right way by reporter of 0005996.
I do not like misleading subject.
if absolutely your opinion that build parameter is missing.

If we have developed a method to return Latest Execution Result in the WHOLE Build Set, this will means that NOT RUN can be only extracted when test case HAS NEVER BEEN executed.
If this does not happen then this is may be an issue that has to be reported in a new issue.

It will be great also that you (and the other users) try to do a minor search before reporting, to avoid issue duplication.

Probably New method will be created but this will be determined only after some analisis.

Side note: if you are using so much TestLink may be is time to start thinking about providing some contribution to support the work.
(0019958)
fman (administrator)
2013-11-03 10:26

see approach by @htptissera on related issue
(0019960)
fman (administrator)
2013-11-03 10:37

https://gitorious.org/testlink-ga/testlink-code/commit/b789fa898163a0fd3ad0f3e58938faf9ced11657 [^]
(0020052)
fman (administrator)
2013-11-17 09:53

1.9.9 Released

- Issue History
Date Modified Username Field Change
2013-10-31 03:17 redpiyo New Issue
2013-10-31 15:11 fman Note Added: 0019931
2013-10-31 16:36 fman Relationship added related to 0005996
2013-11-01 02:53 redpiyo Note Added: 0019943
2013-11-01 09:23 fman Note Added: 0019947
2013-11-03 10:13 fman Relationship added related to 0006021
2013-11-03 10:26 fman Note Added: 0019958
2013-11-03 10:37 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-11-03 10:37 fman Note Added: 0019960
2013-11-03 10:37 fman Status new => resolved
2013-11-03 10:37 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-11-03 10:37 fman Resolution open => fixed
2013-11-03 10:37 fman Assigned To => fman
2013-11-03 10:37 fman Relationship added child of 0005897
2013-11-17 09:53 fman Note Added: 0020052
2013-11-17 09:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker