Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005978TestLinkInstallerpublic2013-10-16 14:422013-10-17 06:07
Reportermoreloci 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformPCOSLinuxOS Version
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0005978: Update script 1.9.8 for Postgres 9.1 not correct
DescriptionWhen I execute db_schema_update.sql for 1.9.8, I get the message that the type 'number' does not exist.


Steps To ReproduceCopy and paste the script contents into the SQL query window from pgAdmin.
Click on start.
Additional InformationThe solution is simple. Change the field number into decimal.

/* tcversions */
ALTER TABLE tcversions ADD COLUMN "estimated_exec_duration" number(6,2) NULL;

/* executions */
ALTER TABLE executions ADD COLUMN "execution_duration" number(6,2) NULL;

To:

/* tcversions */
ALTER TABLE tcversions ADD COLUMN "estimated_exec_duration" decimal(6,2) NULL;

/* executions */
ALTER TABLE executions ADD COLUMN "execution_duration" decimal(6,2) NULL;
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgresql 9.1
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTESTED
Attached Files

- Relationships
duplicate of 0005921closedfman POSTGRESQL - Update 1.9.7 to 1.9.8 fails because db_schema_update.sql use unknown typ number() 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-10-16 14:42 moreloci New Issue
2013-10-16 19:50 fman Status new => resolved
2013-10-16 19:50 fman Resolution open => duplicate
2013-10-16 19:50 fman Assigned To => fman
2013-10-17 06:05 fman Relationship added duplicate of 0005921
2013-10-17 06:06 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-10-17 06:07 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker