Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005937TestLinkFilters - Test Specificationpublic2013-09-26 07:172013-11-17 09:53
Reporterrponoran 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformFireFox v23.0.1OSWindowsOS Version7
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0005937: (Required) Custom Fields become mandatory in Filters Section
DescriptionIf Required Custom Fields are in use and these become available in the Filters section, one can not filter after anything else as long as the required Custom Field is not provided.
Steps To Reproduce1. Create a Custom Field for Test Cases and enable it on Test Spec Design.
2. Set it as Required in the Assign Custom Fields section.
3. Switch to the Test Specification view.
4. The newly assigned Custom Field is now available for filtering.
5. Set a filter for Keyword, Importance or Execution Type but leave the Custom Field empty.
6. Apply the filter.

Expected: The Filters section should not take the Required option for Custom Fields into consideration.

Actual: When filtering, Required Custom Fields need to be provided otherwise filtering after anything else available is not possible.
Additional InformationPressing [Reset Filter] in the Test Specification view without making any changes to the available Filters, pops up the "Please fill out this field" message also.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Bitnami - MySQL
BrowserFireFox v23.0.1
PHP VersionPHP v5.4.15
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon 2013-09-26 10_13_19-TestLink 1.9.8 (Lobizon).jpg [^] (22,048 bytes) 2013-09-26 07:17

- Relationships
child of 0005897closedfman Availables hot-fixes for 1.9.8 & How To get full fixed package from gitorious 

-  Notes
(0019708)
rponoran (reporter)
2013-09-26 07:30

Due to this issue, hiding Custom Fields is also not working via pressing the [Hide Custom Fields] button in the Filters section.
(0019711)
fman (administrator)
2013-09-26 20:04

https://gitorious.org/testlink-ga/testlink-code/commit/a6eaac9596529e674c5c40e14aaebbd9482cdab3 [^]
(0019713)
rponoran (reporter)
2013-09-27 08:11

I've used your new code and this looks great now...works as expected now.
(0020083)
fman (administrator)
2013-11-17 09:53

1.9.9 Released

- Issue History
Date Modified Username Field Change
2013-09-26 07:17 rponoran New Issue
2013-09-26 07:17 rponoran File Added: 2013-09-26 10_13_19-TestLink 1.9.8 (Lobizon).jpg
2013-09-26 07:30 rponoran Note Added: 0019708
2013-09-26 20:04 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-09-26 20:04 fman Note Added: 0019711
2013-09-26 20:04 fman Status new => resolved
2013-09-26 20:04 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-09-26 20:04 fman Resolution open => fixed
2013-09-26 20:04 fman Assigned To => fman
2013-09-26 20:04 fman Relationship added child of 0005897
2013-09-27 08:11 rponoran Note Added: 0019713
2013-11-17 09:53 fman Note Added: 0020083
2013-11-17 09:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker