Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005936TestLinkRequirement Managementpublic2013-09-24 14:172013-11-17 09:53
Reporterdanzone 
Assigned Tofman 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0005936: DB Access Error message on Requirement visualization/modification
DescriptionHi everyone!
   I've just installed TestLink 1.9.8 and I have an issue when I create, view or modify a requirement: at the top of requirement info screen, I've goto the message:
 ==============================================================================
 DB Access Error - debug_print_backtrace() OUTPUT START
 ==============================================================================
 ==============================================================================

with no other info.
In the events section I've found two messages: an ERROR message stating "ERROR ON exec_query() - database.class.php
0 - - /* Class:requirement_mgr - Method: get_coverage - Static Coverage */ SELECT NH_TC.id,NH_TC.name,TCV.tc_external_id,U.login,RC.creation_ts FROM nodes_hierarchy NH_TC JOIN nodes_hierarchy NH_TCV ON NH_TCV.parent_id=NH_TC.id JOIN tcversions TCV ON TCV.id=NH_TCV.id JOIN req_coverage RC ON RC.testcase_id = NH_TC.id LEFT OUTER JOIN users U ON U.id = RC.author_id WHERE RC.req_id=918 ORDER BY tc_external_id
THE MESSAGE : /* Class:requirement_mgr - Method: get_coverage - Static Coverage */ SELECT NH_TC.id,NH_TC.name,TCV.tc_external_id,U.login,RC.creation_ts FROM nodes_hierarchy NH_TC JOIN nodes_hierarchy NH_TCV ON NH_TCV.parent_id=NH_TC.id JOIN tcversions TCV ON TCV.id=NH_TCV.id JOIN req_coverage RC ON RC.testcase_id = NH_TC.id LEFT OUTER JOIN users U ON U.id = RC.author_id WHERE RC.req_id=918 ORDER BY tc_external_id Query failed: errorcode[0] errormsg:"


and three WARNING message stating

1. "E_WARNING debug_print_backtrace() expects exactly 0 parameters, 1 given - in /var/www/html/testlink/lib/functions/database.class.php - Line 219"
2. "E_NOTICE Use of undefined constant DEBUG_BACKTRACE_IGNORE_ARGS - assumed 'DEBUG_BACKTRACE_IGNORE_ARGS' - in /var/www/html/testlink/lib/functions/database.class.php - Line 219"
3. "E_WARNING pg_query(): Query failed: ERROR: column rc.author_id does not exist at character 352 - in /var/www/html/testlink/third_party/adodb/drivers/adodb-postgres7.inc.php - Line 167".


Thanks for your attention, and thanks for this excellent product of Test Management!

Daniele Gagliardi
Steps To ReproduceAccess to requirement specification and add a new requirement, or modify an existing one, or simply view an existing one.
Additional InformationI've activated the two custom fields CF_ESTIMATED_EXEC_TIME and CF_EXEC_TIME, as described in customfields_for_computing_times.txt in bundled TestLink documentation.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres 8.4
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon 2013-09-24_16-02-35.png [^] (37,896 bytes) 2013-09-24 14:17


jpg file icon Testlink 1.9.3 Vs 1.9.8.JPG [^] (32,131 bytes) 2013-10-11 11:50

- Relationships
child of 0005897closedfman Availables hot-fixes for 1.9.8 & How To get full fixed package from gitorious 

-  Notes
(0019703)
fman (administrator)
2013-09-25 09:55

>> I've activated the two custom fields CF_ESTIMATED_EXEC_TIME and CF_EXEC_TIME, >> as described in customfields_for_computing_times.txt in bundled TestLink
>> documentation.
this is not related to issue but THIS CF HAS BEEN DEPRECATED and replaced with fields in standard SCHEMA.
ALL REPORTS HAVE BEEN modified and DO NOT USE ANY MORE THE CF
(0019820)
spacomp (reporter)
2013-10-11 11:41

I have googled out for solution for this.

As such, we have been using TestlInk 1.9.3 from long and we didn't have any issues.

We want to start all upcoming projects with a fresh installation of TestLink

I started with TestLink Ver 1.9.8, the DB Access Error is blocking from most of the functionalities. I have installed it afresh atleast 10 times get rid of this ERROR, but could not succeed.

I thought I will check with TestLink version 1.9.7

I found this to be working perfectly, but when it comes Test Reports for Excel format, most of the reports options are not available.

Please check the snapshot attached for your reference.
(0019821)
fman (administrator)
2013-10-11 18:16
edited on: 2013-10-11 18:29

>> I found this to be working perfectly, but when it comes Test Reports for
>> Excel format, most of the reports options are not available.
this note is not related to this issues => is a wrong way to report => will not be considered.
On this project (and in any standard) 1 issue => 1 ticket, and changing scope/ticket arguments is considered wrong.

Do not use 1.9.7, because you are not going to get any support for any issue you are going to report, because 1.9.8 with latest fixes has to be used.

Here more info:
http://mantis.testlink.org/view.php?id=5897 [^]

I've set solved on next release (1.9.9).

(0020074)
fman (administrator)
2013-11-17 09:53

1.9.9 Released

- Issue History
Date Modified Username Field Change
2013-09-24 14:17 danzone New Issue
2013-09-24 14:17 danzone File Added: 2013-09-24_16-02-35.png
2013-09-25 09:53 fman Assigned To => fman
2013-09-25 09:53 fman Status new => assigned
2013-09-25 09:55 fman Note Added: 0019703
2013-09-25 21:28 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-09-25 21:28 fman Status assigned => resolved
2013-09-25 21:28 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-09-25 21:28 fman Resolution open => fixed
2013-09-25 21:28 fman Relationship added child of 0005897
2013-10-11 11:41 spacomp Note Added: 0019820
2013-10-11 11:50 spacomp File Added: Testlink 1.9.3 Vs 1.9.8.JPG
2013-10-11 18:16 fman Note Added: 0019821
2013-10-11 18:29 fman Note Edited: 0019821 View Revisions
2013-11-17 09:53 fman Note Added: 0020074
2013-11-17 09:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker