Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005921TestLinkDatabase Postgrespublic2013-09-16 15:342013-11-17 09:53
Reporterlczub 
Assigned Tofman 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0005921: POSTGRESQL - Update 1.9.7 to 1.9.8 fails because db_schema_update.sql use unknown typ number()
Descriptionmigration of a 1.9.7 testlink installation under postgres 9.2 fails, cause
   install\sql\alter_tables\1.9.8\postgres\DB.1.9.8\step1\db_schema_update.sql
uses wrong typ number() instead numeric()
Steps To Reproducepsql -h localhost -U TLDBUSER -f DB.1.9.8/step1/db_schema_update.sql TLDB

psql:DB.1.9.8/step1/db_schema_update.sql:28: FEHLER: Typ »number« existiert nicht
ZEILE 2: ...*/tcversions ADD COLUMN "estimated_exec_duration" number(6,2...
                                                              ^
psql:DB.1.9.8/step1/db_schema_update.sql:31: FEHLER: Typ »number« existiert nicht
ZEILE 2: ...refix*/executions ADD COLUMN "execution_duration" number(6,2...
                                                              ^
ALTER TABLE
...

Additional InformationWorkAround: replace number() with numeric()

/* tcversions */
-- Failure: wrong typ 'number'
-- ALTER TABLE /*prefix*/tcversions ADD COLUMN "estimated_exec_duration" number(6,2) NULL;
ALTER TABLE /*prefix*/tcversions ADD COLUMN "estimated_exec_duration" numeric(6,2) NULL;


/* executions */
-- Failure: wrong typ 'number'
-- ALTER TABLE /*prefix*/executions ADD COLUMN "execution_duration" number(6,2) NULL;
ALTER TABLE /*prefix*/executions ADD COLUMN "execution_duration" numeric(6,2) NULL;
 
TagsNo tags attached.
Database (MySQL,Postgres,etc)postgres 9.2
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
has duplicate 0005978closedfman Update script 1.9.8 for Postgres 9.1 not correct 
child of 0005897closedfman Availables hot-fixes for 1.9.8 & How To get full fixed package from gitorious 

-  Notes
(0019636)
fman (administrator)
2013-09-16 19:24

ok, thanks
(0020073)
fman (administrator)
2013-11-17 09:53

1.9.9 Released

- Issue History
Date Modified Username Field Change
2013-09-16 15:34 lczub New Issue
2013-09-16 19:24 fman Note Added: 0019636
2013-09-16 19:31 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-09-16 19:31 fman Status new => resolved
2013-09-16 19:31 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-09-16 19:31 fman Resolution open => fixed
2013-09-16 19:31 fman Assigned To => fman
2013-09-16 19:31 fman Relationship added child of 0005897
2013-10-17 06:05 fman Relationship added has duplicate 0005978
2013-10-17 06:06 fman Summary Update 1.9.7 to 1.9.8 fails because db_schema_update.sql use unknown typ number() => POSTGRESQL - Update 1.9.7 to 1.9.8 fails because db_schema_update.sql use unknown typ number()
2013-11-17 09:53 fman Note Added: 0020073
2013-11-17 09:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker