Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005912TestLinkReportspublic2013-09-11 07:292013-11-17 09:53
Reporterteunehv 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSRed HatOS Version4.4.6-3
Product Version1.9.8 (2013 Q3 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0005912: Report Bugs per Test Case shows white screen
DescriptionWhen opening the report "Bugs per Test Case" a white screen is shown. No testcases with related bugs are shown.
Steps To Reproduce1. Select a project and testplan with test executed and bugs related
2. open the report section
3. select report Bugs per Test Case
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome / FireFox / IE
PHP Version5.3.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0005897closedfman Availables hot-fixes for 1.9.8 & How To get full fixed package from gitorious 

-  Notes
(0019599)
fman (administrator)
2013-09-11 09:24

details provided are not enough
provide step by step to reproduce starting from

1. Create Test project TPROJ1
and so on

type of issue tracker used and type of integration (DB or API) is also mandatory
(0019604)
teunehv (reporter)
2013-09-11 12:59

It's independend of the testproject. The problem occurs with several test project tested.

I can't create a working issue tracker connection in the demo project. But if you check the project NLTestReq (Testplan: Testplan Build: Rel.1) you can see the bug by yourself.

In this case no bug is related to the testcase. But on our own installation we use Mantis via DB connection. With 0, 1 or more bugs related it also gets the white screen.
(0019631)
mbar (reporter)
2013-09-16 07:42

It happens on latest git version also (1.9.9). No steps are really neccessary, apart from clicking on "Bugs per test case" report. Error message:

Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/html/testlink-1.9.5/gui/templates/results/resultsBugs.tpl" on line 64 "{assign var=tableID value=table_$idx}" - Unexpected "$", expected one of: "}" , " " , ATTR' in /var/www/html/testlink-1.9.5/third_party/smarty3/libs/sysplugins/smarty_internal_templatecompilerbase.php:665 Stack trace: #0 /var/www/html/testlink-1.9.5/third_party/smarty3/libs/sysplugins/smarty_internal_templateparser.php(3144): Smarty_Internal_TemplateCompilerBase->trigger_template_error() #1 /var/www/html/testlink-1.9.5/third_party/smarty3/libs/sysplugins/smarty_internal_templateparser.php(3209): Smarty_Internal_Templateparser->yy_syntax_error(18, '$') 0000002 /var/www/html/testlink-1.9.5/third_party/smarty3/libs/sysplugins/smarty_internal_smartytemplatecompiler.php(105): Smarty_Internal_Templateparser->doParse(18, '$') 0000003 /var/www/html/testlink-1.9.5/third_party/smarty3/libs/sysplugins/smarty_internal in /var/www/html/testlink-1.9.5/third_party/smarty3/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 665
(0019632)
mbar (reporter)
2013-09-16 07:43

Disregard "testlink-1.9.5" name, it is only directory name.
(0019633)
fman (administrator)
2013-09-16 08:00

>> No steps are really neccessary
well, this is not the way I work, then as George Clooney said (at least on Italian TV) 'No Martini, No Party' => 'No detailed steps to reproduce, no action'.

I'm not sure that what is happening to mbar is same that is happening to teunehv
why ?
because I've never get detailed steps to reproduce, a must in each issue reporting.


>> Fatal error: Uncaught exception 'SmartyCompilerException' with message
>> 'Syntax Error in template "/var/www/html/testlink-1.9.5/gui/templates/results
>>/resultsBugs.tpl" on line 64 "{assign var=tableID value=table_$idx}" -
>> Unexpected "$", expected one of: "}"
is syntax issue (that has to be fixed) due to differences between Smarty 2.x and 3.x
(0019658)
mbar (reporter)
2013-09-18 07:46

'No Martini, No Party'

I humbly accept that :)
(0020087)
fman (administrator)
2013-11-17 09:53

1.9.9 Released

- Issue History
Date Modified Username Field Change
2013-09-11 07:29 teunehv New Issue
2013-09-11 09:24 fman Note Added: 0019599
2013-09-11 09:24 fman Status new => feedback
2013-09-11 12:59 teunehv Note Added: 0019604
2013-09-11 12:59 teunehv Status feedback => new
2013-09-16 07:42 mbar Note Added: 0019631
2013-09-16 07:43 mbar Note Added: 0019632
2013-09-16 08:00 fman Note Added: 0019633
2013-09-17 20:49 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-09-17 20:49 fman Status new => resolved
2013-09-17 20:49 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-09-17 20:49 fman Resolution open => fixed
2013-09-17 20:49 fman Assigned To => fman
2013-09-17 20:50 fman Relationship added child of 0005897
2013-09-18 07:46 mbar Note Added: 0019658
2013-11-17 09:53 fman Note Added: 0020087
2013-11-17 09:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker