Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005895TestLinkCommunication via mailpublic2013-09-05 20:102013-11-17 09:54
Reporterflaviobeck 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0005895: New Account Created notification is sent to wrong destinations
DescriptionWhen new account is created, a notification email is sent to wrong destinations.

The notification is sent to system admin, and other project admins

System roles:
user1 -> admin
user2 -> guest
user2 -> guest

ProjectA roles:
user1 -> no rights
user2 -> admin
user2 -> no rights

ProjectB roles:
user1 -> no rights
user2 -> no rights
user2 -> admin


when new user is created, the notification is sent to user1, user2 and user3

TEST:
System roles:
user1 -> admin
user2 -> guest
user2 -> guest

ProjectA roles:
user1 -> no rights
user2 -> no rights
user2 -> no rights

ProjectB roles:
user1 -> no rights
user2 -> no rights
user2 -> no rights

when new user is created, the notification is sent to user1

Note:
custom_config_inc.php

# Configure using custom_config.inc.php
$g_tl_admin_email ***** it is set to user1 ****
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon testlink.PNG [^] (5,196 bytes) 2013-09-07 02:27

- Relationships
child of 0005897closedfman Availables hot-fixes for 1.9.8 & How To get full fixed package from gitorious 

-  Notes
(0019495)
flaviobeck (reporter)
2013-09-05 20:25
edited on: 2013-09-05 20:27

When I go to USER/ROLES > VIEW ROLES > ADMIN there is following field:

"Possibly affected users by role delete operation"

Who should be listed in this field?
Thats the people receiving "new account" notification (3 users).

go to USER/ROLES
there is just one admin, all others are GUEST

NOTE: there is just ONE sys admin, and many project admins, but this field just list 3 users.. why there are many project admins missing?

(0019497)
fman (administrator)
2013-09-06 12:49

>> When new account is created, a notification
>> email is sent to wrong destinations.
this means nothing, is too generic = useless.

your are not providing a clear test case i.e. expected results and actual results.

Developer Note:
Role admin at test project level is something that may be has to be rethinked, and use a new role definition like mantis Manager.
(0019501)
flaviobeck (reporter)
2013-09-07 02:24

>>this means nothing, is too generic = useless.

I have just one system administrator all other users are guest by deefault. (of course, they have different roles for projects. Usually I have one admin for each project).

Issue:
When someone (not registred) create a new user account by himself (accessing the login page and selecting "new user?" ), an e-mail is sent to administrator notifying about "new account created".

actual behavior:
In te received e-mail, we can see the field "TO" has 3 other users, not just the administrator, and these users always ask me to remove them from this kind of notification, because they do not need this information.


expected behavior:
Just system administrator $g_tl_admin_email should receive this kind of notification.


adtional info;
I noticed the other users that receive "new acccount" notifications are project admins, but there are many other project admins that is not receiving this notification.

When I go to USER/ROLES > VIEW ROLES > ADMIN there is following field:

"Possibly affected users by role delete operation"

AND IT LISTS THE USERS THAT RECEIVE THE "NEW ACCOUNT" NOTIFICATION.

I want to remove these users from that list.
(0019502)
flaviobeck (reporter)
2013-09-07 02:29

You can see attached file at this screen:

http://demo.testlink.org/tl194demo/lib/usermanagement/rolesEdit.php?doAction=edit&roleid=8 [^]

Where this users come from?
(0019503)
fman (administrator)
2013-09-07 06:23

there is no enugh ingo to answer note 19502
without this info only thing I guest is that each user in this list has admin role (default) or in a test project.
(0019625)
fman (administrator)
2013-09-14 13:39

Fixed:
mail with be sent to any user that has GLOBAL (Default) Role = ADMIN
(0019626)
fman (administrator)
2013-09-14 13:46

Please retest with latest code and provide feedback.

http://gitorious.org/testlink-ga/testlink-code/commit/fce4cba58b403a05d816c265ed27aacb61ff5c61 [^]
(0019629)
flaviobeck (reporter)
2013-09-14 19:59

Great!! I will test it on Monday!
(0019641)
flaviobeck (reporter)
2013-09-17 16:45

It is working fine now!

thank you!
(0020091)
fman (administrator)
2013-11-17 09:54

1.9.9 Released

- Issue History
Date Modified Username Field Change
2013-09-05 20:10 flaviobeck New Issue
2013-09-05 20:25 flaviobeck Note Added: 0019495
2013-09-05 20:27 flaviobeck Note Edited: 0019495 View Revisions
2013-09-06 12:49 fman Note Added: 0019497
2013-09-06 12:49 fman Status new => feedback
2013-09-07 02:24 flaviobeck Note Added: 0019501
2013-09-07 02:24 flaviobeck Status feedback => new
2013-09-07 02:27 flaviobeck File Added: testlink.PNG
2013-09-07 02:29 flaviobeck Note Added: 0019502
2013-09-07 06:23 fman Note Added: 0019503
2013-09-14 13:39 fman Note Added: 0019625
2013-09-14 13:46 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-09-14 13:46 fman Note Added: 0019626
2013-09-14 13:46 fman Status new => resolved
2013-09-14 13:46 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-09-14 13:46 fman Resolution open => fixed
2013-09-14 13:46 fman Assigned To => fman
2013-09-14 13:47 fman Relationship added child of 0005897
2013-09-14 19:59 flaviobeck Note Added: 0019629
2013-09-17 16:45 flaviobeck Note Added: 0019641
2013-11-17 09:54 fman Note Added: 0020091
2013-11-17 09:54 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker