Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005873TestLinkContribution Maintained BY USERpublic2013-08-22 09:052018-10-06 15:41
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.9 (2013 Q4 - bug fixing) 
Fixed in Version1.9.17 (2018 Q1) 
Summary0005873: User contribution : Add/Remove Testcases Navigation REQUIREMENTS
DescriptionAll provided modifications have been done from stable version TL 1.9.7.

In Add/Remove TestCases section, TestLink order TestCases only by TestSuite.
The content of the attached files "TL-1.9.7_testsGroupedByReqCov.zip" add the ability to order TestCases by Requirement Coverage in TL 1.9.7.

The attached file "NewStrings.txt" provide new lines that has to be created to display the new functionnality. You have to update the file "strings.txt" in the folder "locale\en_GB\".
The attached PNG file is provided to show how to access the functionnality in TL GUI.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Tested with MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Fileszip file icon TL-1.9.7_testsGroupedByReqCov.zip [^] (116,667 bytes) 2013-08-22 09:05
txt file icon NewStrings.txt [^] (168 bytes) 2013-08-22 09:05 [Show Content]
png file icon TL-1.9.7_testsGroupedByReqCov.PNG [^] (23,225 bytes) 2013-08-22 09:05


pdf file icon UserView.pdf [^] (1,246,063 bytes) 2014-04-26 00:14
docx file icon EvolutionsOverview.docx [^] (288,190 bytes) 2017-02-27 10:06
? file icon OrderByReq.odt [^] (459,141 bytes) 2017-04-02 13:15
? file icon DocOrderByRequirement.odt [^] (397,228 bytes) 2017-12-17 13:34

- Relationships
related to 0000231new Requirements based testing - allow add TC to TP via REQ 
child of 0005870closedfman User contribution : Req Based Report in MS Excel format, Query Metrics and Group TestCases by Coverage in Add/Remove Testcases 

-  Notes
(0020888)
Mr.Bricodage (updater)
2014-04-25 20:10

Merge request :
https://gitorious.org/testlink-ga/testlink-code/merge_requests/12 [^]
(0020890)
Mr.Bricodage (updater)
2014-04-25 20:19

"as stated on mantis I need detailed documentation about feature from an user point of view. Till I do not have the requeste info on mantis, I can not proceed with any code evaluation." : I wasn't aware of your need (user guide). I'll provide a doc ASAP.

Regards
(0020891)
Mr.Bricodage (updater)
2014-04-26 00:15

File "UserView.pdf" uploaded to explain the feature from an user point of view
(0020892)
fman (administrator)
2014-04-26 06:52

>> I wasn't aware of your need (user guide)
see note (0019469):
(excerpt here)
... would you mind to provide better details regarding this feature ?
more screen shoots that display the effect of this setting on right side of screen will be a must.
(0020895)
fman (administrator)
2014-04-27 08:01

OK, please check if what i've understood is right

with new option, the tree on left pane is build using REQUIREMENT SPECIFICATION and not Test project.

best regards
(0020896)
fman (administrator)
2014-04-27 09:11

There is an important aspect of contributions, comments on contributed code has to convey right information.
While reviewing this code at least on one file (lib/ajax/getreqcoveragenodes.php)
this requirement is not fullfilled.
You can not leave old comments inside because are garbage.
Take in condiserading next time.
Can sound silly but I do not want just working code, but code with a minimun
level of quality, and presence of right not misleading comments are a MUST.
(0020898)
fman (administrator)
2014-04-27 13:54

Another important thing:
you can not use a different programming style.
Is like traveling to a foreing country, then you have to respect other customs.
At least on this project I want this kind of behaviour
(0020900)
fman (administrator)
2014-04-27 15:22

More details are needed, when req to test case linking is not simple.

Req Spec RSP-100
RQ01 -> TC-01, TC-02
RQ02 -> TC-01, TC-03

1. What is displayed on right side pane when you click on Req. Spec RSP-100.
2. How do you provide info when clicking on RQ01, that removing TC-01 will affect also RQ02 ?
(0020907)
Mr.Bricodage (updater)
2014-04-27 16:47

note 20892 :
"see note (0019469)" : I didn't find it, but not matters

note 20895 :
"OK, please check if what i've understood is right
with new option, the tree on left pane is build using REQUIREMENT SPECIFICATION and not Test project." => Yes, you have understood.

notes 20896 and 20898 :
OK, well understood. I'll inform the dev team, that will be taken in account for next contributions.

note 20900 :
1. The collection of all RQ (RQ01 and RQ02 in your example) can be selected. See page 5 of "UserView.pdf" for a screenshot.
2. No information is provided. The need hasn't been expressed by my test designers team. But you're right, the information should be usefull in some cases.
(0020908)
fman (administrator)
2014-04-27 20:08

I've started code review. IMHO an important amount of work is needed in order
to eliminated lot duplicated code introduced by your development people.
in addition i think implementation for req spec done loop calling your new gen_*
can be bad effects on performance.
anyway i think your code can be a good strarting point, but will not be easier
(0026033)
Mr.Bricodage (updater)
2017-02-25 15:27

@fman : one guy of my dev team has posted on TestLink forum about this feature and about the way to implement it (see : http://forum.testlink.org/viewtopic.php?f=11&t=8046 [^])

The code provided here has been reworked for TL 1.9.17 DEV and he is waiting your advice on forum to develop according to your wishes.

Our goal is to provide the implementation that will be merged by TestLink Dev Team.
(0026034)
fman (administrator)
2017-02-25 19:43

I would prefer to discuss this HERE , that using forum.
do you think will be possible?

regards
(0026035)
Mr.Bricodage (updater)
2017-02-26 10:46

Sure.
We'll attach a doc with planned modifications tomorrow.
When we'll agree about doc content, we will provide a Pull Request that add defined functionalities.

Then Github code review could be used.

Your feedback provided on previous version has already be taken in account.
(0026039)
Mr.Bricodage (updater)
2017-02-27 10:07

EvolutionsOverview.docx attached
(0026044)
Mr.Bricodage (updater)
2017-02-27 14:41

pull request link : https://github.com/TestLinkOpenSourceTRMS/testlink-code/pull/81 [^]
(0026045)
fman (administrator)
2017-02-27 18:34

OK, will need time to give a look => be patient
(0026163)
Mr.Bricodage (updater)
2017-03-22 08:53

Hello,

I recently made the last desired modifications.

Can you tell me if I have to realize other changes to be in accordance with your rules.

Thanks
(0027095)
Mr.Bricodage (updater)
2017-12-17 13:35

Documentation attached for the new merged feature
(0027107)
Mr.Bricodage (updater)
2017-12-26 21:53

Should be logged as resolved in TestLink 1.9.17 : PR has been merged
(0027461)
Mr.Bricodage (updater)
2018-05-14 21:32

Ticket status should be set as resolved, feature available in TestLink 1.9.17

- Issue History
Date Modified Username Field Change
2013-08-22 09:05 Mr.Bricodage New Issue
2013-08-22 09:05 Mr.Bricodage File Added: TL-1.9.7_testsGroupedByReqCov.zip
2013-08-22 09:05 Mr.Bricodage File Added: NewStrings.txt
2013-08-22 09:05 Mr.Bricodage File Added: TL-1.9.7_testsGroupedByReqCov.PNG
2013-09-01 17:24 fman Assigned To => fman
2013-09-01 17:24 fman Status new => feedback
2013-09-01 17:26 fman Relationship added child of 0005870
2014-04-25 20:10 Mr.Bricodage Note Added: 0020888
2014-04-25 20:10 Mr.Bricodage Status feedback => assigned
2014-04-25 20:19 Mr.Bricodage Note Added: 0020890
2014-04-26 00:14 Mr.Bricodage File Added: UserView.pdf
2014-04-26 00:15 Mr.Bricodage Note Added: 0020891
2014-04-26 06:52 fman Note Added: 0020892
2014-04-27 08:01 fman Note Added: 0020895
2014-04-27 08:01 fman Product Version => 1.9.9 (2013 Q4 - bug fixing)
2014-04-27 09:11 fman Note Added: 0020896
2014-04-27 13:54 fman Note Added: 0020898
2014-04-27 15:22 fman Note Added: 0020900
2014-04-27 16:47 Mr.Bricodage Note Added: 0020907
2014-04-27 20:08 fman Note Added: 0020908
2014-05-10 08:25 fman Summary User contribution : Group TestCases by Requirements Coverage in Add/Remove Testcases => User contribution : Add/Remove Testcases Navigation REQUIREMENTS
2015-04-26 15:53 Mr.Bricodage Relationship added related to 0000231
2017-02-25 15:27 Mr.Bricodage Note Added: 0026033
2017-02-25 19:43 fman Note Added: 0026034
2017-02-26 10:46 Mr.Bricodage Note Added: 0026035
2017-02-27 10:06 Mr.Bricodage File Added: EvolutionsOverview.docx
2017-02-27 10:07 Mr.Bricodage Note Added: 0026039
2017-02-27 14:41 Mr.Bricodage Note Added: 0026044
2017-02-27 18:34 fman Note Added: 0026045
2017-03-22 08:53 Mr.Bricodage Note Added: 0026163
2017-04-02 13:15 Mr.Bricodage File Added: OrderByReq.odt
2017-12-17 13:34 Mr.Bricodage File Added: DocOrderByRequirement.odt
2017-12-17 13:35 Mr.Bricodage Note Added: 0027095
2017-12-26 21:53 Mr.Bricodage Note Added: 0027107
2018-05-14 21:32 Mr.Bricodage Note Added: 0027461
2018-05-15 18:03 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2018-05-15 18:03 fman Status assigned => resolved
2018-05-15 18:03 fman Fixed in Version => 1.9.17 (2018 Q1)
2018-05-15 18:03 fman Resolution open => fixed
2018-10-06 15:41 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker