Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005844TestLinkTest Executepublic2013-08-07 09:502013-09-08 17:53
Reporterfman 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.8 (2013 Q3 - bug fixing) 
Summary0005844: Database crash when trying to execute test case that uses ghost
DescriptionDatabase crash when trying to execute test case that uses ghost
This issue has to be completed by user
TagsNo tags attached.
Database (MySQL,Postgres,etc)N/A
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon TestLink - Mozilla Firefox_2013-08-07_16-55-18.jpg [^] (417,038 bytes) 2013-08-12 01:31
xml file icon ISSUE-5844.testproject-deep.xml [^] (1,826 bytes) 2013-08-12 13:25
jpg file icon testlink db_version.jpg [^] (78,279 bytes) 2013-08-13 02:39


? file icon testlink.sql [^] (659,534 bytes) 2013-08-13 04:59
jpg file icon TestLink - ghostlink.jpg [^] (112,735 bytes) 2013-08-13 10:03

- Relationships
related to 0005763closedfman Test Case Reuse - Ghost - Possibility to get generated ghost string 
child of 0005731closedfman Availables hot-fixes for 1.9.7 & How To get full fixed package from gitorious 

-  Notes
(0019404)
redpiyo (reporter)
2013-08-12 01:31
edited on: 2013-08-12 11:21

Some error happens when executing test cases with ghost link in the steps, please see attached image
1) modify an existing test case with ghost link references to an existing test case I'd
2) goto test execution page
3) try to expand the test suite folder
The folder did not populate its contents and the error outputs as seen in the attached ss

(0019405)
fman (administrator)
2013-08-12 09:53

Please provide steps to reproduce, following guidelines present on www.teamst.org, without requested info ticket will be closed.
(0019406)
fman (administrator)
2013-08-12 13:25
edited on: 2013-08-12 13:29

I will start working on this, but level of details if far from requested.

Test project & Test plan will be ACTIVE AND PUBLIC
1. Uploaded file to be used to create test scenario.
2. create test project using provided XML file
3. create a test plan (TestPlan-A)
4. create a build 1.0
5. add JUST THE TEST CASE that have steps with links to step of other test case.
6. Go to execution
7. navigate tree and click ON TEST CASE => ok
8. navigate tree and click ON TEST SUITE => ok

Tested with latest code from gitorious (1.9.7 + latest fixes)

(0019407)
fman (administrator)
2013-08-12 13:31

There is an issue AFTER you use export testplan that produce error when clicking on test suite, but has nothing to do with ghost steps.
(0019408)
fman (administrator)
2013-08-12 14:11

try with changed provided in 0005854 and provide feedback
(0019414)
fman (administrator)
2013-08-13 08:05

test - using 1.9.7 get from sourceforge WITHOUT ANY FIX
1. create new database redpiyo
2. import provided sql
3. login admin/admin
4. create new testproject TLSupport
5. import xml file icon ISSUE-5844.testproject-deep.xml
6. check that test cases are OK => KO => import has transformed link to ghost step in test with name 'Will use ghost step', in the text.

7. edit Will use ghost step to add again the ghost
8. create custom config file to enable
$tlCfg->exec_cfg->show_testsuite_contents

9. go to test execution
click on test suite TS-100, got NO error but expected screen.


Find you test project 'TeLEOS-1 OBC Sample', enable it
Have same problem with loose of ghost link.
Fix it
go to test execution
click on test suite TS-100, got NO error but expected screen.


Unfortunately seems to be something very weird.


My suggestion is:
Create a test/playground environment, and proceed in this new environment
as I did, using only sql you have provided here.
Then retest and provide feedback.
(0019415)
redpiyo (reporter)
2013-08-13 10:02

Did you applied the patches from
http://gitorious.org/testlink-ga/testlink-code/commit/dbda5a1dd4390210002a58e27fbd6ab20743e697 [^] [^]

My problems came after applying the above mentioned patches, initially there is no issues when using the described steps, after referring to my attached image, with the new ghost link for test case id, even though i only use the ghost from the test case steps which works previously before the patch also crashes the db.

Hope my clarification helps
(0019417)
fman (administrator)
2013-08-13 10:22
edited on: 2013-08-13 10:26

I have done two different tests

test - using 1.9.7 get from sourceforge WITHOUT ANY FIX (and I've clearly detailed this condition on note (0019414)

test - using 1.9.7 with ALL LATEST FIXES (i've not provided this info before)

I never test with what @today are intermediate fixes.
I always do tests on latest code.

Then my suggestion is to test using 1.9.7 with ALL LATEST FIXES

Please next time provide ALL PARTICULAR conditions from issue first reporting,
because without this info (in this case that issue have started AFTER a fix applied) is impossible to provide support, and worst lost of time is wasted on development side

In addition you were using ghost at test case level and not at STEP level.
All this info is mandatory, and only way you can provide it is if you take the time to provide a detailed step by step test case, thing that never happened on the issue report.
I've provided a detailed step by step of my tests, in order to allow you to reproduce. This is the thing I need from reporters always, and this is what all literature regarding issue reporting suggests.


Since you are using TL since 1.9.3, please consider support in some way our work.

(0019475)
redpiyo (reporter)
2013-09-02 10:55

Solved on 1.9.8, required to fully update from 1.9.7 , ported over 1.9.7 DB and was working but if i just applied on the affected files from 1.9.8, still same old issue so i figured this may be due to some dependencies files not updated on intermediate update
(0019519)
fman (administrator)
2013-09-08 17:53

1.9.8 released

- Issue History
Date Modified Username Field Change
2013-08-07 09:50 fman New Issue
2013-08-07 09:51 fman Relationship added related to 0005763
2013-08-12 01:31 redpiyo Note Added: 0019404
2013-08-12 01:31 redpiyo File Added: TestLink - Mozilla Firefox_2013-08-07_16-55-18.jpg
2013-08-12 09:53 fman Note Added: 0019405
2013-08-12 11:21 redpiyo Note Edited: 0019404 View Revisions
2013-08-12 13:25 fman Note Added: 0019406
2013-08-12 13:25 fman File Added: ISSUE-5844.testproject-deep.xml
2013-08-12 13:26 fman Note Edited: 0019406 View Revisions
2013-08-12 13:26 fman Note View State: 0019406: public
2013-08-12 13:29 fman Note Edited: 0019406 View Revisions
2013-08-12 13:31 fman Note Added: 0019407
2013-08-12 14:11 fman Note Added: 0019408
2013-08-12 14:18 fman Assigned To => fman
2013-08-12 14:18 fman Status new => feedback
2013-08-13 02:38 redpiyo Note Added: 0019413
2013-08-13 02:39 redpiyo File Added: testlink db_version.jpg
2013-08-13 04:59 redpiyo File Added: testlink.sql
2013-08-13 05:02 redpiyo Note Edited: 0019413 View Revisions
2013-08-13 05:04 redpiyo Note Edited: 0019413 View Revisions
2013-08-13 08:05 fman Note Added: 0019414
2013-08-13 08:05 fman Status feedback => assigned
2013-08-13 10:02 redpiyo Note Added: 0019415
2013-08-13 10:03 redpiyo File Added: TestLink - ghostlink.jpg
2013-08-13 10:22 fman Note Added: 0019417
2013-08-13 10:23 fman Database (MySQL,Postgres,etc) ? => N/A
2013-08-13 10:26 fman Note Edited: 0019417 View Revisions
2013-08-13 10:29 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-08-13 10:29 fman Status assigned => resolved
2013-08-13 10:29 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)
2013-08-13 10:29 fman Resolution open => fixed
2013-08-13 10:29 fman Relationship added child of 0005731
2013-09-02 07:11 redpiyo Note Deleted: 0019413
2013-09-02 10:55 redpiyo Note Added: 0019475
2013-09-08 17:53 fman Note Added: 0019519
2013-09-08 17:53 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker