Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005842TestLinkImport results XML formatpublic2013-08-06 19:042013-08-08 21:38
Reporteranjelly6 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindows 7OS Version64-bit
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.8 (2013 Q3 - bug fixing) 
Summary0005842: import XML results error test case not found
DescriptionI tried to import XML results using external id, but got error saying test case not found.
Steps To Reproduce1. Click "Test Execution"
2. Click on a test case
3. Click the "Import XML Results" button
4. Upload XML results file (sample attached)

Get error:
Import TestCase data : Test Case MDE-1013 not found in test plan- results are not imported!
Import TestCase data : Test Case MDE-1014 not found in test plan- results are not imported!
Import TestCase data : Test Case MDE-1015 not found in test plan- results are not imported!

However, I checked to make sure that the test cases with the ids MDE-1013, MDE-1014, MDE-1015 are in fact in my test plan.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon sample_xml_results.xml [^] (695 bytes) 2013-08-06 19:04
xml file icon tree_PLAN-A_results.xml [^] (378 bytes) 2013-08-06 21:18
xml file icon TT.xml [^] (314 bytes) 2013-08-07 14:52
png file icon test_plan.PNG [^] (6,693 bytes) 2013-08-07 14:52

- Relationships
duplicate of 0005257closedfman Testcase exported for id/external id not able to import same for result update 
child of 0005731closedfman Availables hot-fixes for 1.9.7 & How To get full fixed package from gitorious 

-  Notes
(0019368)
fman (administrator)
2013-08-06 20:00

information provided is not enough
You have to provide a detailed step by step test case that include
1. test project creation and population (provide XML export to allow import)
2. test plan creation
3. build creation
4. test plan - test case links
5. etc


Please create a test installation and install latest code from gitorious, and retest.
(0019370)
fman (administrator)
2013-08-06 20:19

0005257 -> seems to be a duplicate and already fixed.
can you give a look to 0005257 details?
(0019378)
anjelly6 (reporter)
2013-08-07 14:52

I looked at 0005257, and then I checked my resultsImport.php file and it includes the fix already.

Sorry if the steps weren't clear. Try again please:

1. Create new test project
2. Create new test suite and test case
3. Create new test plan
4. Go to Test Plan Contents -> Add/Remove Test Cases
5. Select the test case you just created and add to test plan
6. Create new build
7. Go to Test Execution
8. Click "Import XML Results"
9. Import the attached XML file ("TT.xml")

Got error:

"Import TestCase data : Test Case TT-1 not found in test plan- results are not imported!"

Also attached pic is proof that the test case TT-1 is in the test plan.
(0019379)
anjelly6 (reporter)
2013-08-07 14:53

I'm using MSSQL, if it helps.
(0019380)
anjelly6 (reporter)
2013-08-07 14:57

And I'm on version TestLink 1.9.7. I don't know what the latest install would be.
(0019381)
anjelly6 (reporter)
2013-08-07 15:15

Also, I have not exported anything, I just wrote the results XML from scratch but carefully following the format as specified in the documentation.
(0019385)
fman (administrator)
2013-08-07 17:56
edited on: 2013-08-07 17:58

>> I don't know what the latest install would be
give a look with attention to issue with 'Availables hot-fixes for 1.9.7' on subject

(0019386)
anjelly6 (reporter)
2013-08-07 21:41

I looked at http://mantis.testlink.org/view.php?id=5731 [^]

I have the latest package http://gitorious.org/testlink-ga/testlink-code/archive-tarball/testlink_1_9 [^]

I got the latest version after it's been released. Theoretically this issue should've already been fixed but it's not. Like I mentioned, I compared my resultsImport.php file with the one here:

http://gitorious.org/testlink-ga/testlink-code/commit/d32e3262cc91f4e714ce6546b479aa0192058754 [^]

And the fix is already included in the file. I could attach it for proof if you want.
(0019389)
fman (administrator)
2013-08-08 21:02

can you provide info you got in TestLink Event viewer ?
(0019390)
fman (administrator)
2013-08-08 21:08
edited on: 2013-08-08 21:38

tests done on MySQL using LATEST CODE on a fresh installation that has a minor change regading DB VERSION but have no impact on this feature.

worked ok.

You have to do a FRESH INSTALL and do all steps indicated on note (0019373)
tested with latest code (20130808 23:34 CET) (after minor correction on MSSQL column definitions)
worked ok
issue will be closed, and not reopened

(0019391)
fman (administrator)
2013-08-08 21:38

tested on MySQL and MSSQL Express on Windows 7

- Issue History
Date Modified Username Field Change
2013-08-06 19:04 anjelly6 New Issue
2013-08-06 19:04 anjelly6 File Added: sample_xml_results.xml
2013-08-06 20:00 fman Note Added: 0019368
2013-08-06 20:01 fman Assigned To => fman
2013-08-06 20:01 fman Status new => feedback
2013-08-06 20:19 fman Note Added: 0019370
2013-08-06 20:19 fman Relationship added duplicate of 0005257
2013-08-06 21:18 fman File Added: tree_PLAN-A_results.xml
2013-08-06 21:21 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-08-06 21:21 fman Status feedback => resolved
2013-08-06 21:21 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)
2013-08-06 21:21 fman Resolution open => fixed
2013-08-06 21:22 fman Note Added: 0019374
2013-08-06 21:22 fman Relationship added child of 0005731
2013-08-06 21:28 fman Note Deleted: 0019374
2013-08-07 14:52 anjelly6 Note Added: 0019378
2013-08-07 14:52 anjelly6 File Added: TT.xml
2013-08-07 14:52 anjelly6 File Added: test_plan.PNG
2013-08-07 14:53 anjelly6 Note Added: 0019379
2013-08-07 14:57 anjelly6 Note Added: 0019380
2013-08-07 15:15 anjelly6 Note Added: 0019381
2013-08-07 17:56 fman Note Added: 0019385
2013-08-07 17:57 fman Note Edited: 0019385 View Revisions
2013-08-07 17:57 fman Status resolved => closed
2013-08-07 17:58 fman Note Edited: 0019385 View Revisions
2013-08-07 21:41 anjelly6 Note Added: 0019386
2013-08-07 21:41 anjelly6 Status closed => assigned
2013-08-07 21:41 anjelly6 Resolution fixed => reopened
2013-08-08 21:02 fman Note Added: 0019389
2013-08-08 21:08 fman Note Added: 0019390
2013-08-08 21:08 fman Status assigned => feedback
2013-08-08 21:36 fman Note Edited: 0019390 View Revisions
2013-08-08 21:38 fman Note Edited: 0019390 View Revisions
2013-08-08 21:38 fman Note Added: 0019391
2013-08-08 21:38 fman Status feedback => closed
2013-08-08 21:38 fman Resolution reopened => fixed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker