Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005817TestLinkRequirement Revisioningpublic2013-07-18 06:302016-12-28 19:04
Reporterteunehv 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformLinuxOSRed HatOS Version4.4.6-3
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0005817: Changes made in requirements aren't saved
DescriptionChanges made in requirements aren't saved after pressing the save button once. The sreen refreshes but the data isn't stored.

After pressing the save button for a second time the popup for a new version te create shows up. After choosing one of the options the data is stored as expected.
Steps To Reproduce1. Create a requirement and save it
2. Open the created requirement and press edit
3. Change one of the present fields (it makes no difference if it's a custom of system field)
4. Press save -> screen refreshes but the changes aren't saved
5. Press save again -> Popup of new version shows up. After choosing one of the options the requirement is saved.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome / IE
PHP Version5.3.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesdocx file icon error saving editing reqs.docx [^] (512,996 bytes) 2013-07-18 06:30

- Relationships

-  Notes
(0019282)
fman (administrator)
2013-07-18 08:38

1. reported do not need to add himself/herself on monitoring.
2. please apply latest fixes, retest and provide feedback.
(0019285)
teunehv (reporter)
2013-07-18 10:09

It seems to be resolved in the latest fixes. But since a non released version I'm not allowed to use it by the organisation.

Any idea which issue is related to this one which is fixed in 1.9.8 so I can determine the differences and patch only a few files?

Other option is to wait for 1.9.8, when is it planned to be released?
(0019317)
teunehv (reporter)
2013-07-23 10:09

Did you missed my questions?
(0019318)
fman (administrator)
2013-07-23 12:25

Options are the usual:

1. get latest code from gitorious , level of risk similar to a release

2. wait for release
(0019541)
fman (administrator)
2013-09-08 17:55

1.9.8 released
(0019598)
teunehv (reporter)
2013-09-11 07:13

I've checked the new version, but somehow the error is still present.
I've cleared the cache after installation and checked multiple browsers.

- Issue History
Date Modified Username Field Change
2013-07-18 06:30 teunehv New Issue
2013-07-18 06:30 teunehv File Added: error saving editing reqs.docx
2013-07-18 08:38 fman Note Added: 0019282
2013-07-18 08:38 fman Assigned To => fman
2013-07-18 08:38 fman Status new => feedback
2013-07-18 10:09 teunehv Note Added: 0019285
2013-07-18 10:09 teunehv Status feedback => assigned
2013-07-20 13:25 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-07-20 13:25 fman Status assigned => resolved
2013-07-20 13:25 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)
2013-07-20 13:25 fman Resolution open => fixed
2013-07-23 10:09 teunehv Note Added: 0019317
2013-07-23 12:25 fman Note Added: 0019318
2013-09-08 17:55 fman Note Added: 0019541
2013-09-08 17:55 fman Status resolved => closed
2013-09-11 07:13 teunehv Note Added: 0019598
2013-09-11 07:13 teunehv Status closed => assigned
2013-09-11 07:13 teunehv Resolution fixed => reopened
2016-12-28 19:04 fman Status assigned => resolved
2016-12-28 19:04 fman Fixed in Version 1.9.8 (2013 Q3 - bug fixing) => 1.9.16 (2016 Q4)
2016-12-28 19:04 fman Resolution reopened => fixed



Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker