Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005808TestLinkTest Executepublic2013-07-10 17:532013-09-08 17:55
Reportertysonh 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformvsphere virtual serverOSLinux Mint 32-bitOS Version
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.8 (2013 Q3 - bug fixing) 
Summary0005808: Test case versions for executed test cases show new version when updated
DescriptionI have a test that was version 1. That test case was executed and was then updated to version 2. I updated the linked test case version so that the new version would be executed for the next build.

When the next build was executed I looked at the Test Report and Metrics -> Test result matrix and noticed that the previous build now showed that version 2 was executed and passed.

Executed tests should retain the version number they were executed with for historical tracking.
Steps To ReproduceCreate a test case.
Create a test plan.
Create a build/release

Add the test case to the test plan.
Execute the test case.
Close the build.
Create a new build.
Update the test case to version 2.
Update the test case/test plan link using Update Linked Test Case Versions
Execute the test case
Close the build

Go to Test Report and Metrics -> Test result matrix

You will now see that the first execution on the first build now showed the test result and version 2 even though it was executed with version 1.

TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserGoogle Chrome 27.0.1453.116 m
PHP Version5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon ISSUSE-5808.testproject-deep.xml [^] (1,264 bytes) 2013-07-13 07:03
xml file icon linkedItems_PLAN_A.xml [^] (936 bytes) 2013-07-13 07:06
png file icon build1.0.still-open.png [^] (25,547 bytes) 2013-07-13 07:26


png file icon build1.0-CLOSED-2.0-open.png [^] (34,588 bytes) 2013-07-13 07:29


png file icon testmatrix-after-version-update-tc-1a.png [^] (34,187 bytes) 2013-07-13 07:35

- Relationships
child of 0005731closedfman Availables hot-fixes for 1.9.7 & How To get full fixed package from gitorious 

-  Notes
(0019243)
fman (administrator)
2013-07-13 07:02
edited on: 2013-07-13 07:02

Added xml files used to create scenario

(0019244)
fman (administrator)
2013-07-13 07:16
edited on: 2013-07-13 07:26

1. Create Test Project
2. import test spec data using ISSUSE-5808.testproject-deep.xml
3. Create a Test Plan (PLAN A, Public & Active)
4. Import data into Test Plan using xml file icon linkedItems_PLAN_A.xml
5. create FIRST BUILD 1.0
6. Assign execution task for all 3 test cases to admin
7. Execute TC1-A:PASSED, TC1-B:FAILED, TC1-C:BLOCKED
8. Get test matrix report => see attached file build1.0.still-open.png

(0019245)
fman (administrator)
2013-07-13 07:27
edited on: 2013-07-13 07:41

9. Close build 1.0
10. Get AGAIN test matrix report, nothing has changed
11. Create build 2.0 (ACTIVE,OPEN)
12. Get AGAIN test matrix report, see attached image build1.0-CLOSED-2.0-open.png

13. CREATE version 2 for each test case
14. update LINKED VERSION to 2 => ONLY for TC-1A
15. Get AGAIN test matrix report
    ERROR GOT!!
    TC-1A is at the bottom of report with V2
    see testmatrix-after-version-update-tc-1a.png

(0019246)
fman (administrator)
2013-07-13 07:53

issues seems to be on
class: tlTestPlanMetrics
method: getExecStatusMatrix()
(0019247)
fman (administrator)
2013-07-13 08:11

Please apply fix,retest and provide feedback

http://gitorious.org/testlink-ga/testlink-code/commit/7bddb18b2e70beacad1d89e4f8815891a3edfd0b [^]
(0019300)
tysonh (reporter)
2013-07-19 15:48

I applied the fix.

I viewed a previously executed test plan that had several test case revisions throughout the execution. The versions are now properly displayed.

This issue is fixed.

GREAT WORK!
(0019543)
fman (administrator)
2013-09-08 17:55

1.9.8 released

- Issue History
Date Modified Username Field Change
2013-07-10 17:53 tysonh New Issue
2013-07-13 07:02 fman Note Added: 0019243
2013-07-13 07:02 fman Note Edited: 0019243 View Revisions
2013-07-13 07:03 fman File Added: ISSUSE-5808.testproject-deep.xml
2013-07-13 07:06 fman File Added: linkedItems_PLAN_A.xml
2013-07-13 07:16 fman Note Added: 0019244
2013-07-13 07:26 fman File Added: build1.0.still-open.png
2013-07-13 07:26 fman Note Edited: 0019244 View Revisions
2013-07-13 07:27 fman Note Added: 0019245
2013-07-13 07:28 fman Note Edited: 0019245 View Revisions
2013-07-13 07:29 fman File Added: build1.0-CLOSED-2.0-open.png
2013-07-13 07:29 fman Note Edited: 0019245 View Revisions
2013-07-13 07:30 fman Note Edited: 0019245 View Revisions
2013-07-13 07:33 fman Note Edited: 0019245 View Revisions
2013-07-13 07:35 fman Note Edited: 0019245 View Revisions
2013-07-13 07:35 fman File Added: testmatrix-after-version-update-tc-1a.png
2013-07-13 07:36 fman Note Edited: 0019245 View Revisions
2013-07-13 07:37 fman Note Edited: 0019245 View Revisions
2013-07-13 07:41 fman Note Edited: 0019245 View Revisions
2013-07-13 07:41 fman Note View State: 0019245: public
2013-07-13 07:41 fman Assigned To => fman
2013-07-13 07:41 fman Status new => acknowledged
2013-07-13 07:53 fman Note Added: 0019246
2013-07-13 08:11 fman Note Added: 0019247
2013-07-13 08:11 fman Status acknowledged => feedback
2013-07-13 08:11 fman Relationship added child of 0005731
2013-07-18 18:43 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-07-18 18:43 fman Status feedback => resolved
2013-07-18 18:43 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)
2013-07-18 18:43 fman Resolution open => fixed
2013-07-19 15:48 tysonh Note Added: 0019300
2013-09-08 17:55 fman Note Added: 0019543
2013-09-08 17:55 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker