Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005788TestLinkTest Plan - Assign Test Case Executionpublic2013-06-24 08:572013-09-08 17:55
ReporterSSO_TL 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows ServerOS2008OS VersionR2
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.8 (2013 Q3 - bug fixing) 
Summary0005788: test case execution order not working on RIGHT PANE
DescriptionSetting test case execution order different to order according to test case ID does not work
Steps To Reproduce1. Create Test Plan "Test Image"
2. Create Build "First Test"
3. Choose "add/remove test cases" on home page. Select Test Cases for Build "First Test" in Test Plan "Test Image" and add to Test Plan by selecting test cases and confirming "add/remove selected test cases"
4. Set test cases to different execution order by typing numbers 1,2,3,4 into text field "execution order" and then confirming "save order"
5. Choose "assign test cases to user" on home page. Assign the test cases to a specific tester.
6. login as tester(see 5.)
7. Choose assigned test cases. The test cases are not displayed in the new order (see 4.). They are sorted according to their TestLink-ID.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE 8
PHP Version5.4.7
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0005731closedfman Availables hot-fixes for 1.9.7 & How To get full fixed package from gitorious 

-  Notes
(0019194)
fman (administrator)
2013-07-01 21:06

subject and description are incomplete.
You do not specify clearly where execution order is not honored
Please provide detailed step by steps to reproduce in this way

1. create test project TPRJ5788
2. create a test suite TS100
3. create TC1,TC2,TC3,TC4
4. bla, bla
5. ...
(0019219)
fman (administrator)
2013-07-06 08:07

Just for the records
>> 7. Choose assigned test cases.
>> The test cases are not displayed in the new order (see 4.).
>> They are sorted according to their TestLink-ID.

is an incomplete description, because what is happening is:
on Left side pane where there is the tree, order is OK
on Right side pane order is wrong.
This kind of info reduce the dev team work, and is info reported had,and has to provide
(0019220)
fman (administrator)
2013-07-06 08:17

http://gitorious.org/testlink-ga/testlink-code/commit/12a9e2acdb13f39c3bffa577bbf1d0af253ed2a0 [^]
(0019549)
fman (administrator)
2013-09-08 17:55

1.9.8 released

- Issue History
Date Modified Username Field Change
2013-06-24 08:57 SSO_TL New Issue
2013-07-01 21:06 fman Note Added: 0019194
2013-07-06 08:07 fman Note Added: 0019219
2013-07-06 08:07 fman Summary test case execution order not working => test case execution order not working on RIGHT PANE
2013-07-06 08:16 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-07-06 08:16 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)
2013-07-06 08:17 fman Note Added: 0019220
2013-07-06 08:17 fman Status new => resolved
2013-07-06 08:17 fman Resolution open => fixed
2013-07-06 08:17 fman Assigned To => fman
2013-07-06 08:17 fman Relationship added child of 0005731
2013-09-08 17:55 fman Note Added: 0019549
2013-09-08 17:55 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker