Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005764TestLinkReportspublic2013-06-06 07:392013-09-08 17:55
Reporterseajays 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionServer 2003
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.8 (2013 Q3 - bug fixing) 
Summary0005764: Browsers IE - OPERA / Clicking report direct link opens file "Save As" dialog
DescriptionWhen I try to use a direct report link (using the API key), I can use the link normally in Firefox, and it correctly opens the report, however, when I try to use the same API link in Opera or IE (8), I get a save as fialog box instead of opening the HTML page. This save as downloads the HTML page.
Steps To ReproduceCopy the API link report URL for example the Results Matrix:

http://myserver.co.uk:8080/testlink/lnl.php?apikey=fbe7ffe4f2e5fde8f25e31b381331240d5&tproject_id=38&tplan_id=1792&type=results_matrix [^]

Open a new browser, such as IE/Opera, paste the link into the address bar. The browser will ask you to download a file instead of displaying the page.
Additional InformationAttached screenshot from IE.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserTested in IE8/Opera
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon greenshot_2013-06-06_08-30-16.png [^] (19,519 bytes) 2013-06-06 07:39

- Relationships
child of 0005731closedfman Availables hot-fixes for 1.9.7 & How To get full fixed package from gitorious 

-  Notes
(0019105)
fman (administrator)
2013-06-06 20:21

Unfortunately I can not thinka about supporting all browsers.
Main tests are done with firefox latest version and chrome.
Opera is out of scope.
I will try to check what happens with IE
(0019108)
fman (administrator)
2013-06-06 21:03
edited on: 2013-06-06 21:05

implementation uses a custom function redirect(), that uses a javascript function.
Seems that other product have had issues with opera:

googled for opera redirect bug

http://stackoverflow.com/questions/14275237/codeigniter-redirect-doesnt-work-in-opera-browser [^]

http://stackoverflow.com/questions/4118313/how-to-do-redirect-via-header-in-opera [^]

Still think no action will be taken for opera.

(0019110)
seajays (reporter)
2013-06-07 07:44

The problem isn't the browser... it appears testlink is setting an invalid content type in the header - see last line below - it should of course be

Content-Type: text/html
    but instead is
Content-Type: ; name='Testlink_'
--

HTTP/1.1 200 OK
Date: Fri, 07 Jun 2013 07:42:18 GMT
Server: Apache/2.2.22 (Win32) PHP/5.4.6
X-Powered-By: PHP/5.4.6
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Content-Description: TestLink - Generated Document
Keep-Alive: timeout=5, max=88
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: ; name='Testlink_'
(0019112)
fman (administrator)
2013-06-07 10:08

with info now I can try to find a solution, but no code inside TestLink is Setting content type (in a explicit way).
Will see if this can be forced.

On my searches regarding this kind of issues Opera has been always indicated as guilty
(0019113)
seajays (reporter)
2013-06-07 11:22

That header info is from Firefox - but it is obviouly handling the incorrect content-type by ignoring it - other browers like IE and Opera seem to be asking for download.
(0019118)
fman (administrator)
2013-06-07 18:39

Got this info

http://msdn.microsoft.com/en-us/library/system.net.mime.contenttype.name.aspx [^]

In the following example of a Content-Type header, the value of the Name property is "data.xyz".

content-type: application/x-myType; name=data.xyz

A grammar that details the syntax of the Content-Type header is described in RFC 2045 Section 5.1, available at http://www.ietf.org. [^]

When specifying content for a Attachment as a Stream or String, you can use Name to set the name of the file that stores the content on the recipient's system.
(0019119)
fman (administrator)
2013-06-07 18:53

http://gitorious.org/testlink-ga/testlink-code/commit/2a608935f217c5e15230a6dcd5126eef82e93ab8 [^]
(0019120)
fman (administrator)
2013-06-07 18:54

please retest an provide feedback. Tested on fedora 18 64 bits with latest Opera version (downloaded 20130606)
(0019128)
seajays (reporter)
2013-06-11 11:01

This fixes it for me in both IE and Opera. :) Thanks.
(0019558)
fman (administrator)
2013-09-08 17:55

1.9.8 released

- Issue History
Date Modified Username Field Change
2013-06-06 07:39 seajays New Issue
2013-06-06 07:39 seajays File Added: greenshot_2013-06-06_08-30-16.png
2013-06-06 20:21 fman Note Added: 0019105
2013-06-06 21:03 fman Note Added: 0019108
2013-06-06 21:05 fman Note Edited: 0019108 View Revisions
2013-06-06 21:05 fman Assigned To => fman
2013-06-06 21:05 fman Status new => feedback
2013-06-07 05:16 fman Summary Clicking report direct link opens file "Save As" dialog in IE/Opera => Browsers IE - OPERA / Clicking report direct link opens file "Save As" dialog
2013-06-07 07:44 seajays Note Added: 0019110
2013-06-07 07:44 seajays Status feedback => assigned
2013-06-07 10:08 fman Note Added: 0019112
2013-06-07 11:22 seajays Note Added: 0019113
2013-06-07 18:39 fman Note Added: 0019118
2013-06-07 18:53 fman Note Added: 0019119
2013-06-07 18:54 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-06-07 18:54 fman Note Added: 0019120
2013-06-07 18:54 fman Status assigned => resolved
2013-06-07 18:54 fman Resolution open => fixed
2013-06-11 11:01 seajays Note Added: 0019128
2013-06-12 20:59 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)
2013-06-14 18:50 fman Relationship added child of 0005731
2013-09-08 17:55 fman Note Added: 0019558
2013-09-08 17:55 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker