Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005746TestLinkUsers and Rightspublic2013-05-28 10:152014-03-13 21:27
Reportertwelve 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.7 (2013 Q2 - bug fixing) 
Fixed in Version1.9.8 (2013 Q3 - bug fixing) 
Summary0005746: Cannot set new rights after upgrade
DescriptionAfter upgrading to Testlink 1.9.7 and performing the database upgrade I cannot set the following role rights:
Unlink Executed Test Cases
Delete Executed Test Cases
Edit Executed Test Cases
Edit Execution Notes
Delete Execution

Also the admin role does not have any of these rights and it is impossible to enable them through the GUI, because they are all greyed out.

The same problem appears when using Testlink 1.9 HEAD (from http://gitorious.org/testlink-ga/testlink-code/archive-tarball/testlink_1_9 [^])
Steps To Reproduce1. Upgrade an earlier version to Testlink 1.9.7
2. Log in as an admin
3. Click User management > View roles
4. Open a role
5. Enable "Unlink Executed Test Cases"
6. Click Save
7. Open the same role again
=> "Unlink Executed Test Cases" is unchecked
Additional InformationThe new rights of 0005311 should be added to the database upgrade scripts.

Something like:
INSERT INTO /*prefix*/rights (id,description) VALUES (35,'exec_edit_notes');
INSERT INTO /*prefix*/role_rights (role_id,right_id) VALUES (8,35);
INSERT INTO /*prefix*/rights (id,description) VALUES (36,'exec_delete');
INSERT INTO /*prefix*/role_rights (role_id,right_id) VALUES (8,36);
...
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006250closedfman Cannot set new rights after upgrade to 1.9.8 
child of 0005731closedfman Availables hot-fixes for 1.9.7 & How To get full fixed package from gitorious 

-  Notes
(0019051)
fman (administrator)
2013-05-28 20:04

yes you are right without this records you can not add the rights.
I'm sorry for missing info.
(0019366)
jason.helm (reporter)
2013-08-06 18:42
edited on: 2013-08-06 18:43

Because the config file setting for this is no longer honored in favor of the new UI, and because the UI cannot be changed, these features have effectively been lost. Of particular concern to our organization is the ability to Delete Executed Test Cases. Due to complete feature loss, I would like to see the priority set to something a big higher than "minor". In the meantime, could you attach a DB script that will fix this (if it is, indeed, simply a DB issue)? Thank you!

(0019367)
fman (administrator)
2013-08-06 19:54

all the info you need have been kindly provided by original reporter.
that's why this issue has priority minor.
(0019533)
fman (administrator)
2013-09-08 17:53

1.9.8 released

- Issue History
Date Modified Username Field Change
2013-05-28 10:15 twelve New Issue
2013-05-28 20:04 fman Note Added: 0019051
2013-08-06 18:42 jason.helm Note Added: 0019366
2013-08-06 18:43 jason.helm Note Edited: 0019366 View Revisions
2013-08-06 19:54 fman Note Added: 0019367
2013-08-06 20:16 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-08-06 20:16 fman Fixed in Version => 1.9.8 (2013 Q3 - bug fixing)
2013-08-06 20:16 fman Relationship added child of 0005731
2013-08-08 21:41 fman Status new => resolved
2013-08-08 21:41 fman Resolution open => fixed
2013-08-08 21:41 fman Assigned To => fman
2013-09-08 17:53 fman Note Added: 0019533
2013-09-08 17:53 fman Status resolved => closed
2014-03-13 21:27 fman Relationship added related to 0006250



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker