Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005712TestLinkGeneralpublic2013-05-14 15:382013-05-22 20:56
Reporteraostad 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSServer 2008OS VersionR2
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005712: Missing files from lib/API
DescriptionSome file especially APIkey.php is missing from lib\api folder causing "MySetting" fails to open.

Although by copying APIkey.php it works, but I have copied all files from testlink1.9.5\lib\api to 1.9.6:

APIErrors.php
APIkey.php
xmlrpc.class.php
api.const.inc
TagsNo tags attached.
Database (MySQL,Postgres,etc)mssql server 2008
Browserany
PHP Version5.3
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0018955)
fman (administrator)
2013-05-14 18:59

Seems very strange because on 1.9.6 (you can give a look to repository on gitorious) APIkey.php is present on lib\api.

During some development stage, there were this issue but with code present on latest code on gitorious.

Can you confirm that getting 1.9.6 from sourceforge the file is missing ?

(0018956)
aostad (reporter)
2013-05-14 22:21

Still missing.

- Issue History
Date Modified Username Field Change
2013-05-14 15:38 aostad New Issue
2013-05-14 18:44 fman Status new => resolved
2013-05-14 18:44 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-14 18:44 fman Resolution open => fixed
2013-05-14 18:44 fman Assigned To => fman
2013-05-14 18:59 fman Note Added: 0018955
2013-05-14 22:21 aostad Note Added: 0018956
2013-05-14 22:21 aostad Status resolved => assigned
2013-05-14 22:21 aostad Resolution fixed => reopened
2013-05-15 07:17 fman Status assigned => resolved
2013-05-15 07:17 fman Resolution reopened => fixed
2013-05-22 20:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker