Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005696TestLinkTest Specificationpublic2013-05-07 20:592013-05-22 20:56
Reporterjamiep 
Assigned Tofman 
PriorityhighSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005696: Add "Copy as Ghost" button to "Move / Copy Test Case" page.
DescriptionOn the page "Move / Copy Test Case" add next to the "Move" and "Copy" buttons a "Copy as Ghost" button which will copy all the test case steps with the [ghost] sytax.

Steps To ReproduceGo to page
"Move / Copy Test Case
Move Test Case to a different Test Suite.
Copy Test Case to any Test Suite.
Important: You can only choose Test Suites belonging to this Test Project.

Choose Test Suite

 Copy Keyword Assignments
 Copy Requirement Assignments

Destination position top
Destination position bottom"
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL and Postgres
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon first-impl.png [^] (30,702 bytes) 2013-05-08 21:52


png file icon ontcase-page.png [^] (20,856 bytes) 2013-05-09 05:55

- Relationships
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0018906)
fman (administrator)
2013-05-07 21:09

1. please explain with more details what has to happen, what is the use case, because is not clear (at least for me)
2. give a look to 0005697, may be can solve part of your request
(0018907)
fman (administrator)
2013-05-07 21:14

ok just got the idea.
(0018908)
fman (administrator)
2013-05-08 06:12
edited on: 2013-05-08 06:15

Important Thing:
Normal copy operation copy (to be cheched) all test case versions, the 'Copy with Ghost Steps' is going to use as version reference LATEST no matter if test case version is active or not ?
Given a look to the code the simplest (Quick & Dirty) solution is to copy ALL test case version, using GHOST for each version on step action and expected result,

(0018909)
jamiep (reporter)
2013-05-08 06:23

Ghosting the latest version will be the normally desired result.

Is LATEST a keyword?

For example
[ghost]"Step":1,"TestCase":"TRAIN-7 ","Version":LATEST[/ghost]
(0018910)
fman (administrator)
2013-05-08 09:08

I think latest is not managed will check
(0018913)
fman (administrator)
2013-05-08 21:52

first implementation available FROM TEST CASE OPERATIONS see attached image.
please test and provide feedback
(0018914)
fman (administrator)
2013-05-08 21:54

http://gitorious.org/testlink-ga/testlink-code/commit/c3c39193fc1e939590734416305d3cc0d8f17fcb [^]
(0018915)
jamiep (reporter)
2013-05-08 21:56
edited on: 2013-05-08 21:57

I will test.

Issue I reliased is when New version is made. I will test the following workaround.

Once Versioning happens all the Ghost links will be broken so the workaround process will have to be make a master test suite that is never executed to ghost from. It will be just a library of shared steps.

This loses the benefit of Test Case versioning but ghosting is a bigger productivity gain.

(0018916)
fman (administrator)
2013-05-08 22:06

>> Once Versioning happens all the Ghost links will be broken
>> so the workaround process will have to be make a master
>> test suite that is never executed to ghost from.
>> It will be just a library of shared steps.
yes this is some kind of approach I've started to use.
Because you can point steps of test cases that belong to OTHER TEST PROJECT instead of having a master test suite that you use to provide reuse you can use a DIFFERENT TEST PROJECT named TEST REUSE or COMMON TESTS (what a great fantasy:))

Implementation use ONLY the latest version of test case been copied.
(0018917)
fman (administrator)
2013-05-09 05:56

http://gitorious.org/testlink-ga/testlink-code/commit/252b777569d85f85bb4721df05d2ecdbf70ff9e2 [^]
(0018921)
jamiep (reporter)
2013-05-09 06:27

Work OK.

Not sure of performance implications of allowing a Ghost Copy of a Test Case that is already Ghosted.

- Issue History
Date Modified Username Field Change
2013-05-07 20:59 jamiep New Issue
2013-05-07 21:09 fman Note Added: 0018906
2013-05-07 21:14 fman Note Added: 0018907
2013-05-08 06:12 fman Note Added: 0018908
2013-05-08 06:15 fman Note Edited: 0018908 View Revisions
2013-05-08 06:23 jamiep Note Added: 0018909
2013-05-08 09:08 fman Note Added: 0018910
2013-05-08 21:52 fman File Added: first-impl.png
2013-05-08 21:52 fman Note Added: 0018913
2013-05-08 21:54 fman Note Added: 0018914
2013-05-08 21:55 fman Assigned To => fman
2013-05-08 21:55 fman Status new => assigned
2013-05-08 21:56 jamiep Note Added: 0018915
2013-05-08 21:57 jamiep Note Edited: 0018915 View Revisions
2013-05-08 22:06 fman Note Added: 0018916
2013-05-09 05:55 fman File Added: ontcase-page.png
2013-05-09 05:56 fman Tag Attached: TO BE FIXED on 2.0
2013-05-09 05:56 fman Note Added: 0018917
2013-05-09 05:57 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-05-09 05:57 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-09 05:57 fman Relationship added child of 0005551
2013-05-09 05:57 fman Status assigned => feedback
2013-05-09 06:27 jamiep Note Added: 0018921
2013-05-09 06:27 jamiep Status feedback => assigned
2013-05-11 17:24 fman Status assigned => resolved
2013-05-11 17:24 fman Resolution open => fixed
2013-05-22 20:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker