Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005694TestLinkTest Specificationpublic2013-05-06 09:532013-05-22 20:56
Reporterjamiep 
Assigned Tofman 
PrioritynoneSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005694: Shared Step corrupts whole Test Case pane
DescriptionInserting text [ghost]"Step":1,"TestCase":"DXI-1","Version":1[/ghost] corrupts right pane, see screenshot.
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon 37d5adb8a3e740418d114ab46c1b46ac.png [^] (54,206 bytes) 2013-05-06 09:53

- Relationships
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0018878)
jamiep (reporter)
2013-05-06 10:05

Sorry this should not of been a feature request by a minor bug I replicated 3 times.

P.S I tried to click on the link "Make a donation to the TestLink community" and the hyperlink fails!
(0018880)
fman (administrator)
2013-05-06 13:20

For donations => contact francisco.mancardi@gmail.com for instructions
(0018881)
fman (administrator)
2013-05-06 13:26

Do you have a test case identified by 'DXI-1' ?
[ghost]"Step":1,"TestCase":"DXI-1","Version":1[/ghost]

if not system is going to crash

You have to reference an existent test case, step and version
(0018888)
fman (administrator)
2013-05-06 18:32

try / catch added to allow access to testcase in order to fix it
(0018889)
fman (administrator)
2013-05-06 18:34

http://gitorious.org/testlink-ga/testlink-code/commit/7245f18c4e6e7410b15959810ef7a39c638365cf [^]
(0018891)
jamiep (reporter)
2013-05-06 18:37

Thanks, I will test.
I was already using a valid Test Case name, I could not paste original example here since pane had disappeared. If crash is fixed then the reported bug is fixed.
If there is syntax mistake by my it will be easier to troubleshoot now.
(0018893)
fman (administrator)
2013-05-06 18:40

On my development env, I got an exception not blank screen but may be this depends on ERROR levels of PHP

>> I was already using a valid Test Case name, I could not paste original
>> example here since pane ...
ok but using as additional info the example we have put on forum is a little bit misleading
(0018894)
jamiep (reporter)
2013-05-07 01:19

Confirm fixed. Displays error message instead of blank screen now.

- Issue History
Date Modified Username Field Change
2013-05-06 09:53 jamiep New Issue
2013-05-06 09:53 jamiep File Added: 37d5adb8a3e740418d114ab46c1b46ac.png
2013-05-06 10:05 jamiep Note Added: 0018878
2013-05-06 13:20 fman Note Added: 0018880
2013-05-06 13:26 fman Note Added: 0018881
2013-05-06 18:32 fman Note Added: 0018888
2013-05-06 18:32 fman QA Team - Task Workflow Status => READY FOR TESTING
2013-05-06 18:32 fman Product Version => 1.9.6 (2013 Q1 - bug fixing)
2013-05-06 18:32 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-06 18:32 fman Description Updated View Revisions
2013-05-06 18:33 fman Tag Attached: TO BE FIXED on 2.0
2013-05-06 18:34 fman Note Added: 0018889
2013-05-06 18:34 fman Relationship added child of 0005551
2013-05-06 18:34 fman Severity feature request => crash
2013-05-06 18:34 fman Status new => resolved
2013-05-06 18:34 fman Resolution open => fixed
2013-05-06 18:34 fman Assigned To => fman
2013-05-06 18:37 jamiep Note Added: 0018891
2013-05-06 18:40 fman Note Added: 0018893
2013-05-07 01:19 jamiep Note Added: 0018894
2013-05-22 20:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker