Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005682TestLinkUser Interface Generalpublic2013-05-02 22:262013-05-22 20:57
Reporteraostad 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSserver 2008OS VersionR2
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005682: MSSQL - The user management page is displayed incorrectly
DescriptionSome information in user management page are missing and some are duplicated.

First name and last name are duplicated. email address is missing.
Steps To ReproduceCreate a couple users with all information (Fname, Lname, login, email)
Go to user management page and check out the users.
TagsMSSQL ADODB PHP, TO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MSSQL 2008
BrowserAny
PHP Version5.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon UserManagementPage_Issue.jpg [^] (56,430 bytes) 2013-05-02 22:26

- Relationships
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0018860)
aostad (reporter)
2013-05-03 17:25

I have installed the latest fix yesterday (May 02). But the issue still shows up.

The version that I have installed includes your last committed code:

    22:20
    avatar
    fman committed 5d511fc
    TICKET 5679: Login page - use of HTML5 required attribute

    19:40
    avatar
    fman committed 0b7092f
    missing piece on check to understand if platform column has to be displayed
(0018861)
fman (administrator)
2013-05-03 18:38

Tested on fedora 18 64bits with mysql using XAMPP 1.8.1 => unable to reproduce

These are the Paths that you can follow to find a solution

1. install XAMPP on windows this will provide an env similar to used to test (no MSSQL no IIS) and retest.
Do fresh install with latest code from gitorious

2. repeat same test using MSSQL.

Do not have similar environment to test.
(0018870)
fman (administrator)
2013-05-05 14:25

Related to PHP ADODB FETCH mode TestLink uses for MSSQL.
In next releases (if we can find people available to test on MSSQL) we can try to change the mode.
(0018871)
fman (administrator)
2013-05-05 14:26

http://gitorious.org/testlink-ga/testlink-code/commit/fd403b2cf7b4efd6ff337d7921fe567f6626e3f9 [^]
(0018872)
aostad (reporter)
2013-05-05 17:06

Thanks. It works now.

- Issue History
Date Modified Username Field Change
2013-05-02 22:26 aostad New Issue
2013-05-02 22:26 aostad File Added: UserManagementPage_Issue.jpg
2013-05-03 07:52 fman Status new => resolved
2013-05-03 07:52 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-03 07:52 fman Resolution open => fixed
2013-05-03 07:52 fman Assigned To => fman
2013-05-03 17:25 aostad Note Added: 0018860
2013-05-03 17:25 aostad Status resolved => assigned
2013-05-03 17:25 aostad Resolution fixed => reopened
2013-05-03 18:38 fman Note Added: 0018861
2013-05-03 18:58 aostad Note Added: 0018864
2013-05-05 14:23 fman Summary The user management page is displayed incorrectly => MSSQL - The user management page is displayed incorrectly
2013-05-05 14:24 fman Note Deleted: 0018864
2013-05-05 14:25 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-05-05 14:25 fman Note Added: 0018870
2013-05-05 14:25 fman Status assigned => resolved
2013-05-05 14:25 fman Resolution reopened => fixed
2013-05-05 14:26 fman Tag Attached: TO BE FIXED on 2.0
2013-05-05 14:26 fman Tag Attached: MSSQL ADODB PHP
2013-05-05 14:26 fman Note Added: 0018871
2013-05-05 14:27 fman Relationship added child of 0005551
2013-05-05 17:06 aostad Note Added: 0018872
2013-05-22 20:57 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker