Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005681TestLinkTest Execute - Filterspublic2013-05-02 22:162013-05-22 20:57
Reporteraostad 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformWindowsOSServer 2008OS VersionR2
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005681: Test cases are not filtered based on platform
DescriptionAll test cases are shown regardless of what platform is selected.
Steps To Reproduce1 Create a couple platforms
2 Assign test cases with platforms to a test plan
3 Go to execution page
4 try to filter test cases based on platform.

You will notice all test cases are displayed regardless of what platform is selected.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL 2008
BrowserAny
PHP Version5.3
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
related to 0005572closedfman Filter by Platforms - Wrong test case state count in test plan execution 

-  Notes
(0018856)
fman (administrator)
2013-05-03 07:51

wrong category
(0018862)
fman (administrator)
2013-05-03 18:43
edited on: 2013-05-03 18:44

1. no info about errors (obviously that have any relation to this issue) provided
2. tested with latest code from gitoriuos repo on fedora 18 using XAMP 1.8.1 => unable to reproduce

do not have windows env to test.
can be some strange effect on query on MSSQL

(0018866)
aostad (reporter)
2013-05-03 21:12

This is fixed in your latest fixed-version. I've installed it and the issue doesn't show up any more. So you may close it.
(0018867)
fman (administrator)
2013-05-04 06:56

can not other thing that complain about not searching for duplicates
5572: Filter by Platforms

doing the simple check helps to

1. avoid duplicated issues
2. waste time in retest

- Issue History
Date Modified Username Field Change
2013-05-02 22:16 aostad New Issue
2013-05-03 07:51 fman Note Added: 0018856
2013-05-03 07:51 fman Category Inventory / Platforms => Test Execute - Filters
2013-05-03 18:43 fman Note Added: 0018862
2013-05-03 18:44 fman Assigned To => fman
2013-05-03 18:44 fman Status new => assigned
2013-05-03 18:44 fman Note Edited: 0018862 View Revisions
2013-05-03 21:12 aostad Note Added: 0018866
2013-05-04 06:54 fman Status assigned => resolved
2013-05-04 06:54 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-04 06:54 fman Resolution open => fixed
2013-05-04 06:56 fman Note Added: 0018867
2013-05-04 06:56 fman Relationship added related to 0005572
2013-05-04 06:56 fman Resolution fixed => duplicate
2013-05-22 20:57 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker