Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005664TestLinkTest Executepublic2013-04-26 18:572013-05-22 20:57
Reportermattiamorales 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005664: The tags that indicate the build version in “Execution history” are wrong on “Test Execution” tab
DescriptionAs you can see in the pictures below, though I’ve selected “Build 1” in “Build to execute” combo box, the div component “execution_history” shows “Last execution (current build) - Build : Build 2” instead (“Last execution (current build) - Build : Build 1” would be the correct label). And I’ve got the same problem if I select “Show complete execution history”…
It seems a detail, so I wonder what line (or lines) should I modify to fix it?
Steps To Reproduce1) Execute a Test Case (on Build 1).
2) Execute the same Test Case with another build (Build 2).
3) Select the first build (Build 1) on Test Execution tab and then observe the tag (“Last execution (current build) - Build : Build 1”) to find the mistake.
4) Select "Show complete execution history" and look for the "Execution history - Build: Build 2" label. There's the error again.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon Dibujo.bmp [^] (1,278,754 bytes) 2013-04-26 18:57
jpg file icon Errores de etiqueta en pestaña de ejecuciones.jpg [^] (126,577 bytes) 2013-04-27 00:14

- Relationships

-  Notes
(0018785)
fman (administrator)
2013-04-26 19:45
edited on: 2013-04-26 19:48

1. Please for images use ONLY jpg or png
2. if
>> It seems a detail, so I wonder what line (or lines) should I modify to fix it?
you have to find the lines by yourself.

Normally I need a good issue reporting and then I will try to verify is issue exists and fix it.

Please improve your issue details adding clear info like

1. execute on build 1 , with status PASSED
2. execute on build 2 - with status BLOCKED
then instead of talking about ' ... the mistake ..', explain clearly without
any possibility of misunderstanding what is the mistake, i.e.
expected result is XXX, actual result is GGGG

(0018787)
mattiamorales (reporter)
2013-04-27 00:13
edited on: 2013-04-27 00:22

The error is independent of the status that you select on execution time for the test case. And it’s independent of the Test Cast that you choose too.

I’m sorry if the “It seems a detail” sounds offensive; it wasn’t the intension at all. I mean that it seems something minor, like a confusion on the variable that is used on the “.tpl” file. Or wherever the html code is contained (I'm not a programmer).

I don’t know if you saw the picture, but I think the image per se is clear enough...

Example: suppose that test case A was executed two times on two different builds, build X and build Y. Suppose that the last time Test Case A was executed, it was on build X.

After that, if you select build Y in combo “Build” (in “Settings” section of “Test Execution” tab), and then the test case A, you’re going to see the correct information in the “Execution History” but with a wrong title.

Please look the picture (I've just uploaded it again in jpg format).

(0018789)
fman (administrator)
2013-04-27 07:44
edited on: 2013-04-27 07:46

I want to be absolute clear:
I want clear step by step with details I've requested.
I do not want pictures and nothing more.

Then if you are not able to provide the requested details, unfortunately I will close this issue with
unable to reproduce + user has not provided requested feedback

We are wasting lot of time just because you are not willing to provide the information requested in the format that is useful for developer team.

(0018794)
mattiamorales (reporter)
2013-04-29 14:08

The steps are the following:

1) Execute a Test Case on a Build, in this case “Build 1”, with any status.

2) Execute the same Test Case with another build “Build 2”, again with any status.

3) Select the first build (“Build 1”) on Test Execution tab in the combo box “Build to execute” . On Last execution (current build) should show “Build 1” instead of “Build 2”.

4) Now select the option “Show complete execution history”, Build to execute “Build 1”. Instead of saying “Execution history – Build : Build 2”, should say “Execution history – Build : Build 1”.

- Issue History
Date Modified Username Field Change
2013-04-26 18:57 mattiamorales New Issue
2013-04-26 18:57 mattiamorales File Added: Dibujo.bmp
2013-04-26 19:45 fman Note Added: 0018785
2013-04-26 19:48 fman Note Edited: 0018785 View Revisions
2013-04-26 19:48 fman Status new => feedback
2013-04-27 00:13 mattiamorales Note Added: 0018787
2013-04-27 00:13 mattiamorales Status feedback => new
2013-04-27 00:14 mattiamorales File Added: Errores de etiqueta en pestaña de ejecuciones.jpg
2013-04-27 00:15 mattiamorales Note Edited: 0018787 View Revisions
2013-04-27 00:22 mattiamorales Note Edited: 0018787 View Revisions
2013-04-27 00:22 mattiamorales Note Edited: 0018787 View Revisions
2013-04-27 07:44 fman Note Added: 0018789
2013-04-27 07:44 fman Priority high => normal
2013-04-27 07:46 fman Note Edited: 0018789 View Revisions
2013-04-29 14:08 mattiamorales Note Added: 0018794
2013-05-01 12:04 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-05-01 12:04 fman Status new => resolved
2013-05-01 12:04 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-01 12:04 fman Resolution open => fixed
2013-05-01 12:04 fman Assigned To => fman
2013-05-22 20:57 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker