Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005663TestLinkBug Tracking System - JIRA Integrationpublic2013-04-26 11:532013-05-22 20:56
ReporterLucy 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005663: Manage the fields thate are filled in the Jira issue and the data in them
DescriptionProvide a way (or a least a tutorital how to make changes in the code) to manage the data filled in the fields of the created Jira issue e.g. to fill the build as an Affected version, the user who executed the test as Reporter (because the SOAP configuration keeps the password in plain text and it's not a safe option).
Also give explanation about the id-s of the attributes and components needed in the configuration xml, because it's not clear what exactly to do with them.
Additional InformationI already tried some changes in the code but nothing worked.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0018783)
fman (administrator)
2013-04-26 13:11
edited on: 2013-04-26 13:23

Regarding
>> the user who executed the test as Reporter
IMHO this neither critic nor important.

>> Also give explanation about the id-s of the attributes and components needed >> in the configuration xml, because it's not clear what exactly to do with them.
unfortunately this request is far from clear.
You have to ask in a very,very detailed way in order to have any chance to recieve a answer.

I can not provide a tutorial to make changes to code, changes to be done are not hard to do, if you do some debug on code.

I've provided basic integration and because I'm not a JIRA user, i think more info can be produced by people like you that use JIRA everyday.
IMHO issue creation from TestLink has to be viewed as creation of a Draft o Blue print of issue, that will need manual rework on the right tool i.e. the bug tracking system.

In the XML CFG that you got when doing the config, IMHO there is all
info you need alt least to provide other issue attributes.

You can use forum www.teamst.org to contact other real world JIRA users.

Last word:
'Please provide ...' , or ' It would be great if ..', is IMHO a lot better than 'Provide ...'

(0018792)
fman (administrator)
2013-04-28 08:46

You can manage by yourself all information you want without any development if you choose instead of CREATE ISSUE, the LINK ISSUE OPTION.
This way you can access to JIRA and using JIRA GUI provide all info.
Only drawback: you need to provide manually the JIRA ID to TestLink
(0018890)
fman (administrator)
2013-05-06 18:35

no more user feedback

- Issue History
Date Modified Username Field Change
2013-04-26 11:53 Lucy New Issue
2013-04-26 13:05 fman Priority high => normal
2013-04-26 13:11 fman Note Added: 0018783
2013-04-26 13:13 fman Note Edited: 0018783 View Revisions
2013-04-26 13:22 fman Note Edited: 0018783 View Revisions
2013-04-26 13:22 fman Note View State: 0018783: public
2013-04-26 13:23 fman Note Edited: 0018783 View Revisions
2013-04-28 08:46 fman Note Added: 0018792
2013-05-06 18:35 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-05-06 18:35 fman Note Added: 0018890
2013-05-06 18:35 fman Status new => resolved
2013-05-06 18:35 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-06 18:35 fman Resolution open => fixed
2013-05-06 18:35 fman Assigned To => fman
2013-05-22 20:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker