Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005638TestLinkRequirement Managementpublic2013-04-15 07:362013-05-22 20:59
Reporterngiraud 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005638: Combo box content when copying requirements and there are duplicated req. spec with different parent
DescriptionWhen I copy som requirements from a "folder" to an other, I have a combobox which contain the list of each "folder".

But this list contains only the name of the folder, and non the code (SRS_ID).
So if two folder have the same name, yon can't choose the right one.

Can I make some personal configuration for doing this, or is it somethig to fix ?
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)mysql
Browserchrome / IE 10
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0018692)
fman (administrator)
2013-04-15 10:31

having two folders with SAME PARENT with same name is a condition that TestLink has to block.
(0018693)
ngiraud (reporter)
2013-04-15 12:57

The two folder has not the same parent.

For exemple, you have :
 - SRS_DIR_CAS : Directory for case 1
   * SRS_DIR_CAS_IHM : Interfaces
   * SRS_DIR_CAS_ACT : Actions
 - SRS_DIR_TES : Directory for case 2
   * SRS_DIR_TES_IHM : Interfaces
   * SRS_DIR_TES_ACT : Actions

In the combo box, you have :
.Directory for case 1
..Interfaces
..Actions
.Directory for case 2
..Interfaces
..Actions

So when you have lots of directories, yon cant find easily thr right one.
(It's not really a bug, but more a missing function)

I don't know if this details show you my problems ?
(0018696)
fman (administrator)
2013-04-15 18:42

it can be improved but IMHO is a false problem.
In the situation you have depicted you can be confused, because you are always the parent (Directory for case 1,Directory for case 2) that helps you.

Anyway will try to add the doc id
(0018697)
fman (administrator)
2013-04-15 19:10

Please test and provide feedback (adding a donation will not be bad :))
http://gitorious.org/testlink-ga/testlink-code/commit/4d564c7f3d5ff804e03dfd71aa1f2dc2a5b5bb1c [^]
(0018700)
ngiraud (reporter)
2013-04-15 21:28

First of all I haven't understand why IHMO is a false problem ! If you can explain, I could give you more details about our using of testlink.

So for feedback...
There are two way for copying requirements :
- Select a requirement and clic the "copy" button
- Select a folder and clic the "copy requirements" button.

The first way is OK, but the second dosen't match !
I can search in functions where I Can modify it, but I prefer send you this feedback !

(And great thanks for your quick support)
(0018701)
fman (administrator)
2013-04-16 09:06

Is a false problem because you have under your eyes all info you need, because you can see the parent req spec, unless you have a large amount of children and you need to scroll.
There is nothing to explain about how to use testlink
(0018702)
ngiraud (reporter)
2013-04-16 14:06

I undertsant your position, and I'm agree with you when you say that all information are in the list, but it's should be an easier way to find folders if the SRS_ID was in the list.

In fact it's an important request of my users, even if I'm not using this function.
(0018707)
fman (administrator)
2013-04-16 21:17

also
http://gitorious.org/testlink-ga/testlink-code/commit/eb6a8f0f55afcfa2bb6f2bdbf3ca8dc2724bafa7 [^]
(0018733)
ngiraud (reporter)
2013-04-18 14:14

Great !
Thanks a lot.

- Issue History
Date Modified Username Field Change
2013-04-15 07:36 ngiraud New Issue
2013-04-15 10:31 fman Note Added: 0018692
2013-04-15 12:57 ngiraud Note Added: 0018693
2013-04-15 18:38 fman Summary Combo box content when I copying requirements. => Combo box content when copying requirements and there are duplicated req. spec with different parent
2013-04-15 18:42 fman Note Added: 0018696
2013-04-15 18:45 fman Severity major => feature request
2013-04-15 19:08 fman Assigned To => fman
2013-04-15 19:08 fman Status new => assigned
2013-04-15 19:08 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-04-15 19:08 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-04-15 19:09 fman Tag Attached: TO BE FIXED on 2.0
2013-04-15 19:10 fman Note Added: 0018697
2013-04-15 19:11 fman Relationship added child of 0005551
2013-04-15 19:11 fman Status assigned => resolved
2013-04-15 19:11 fman Resolution open => fixed
2013-04-15 21:28 ngiraud Note Added: 0018700
2013-04-15 21:29 ngiraud Status resolved => assigned
2013-04-15 21:29 ngiraud Resolution fixed => reopened
2013-04-16 09:06 fman Note Added: 0018701
2013-04-16 14:06 ngiraud Note Added: 0018702
2013-04-16 21:17 fman Note Added: 0018707
2013-04-16 21:17 fman Status assigned => resolved
2013-04-16 21:17 fman Resolution reopened => fixed
2013-04-18 14:14 ngiraud Note Added: 0018733
2013-05-22 20:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker