Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005610TestLinkBug Tracking System - Redmine Integrationpublic2013-04-05 07:322013-05-22 20:59
Reporterredpiyo 
Assigned Tofman 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformBitnami Testlink OSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005610: Redmine Create issue from Testlink - blocked due to Redmine MANDATORY Fields
DescriptionAn issue is encountered when creating an issue from testlink
Create REDMINE Ticket FAILURE => redmine::_requesturl:http://155.69.225.233/redmine/ [^] - response:Array - content: <?xml version="1.0" encoding="UTF-8"?><errors type="array"><error>Affected version can't be blank</error><error>Target version can't be blank</error></errors> - serialized issue:N;
Steps To Reproduce1) Click on create issue from Test Execution
Additional InformationWill require a way to include the Target version from Testlink
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon settings-issue-tracking.png [^] (13,246 bytes) 2013-04-06 11:35


png file icon redmine-issue-available-columns.png [^] (18,404 bytes) 2013-04-06 11:36


png file icon columns-AFTER-CONFIG-change.png [^] (19,663 bytes) 2013-04-06 11:37

- Relationships
related to 0005517closedfman Create Issue (SOAP) fails due to required attributes (not managed yet on TestLink) 
parent of 0005613closedfman Redmine Create issue from Testlink - Allow setting of issues attributes through XML configuration 

-  Notes
(0018626)
fman (administrator)
2013-04-05 12:08

please confirm that you have checked for similar issues on mantis (removing status filter)
(0018627)
redpiyo (reporter)
2013-04-05 16:12

Issue is unique and not found in mantis, please note it was reproduceable uisng redmine 2.0
(0018629)
fman (administrator)
2013-04-06 10:54
edited on: 2013-04-06 10:56

More details are needed.
Just installed Bitnami Redmine 2.3.0.
Found no standard fieldd named:
Affected version
Target version

Redmine API documentation regarding issue creation indicates:


Creating an issue
POST /issues.[format]

Parameters:
    issue - A hash of the issue attributes:
    project_id
    tracker_id
    status_id
    subject
    description
    category_id
    assigned_to_id - ID of the user to assign the issue to (currently no mechanism to assign by name)
    parent_issue_id - ID of the parent issue
    custom_fields - See Custom fields
    watcher_user_ids - Array of user ids to add as watchers (since 2.3.0)

Again no mention regarding:
Affected version
Target version

Because I'm not redmine user, only thing I can immagine is that these are Custom fields.

Can you please confirm or provide more details ?

Current TestLink implementation do not support creation issue on redmine
sending CUSTOM FIELD info

(0018630)
fman (administrator)
2013-04-06 11:35
edited on: 2013-04-06 13:56

After digging a littel bit I've found under Settings -> Issue tracking, the possibility to add new columns BUT ONLY ON VIEW, and in this list the two fields (Affected versio
and target version are present).
(see attached images)

More digging => Target Version field is available on issue reporting ONLY AFTER versions has been created for project

(0018633)
fman (administrator)
2013-04-06 17:38

From:
http://www.redmine.org/issues/6843 [^]
"Target version" is the new display name for this property,
but it's still named fixed_version internally and thus in the API.

Following lines have to be added on issue tracker configuration

<attributes><fixed_version_id>2</fixed_version_id><category_id>1</category_id>
</attributes>


Fix will be released on next days, then issue status will be changed.
(0018634)
fman (administrator)
2013-04-07 09:14

These are columns of issue table on redmine 2.3
`id`, `tracker_id`, `project_id`, `subject`, `description`, `due_date`, `category_id`, `status_id`, `assigned_to_id`, `priority_id`, `fixed_version_id`, `author_id`, `lock_version`, `created_on`, `updated_on`, `start_date`, `done_ratio`, `estimated_hours`, `parent_id`, `root_id`, `lft`, `rgt`, `is_private`, `closed_on`

need to check if any of these can updated via API using column name as KEY
(0018635)
fman (administrator)
2013-04-07 09:26
edited on: 2013-04-07 09:32

Tested OK (using new test page provided with TestLink 1.9.7
test2.redminerestinterface.class.php)


$cfg = "<issuetracker>\n" .
       "<apikey>{$apiKey[$redmineHost]['user']}</apikey>\n" .
       "<projectidentifier>{$projectidentifier[$redmineHost]}</projectidentifier>\n" .
"<attributes><fixed_version_id>2</fixed_version_id><category_id>1</category_id>\n" .
       "<estimated_hours>12.6</estimated_hours>\n" .
       "</attributes>\n" .

           "<uribase>http://$redmineHost/redmine/</uribase>\n" [^] .
           "</issuetracker>\n";


Estimated hours were updated

(0018636)
fman (administrator)
2013-04-07 09:33

http://gitorious.org/testlink-ga/testlink-code/commit/2f6bbcf865f5004873b6693511e28ccaa57336e4 [^]

- Issue History
Date Modified Username Field Change
2013-04-05 07:32 redpiyo New Issue
2013-04-05 12:08 fman Note Added: 0018626
2013-04-05 16:12 redpiyo Note Added: 0018627
2013-04-06 09:28 fman Summary Redmine Create issue from Testlink => Redmine Create issue from Testlink - blocked due to Redmine MANDATORY Fields
2013-04-06 09:56 fman Relationship added related to 0005517
2013-04-06 10:54 fman Note Added: 0018629
2013-04-06 10:56 fman Note Edited: 0018629 View Revisions
2013-04-06 10:56 fman Assigned To => fman
2013-04-06 10:56 fman Status new => feedback
2013-04-06 11:35 fman Note Added: 0018630
2013-04-06 11:35 fman File Added: settings-issue-tracking.png
2013-04-06 11:36 fman File Added: redmine-issue-available-columns.png
2013-04-06 11:37 fman File Added: columns-AFTER-CONFIG-change.png
2013-04-06 13:56 fman Note Edited: 0018630 View Revisions
2013-04-06 17:38 fman Note Added: 0018633
2013-04-06 17:38 fman Status feedback => assigned
2013-04-07 09:14 fman Note Added: 0018634
2013-04-07 09:26 fman Note Added: 0018635
2013-04-07 09:28 fman Relationship added parent of 0005613
2013-04-07 09:32 fman Note Edited: 0018635 View Revisions
2013-04-07 09:33 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-04-07 09:33 fman Note Added: 0018636
2013-04-07 09:33 fman Status assigned => resolved
2013-04-07 09:33 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-04-07 09:33 fman Resolution open => fixed
2013-04-07 09:33 fman Tag Attached: TO BE FIXED on 2.0
2013-05-22 20:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker