Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005599TestLink0 - User too Lazy to analize defined categoriespublic2013-03-29 01:292013-05-22 20:59
ReporterGilbert 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005599: "Save and move to next" worked unexpectedly within a test suite after test case IMPORT from XML without ORDER attribute
DescriptionWhen I import cases with titles like "1 - title1", "Save and move to next" button does not work correctly.
Steps To Reproduce1 - import cases into a test suite
2 - add and assign those cases, then go to "Test execution" page
3 - make the 1st case "pass" and click the button of "Save and move to next",
it will move to the 10th case's page. (And 2nd=>20th ... 11th => 110th)
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 19.0.2
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon test.xml [^] (5,377 bytes) 2013-03-30 01:14
png file icon zero.png [^] (37,202 bytes) 2013-04-02 21:32

- Relationships
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0018598)
fman (administrator)
2013-03-29 11:54

level of details provided are insufficient for any kind of analysis.
We need level of detail explained on forum or we will be forced to close on 1 week
(0018601)
Gilbert (reporter)
2013-03-29 14:22

My Test Scenario
ONE ACTIVE TEST PLAN
ONE PLATFORM
ONE BUILD

1. create test project Pj1
2. create Test plan Tp1
3. create build B1
4. create Test suite Ts1
5. import cases into Ts1 from a xml file which includes 116 pcs cases. (Tc1, Tc2...Tc116)
6. add Ts1 to test plan Tp1 and assign those cases to user 'gil'

7. from "Text Execution" page, execute Tc1 -> passed
8. click the button "Save and move to next", it went to Tc10's page, not Tc2's.
9. Execute Tc10 -> passed
10. click the button "Save and move to next", it went to Tc100's page.
...
(0018605)
fman (administrator)
2013-03-29 16:50

Please provide XML file test spec, in order to work WITH SAME DATA SET.
(0018612)
fman (administrator)
2013-04-02 21:15

got xml file
(0018613)
fman (administrator)
2013-04-02 21:30
edited on: 2013-04-02 21:31

Issue seems to be related to the fact that xml provided has NO ORDER specified for test cases.
when order is same for ALL test cases seems we are ordering considering number as strings then
10 comes BEFORE 2.

Give a look to attached image, exec order is ALWAYS 0.

(0018614)
Gilbert (reporter)
2013-04-03 01:57
edited on: 2013-04-03 02:00

I didn't get it exactly. What are U ordering by during the case execution with execution orders all set to '0'?
Pls note that the symptom continued even with usual title like "title1".
BTW, is it possible to specify execution orders in xml? As it's time-consuming to do that in the "Add/Remove Test cases" page.

(0018615)
fman (administrator)
2013-04-03 15:31

>> BTW, is it possible to specify execution orders in xml?
yes.
is this info missing from our documentation ?
have you checked the file formats documentation ?
(0018624)
fman (administrator)
2013-04-03 18:45
edited on: 2013-04-03 20:16

http://gitorious.org/testlink-ga/testlink-code/commit/06031aa4cdc5980da7b23e502557530ac8334335 [^]

http://gitorious.org/testlink-ga/testlink-code/commit/bed3c5088ff21c50dd59a3b82e7d237259e1a640 [^]

issue was generated because on testplan->getTestCaseSiblings()
recorset was order by exec order,test case name

now this has been changed to exec order,test case external id

(0018672)
Gilbert (reporter)
2013-04-11 06:45

Regarding “specify execution orders in xml”, the info is missing from the "tl-file-formats.pdf v1.0"

- Issue History
Date Modified Username Field Change
2013-03-29 01:29 Gilbert New Issue
2013-03-29 11:54 fman Note Added: 0018598
2013-03-29 11:55 fman Status new => feedback
2013-03-29 14:22 Gilbert Note Added: 0018601
2013-03-29 14:22 Gilbert Status feedback => new
2013-03-29 16:50 fman Note Added: 0018605
2013-03-30 01:14 Gilbert File Added: test.xml
2013-04-02 21:15 fman Note Added: 0018612
2013-04-02 21:30 fman Note Added: 0018613
2013-04-02 21:31 fman Note Edited: 0018613 View Revisions
2013-04-02 21:32 fman File Added: zero.png
2013-04-02 21:33 fman Assigned To => fman
2013-04-02 21:33 fman Status new => work in progress
2013-04-03 01:57 Gilbert Note Added: 0018614
2013-04-03 02:00 Gilbert Note Edited: 0018614 View Revisions
2013-04-03 15:31 fman Note Added: 0018615
2013-04-03 18:43 fman Status work in progress => assigned
2013-04-03 18:43 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-04-03 18:43 fman Status assigned => resolved
2013-04-03 18:43 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-04-03 18:43 fman Resolution open => fixed
2013-04-03 18:44 fman Summary "Save and move to next" worked unexpectedly within a test suite => "Save and move to next" worked unexpectedly within a test suite after test case IMPORT from XML without ORDER attribute
2013-04-03 18:45 fman Note Added: 0018624
2013-04-03 18:45 fman Tag Attached: TO BE FIXED on 2.0
2013-04-03 18:45 fman Relationship added child of 0005551
2013-04-03 20:15 fman Note Edited: 0018624 View Revisions
2013-04-03 20:16 fman Note Edited: 0018624 View Revisions
2013-04-11 06:45 Gilbert Note Added: 0018672
2013-05-22 20:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker