Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005596TestLinkBug Tracking System - Mantis Integrationpublic2013-03-26 14:592013-05-22 20:59
ReporterRTLCJB 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005596: Mantis Bug generation from testlink fails if bug description is larger than mantis permitted bug summary section. (I.E This Box)
DescriptionOn mantis bug generation from testlink could an option be added to allow the user to custom make a mantis summary description.

bug generation will fail if the auto generated path is to large to fit in the mantis summary section.
Steps To Reproduce1) Generate a long test path

/TestSuiteA/TestSuiteB/TestSuiteC/TestSuiteD/TestSuiteE/MYTest00000001

2) Execute test and mark as failed

3) Click create issue (generate mantis issue)

4) Fail (No indication why)



Additional InformationTested on V1.9.6
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserInternet explorer
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0018581)
fman (administrator)
2013-03-26 16:52

Mantis summary will be truncated to max size according to mantis version 1.2.4
(0018585)
RTLCJB (reporter)
2013-03-27 09:22

Tested with Mantis V1.2.10 (Interface:soap)
(0018588)
fman (administrator)
2013-03-27 19:25

Tested with Mantis running with MySQL, issue is created but summary is truncated
This seems to be the way MySQL works when installed in standard way.
(0018589)
fman (administrator)
2013-03-27 19:27

http://gitorious.org/testlink-ga/testlink-code/commit/5d2e95385caf699f13665e2269fbd14239c3fcad [^]

- Issue History
Date Modified Username Field Change
2013-03-26 14:59 RTLCJB New Issue
2013-03-26 16:52 fman Note Added: 0018581
2013-03-26 18:09 fman Assigned To => fman
2013-03-26 18:09 fman Status new => assigned
2013-03-26 18:09 fman Description Updated View Revisions
2013-03-27 09:22 RTLCJB Note Added: 0018585
2013-03-27 19:25 fman Note Added: 0018588
2013-03-27 19:25 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-03-27 19:27 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-03-27 19:27 fman Note Added: 0018589
2013-03-27 19:27 fman Status assigned => resolved
2013-03-27 19:27 fman Resolution open => fixed
2013-03-27 19:27 fman Relationship added child of 0005551
2013-05-22 20:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker