Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005580TestLinkFilterspublic2013-03-20 22:022013-05-22 20:58
Reporteradejeffchen 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformUbuntu 12.04OSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005580: Filters has no effect in Test Execution when same sets of test cases are assigned by Platform
DescriptionInstalled: BitNami virtual machine image version of TestLink 1.9.6

When I assigned the test cases by platforms to two testers, they can see all test cases during Test Execution even though the platform selected is not theirs under Settings.
Steps To Reproduce0. create two testers (tester1, tester2)
1. create two test cases (TC1, TC2)
2. create two platforms (Win32, iOS)
3. create a test plan (TP1) and a build
4. add the two platforms to it
5. add the two test cases to TP1 with two platforms each
6. assign all Win32 cases to tester1, all iOS cases to tester2
7. sign in as tester1
8. click "Test Execution"
9. under "Settings", choose platform iOS (which is not his assignment)
10. apply filter of "assigned to" = tester1
result: sees test cases that's not assigned to tester1
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browserall
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon TL_filterBug.png [^] (53,348 bytes) 2013-03-20 22:02

- Relationships
duplicate of 0005566closedfman "Assigned to" does not work in "test execution" page 
duplicate of 0005572closedfman Filter by Platforms - Wrong test case state count in test plan execution 

-  Notes
(0018517)
adejeffchen (reporter)
2013-03-20 22:10

in my config.inc.php, I have the following settings:
$tlCfg->exec_cfg->view_mode->tester='assigned_to_me';
$tlCfg->exec_cfg->exec_mode->tester='assigned_to_me';
(0018519)
fman (administrator)
2013-03-20 22:13

please always check for similar issues.
Give a look to issue 0005551, container of already reported and solved issue.
I think this issue is a duplicate.
Please provide feedback
(0018520)
adejeffchen (reporter)
2013-03-20 22:59

When I logged in as admin, go to Test Execution and do the filtering, result is the same (unexpected). I am not sure if it's the same problem as 5572.

Looks like the filtering result in Test Execution is not the same as the filtering result in Assign Test Case Execution.

I remove all the platforms and do a filter by Priority or by Execution type in Test Execution mode, it just returns me everything.
(0018536)
fman (administrator)
2013-03-21 19:20

please check all related issues (there are two), retest and only then provide more info is things did not work
(0018540)
adejeffchen (reporter)
2013-03-21 20:10

After applying both fixes, this issue no longer occurs. thanks!
(0018542)
fman (administrator)
2013-03-21 21:36

Great. Try to follow our advices
(0018767)
tintin (reporter)
2013-04-25 07:13

I also just update from 1.9.3 to 1.9.6, encounter the same problem. And I follow the fix here:
http://gitorious.org/testlink-ga/testlink-code/commit/47e161b49206de900da34089e6a87c6252485c94 [^]

Then it is okay now.

Thanks for quick support. Keep up with great work @fman

- Issue History
Date Modified Username Field Change
2013-03-20 22:02 adejeffchen New Issue
2013-03-20 22:02 adejeffchen File Added: TL_filterBug.png
2013-03-20 22:10 adejeffchen Note Added: 0018517
2013-03-20 22:13 fman Note Added: 0018519
2013-03-20 22:13 fman Relationship added duplicate of 0005566
2013-03-20 22:14 fman Relationship added duplicate of 0005572
2013-03-20 22:14 fman Assigned To => fman
2013-03-20 22:14 fman Status new => feedback
2013-03-20 22:59 adejeffchen Note Added: 0018520
2013-03-20 22:59 adejeffchen Status feedback => assigned
2013-03-21 19:20 fman Note Added: 0018536
2013-03-21 19:20 fman Status assigned => feedback
2013-03-21 20:10 adejeffchen Note Added: 0018540
2013-03-21 20:10 adejeffchen Status feedback => assigned
2013-03-21 21:36 fman Note Added: 0018542
2013-03-21 21:37 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-03-21 21:37 fman Status assigned => resolved
2013-03-21 21:37 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-03-21 21:37 fman Resolution open => duplicate
2013-04-25 07:13 tintin Note Added: 0018767
2013-05-22 20:58 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker