Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005566TestLinkTest Execute - Filterspublic2013-03-18 08:532013-05-22 20:59
ReporterFelixLin 
Assigned Tofman 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformCentOSOSOS Version
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005566: "Assigned to" does not work in "test execution" page
DescriptionAlthough right configuration in "config.inc.php":
$tlCfg->exec_cfg->view_mode->tester='assigned_to_me';
$tlCfg->exec_cfg->exec_mode->tester='assigned_to_me';
$tlCfg->exec_cfg->user_filter_default='logged_user';

The user with tester-role can see all the testcases in "test execution" page.
It's not convenient for tester to execute the cases assigned to him/her when there are many cases in a build.

Even if he/she apply the filter with "Assigned to == his/her logged name", he/she cannot see only the cases for himself/herself.
Steps To ReproduceTest leader.
A. Design test case for a Project.
B. Create a test plan.
C. Created a build for this plan.
D. Add some test cases to tester-A, the others to tester-B for this plan.

Tester-A logged in testlink, to do the cases assigned to him.
In "test execution" page, he cansee all the testcases although only the ones assigned to him can be executed.

Tester-B has the same condition.
 
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
BrowserFireFox
PHP VersionPHP Version 5.3.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon user-cfg-5566.png [^] (27,006 bytes) 2013-03-18 19:37


xml file icon ISSUE-5566.testproject-deep.xml [^] (2,276 bytes) 2013-03-18 19:38
xml file icon linkedItems_PLAN-A.xml [^] (1,737 bytes) 2013-03-18 19:39

- Relationships
has duplicate 0005580closedfman Filters has no effect in Test Execution when same sets of test cases are assigned by Platform 
has duplicate 0005639closedfman Filter by assignment. 
related to 0005572closedfman Filter by Platforms - Wrong test case state count in test plan execution 
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0018473)
fman (administrator)
2013-03-18 19:37
edited on: 2013-03-18 21:15

XML with test spec, used to test
XML with test plan definition (linkedItems_PLAN-A.xml)

Issue is verified when all test cases have NOT RUN status, due to missing
piece on where clause on testplan->initGetLinkedForTree()

(0018474)
fman (administrator)
2013-03-18 21:20
edited on: 2013-03-18 21:48

Apply in order:
http://gitorious.org/testlink-ga/testlink-code/commit/ad425754f5ac1e9583f78dd1c0f98d3291ec34a0 [^]

http://gitorious.org/testlink-ga/testlink-code/commit/47e161b49206de900da34089e6a87c6252485c94 [^]

(0018476)
fman (administrator)
2013-03-18 21:21

please apply provided fix, retest and let us know
(0018479)
FelixLin (reporter)
2013-03-19 01:20

fman,
do you mean the following fix:
    Availables hot-fixes for 1.9.6

    Get latest package with all fixes from gitorious, using wget
    wget http://gitorious.org/testlink-ga/testlink-code/archive-tarball/testlink_1_9 [^] [^]

I am not a developer, and know nothing about wget.

will you please give me some guide to apply the fix?
(0018480)
FelixLin (reporter)
2013-03-19 02:30

fman,
I just replace the "lib/functions/testplan.class.php" with the one in "latest package".
I find the problem disappear.

Maybe it's not enough?
Thanks.
(0018486)
fman (administrator)
2013-03-19 18:46

you need to make an effort and understand how the links to gitoriuos commits work.
I can not provide the kind of support your are requesting (it means an giant effort).
Do not use mantis to ask thinks, just to report and provide requested feedback
(0018500)
FelixLin (reporter)
2013-03-20 09:59

OK,Thanks you.
now I replaced the "testplan.class.php"file, it seems that works well.
I just wait for your next stable release.

- Issue History
Date Modified Username Field Change
2013-03-18 08:53 FelixLin New Issue
2013-03-18 10:03 fman Priority urgent => normal
2013-03-18 19:36 fman Assigned To => fman
2013-03-18 19:36 fman Status new => acknowledged
2013-03-18 19:37 fman Note Added: 0018473
2013-03-18 19:37 fman File Added: user-cfg-5566.png
2013-03-18 19:38 fman File Added: ISSUE-5566.testproject-deep.xml
2013-03-18 19:39 fman Note Edited: 0018473 View Revisions
2013-03-18 19:39 fman File Added: linkedItems_PLAN-A.xml
2013-03-18 19:39 fman Note Edited: 0018473 View Revisions
2013-03-18 21:15 fman Note Edited: 0018473 View Revisions
2013-03-18 21:20 fman Note Added: 0018474
2013-03-18 21:20 fman Tag Attached: TO BE FIXED on 2.0
2013-03-18 21:21 fman Note Added: 0018476
2013-03-18 21:21 fman Status acknowledged => feedback
2013-03-18 21:21 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-03-18 21:23 fman Relationship added child of 0005551
2013-03-18 21:48 fman Note Edited: 0018474 View Revisions
2013-03-18 21:49 fman Relationship added related to 0005572
2013-03-19 01:20 FelixLin Note Added: 0018479
2013-03-19 01:20 FelixLin Status feedback => assigned
2013-03-19 02:30 FelixLin Note Added: 0018480
2013-03-19 18:46 fman Note Added: 0018486
2013-03-19 18:46 fman Status assigned => resolved
2013-03-19 18:46 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-03-19 18:46 fman Resolution open => fixed
2013-03-20 09:59 FelixLin Note Added: 0018500
2013-03-20 22:13 fman Relationship added has duplicate 0005580
2013-04-15 19:38 fman Relationship added has duplicate 0005639
2013-05-22 20:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker