Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005555TestLinkTest Executepublic2013-03-12 11:312013-05-22 20:58
Reporterowohlfarth 
Assigned Tofman 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS VersionServer 2008 R2
Product Version1.9.6 (2013 Q1 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005555: Test Execution Tree does not show correct color/numbers
DescriptionThe Tree in "Test Execution" only shows "Passed" in a green color. All other test cases ("Blocked", "Failed"...) are shown as "Not Run" grey.

Furthermore the numbers representing the amount of "Passed" "Blocked" etc. TestCases below the tree is not working correctly.
Only the number for "Passed" TestCases is correct. All other Numbers are summed up as "Not Run".
Steps To Reproduce1) Navigate to Test Execution
2) "Save execution" as "Passed"
3) Item in tree is green and the number for "Passed" items is correct
4) "Save execution" as "Blocked"
5) Item in tree is grey and number for "Blocked" is 0
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
BrowserFirefox / Opera / IE / Chrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Screenshot.png [^] (128,044 bytes) 2013-03-25 08:21


? file icon Color_Test.tiff [^] (104,018 bytes) 2013-03-26 21:25

- Relationships

-  Notes
(0018421)
fman (administrator)
2013-03-12 19:23

Unable to reproduce
Firefox 19 on Fedora 18 64 bits.

double check to understand if you have some cookie or javascript error
(0018568)
piotrgrzybowski (reporter)
2013-03-25 08:21

I am able to reproduce this Bug.
Browser: Firefox 19
OS: Ubuntu
Test Link Version: TestLink 1.9.4 (Prague - Speedy)
1. Set Bug Execution to Not Ok -> Bug in Tree is red.
2. Set Bug Execution to Ok -> Bug in Tree is green.
3. Set Bug Execution to Not Ok -> Bug in Tree is green, but it should be green.
See attachment.
(0018569)
fman (administrator)
2013-03-25 09:06

We are talking of 1.9.6 then what happens on 1.9.4 is useless.
You have to test on same version where issue was reported not on an older one.

Tree is refreshed using JAVASCRIPT.
Please check if on left panel there is some option that prevents refreshing

Situation on 1.9.6 is still => unable to reproduce. Note 18568 has to be ignored
(0018571)
owohlfarth (reporter)
2013-03-25 09:15

Hi,

the Problem occured after upgrade from 1.9.3 to 1.9.4 to 1.9.6.
Clean folder etc. just like said in upgrade notice.
We then just updated database and applied changes to the config file.

Nothing is blocking js, but it's just not working

After a downgrade to 1.9.5 it seems to work. Allthough there are other Problems like you can't edit testcases any more.

After all, a lot of problems occure after an upgrade from 1.9.3, like :
http://mantis.testlink.org/view.php?id=5556 [^]
(0018573)
grinder (reporter)
2013-03-25 11:24

I experience the same issue and we have recently upgraded from 1.9.3 to 1.9.4 and then to 1.9.6 too. The only difference is that even Passed statuses are not displayed properly - all test-cases are just grey in the tree on the left.
(0018575)
fman (administrator)
2013-03-25 13:20

@owohifarth
>> After all, a lot of problems occure after an upgrade from 1.9.3, like :
This has absolutely no value.
1. on 5556 is not clear that you have updated from 1.9.3
2. if you have more issue detail it please, but do not write '...lots of problems...' that means nothing and provide no value.

3. Is very important for us to understand if IN A FRESH 1.9.6 the issue exists, because when an issue is reported in a version I only test this version is version is latest.
(0018584)
denjolras (reporter)
2013-03-26 21:25

Not reproduced in 1.9.6 with latested patches
(0018676)
lbracqua (reporter)
2013-04-12 14:25

Hi,
I experience the same issue as grinder after upgrade from 1.9.4 to 1.9.6 (total is OK, all other counters are 0) after adding executions in 1.9.6 on testcases/testplans/builds added in 1.9.4.
I do not experience the same issue on fresh installation on 1.9.6 after all creations in 1.9.6.
(I only changed 'DB_NAME' in config_db.inc.php file, everything identical excepted this parameter)

Do you have any idea of what may explain this difference?
(0018686)
fman (administrator)
2013-04-14 14:33

I can not, but having a DB where the issue happens will be a great help
(0018703)
grinder (reporter)
2013-04-16 14:28

lbracqua, I have tried installing the hotfixes for 1.9.6 and the issue seem to be gone.
(0018704)
lbracqua (reporter)
2013-04-16 14:52

Thank you grinder for the information.
Thank you fman for your proposal. But I use Testlink for military projects, I can not send you the (classified) DB. I will first try the hotfixes, if not suffisant for us, I need time to make test datas in 1.9.4 and update to 1.9.6.
(0018747)
lbracqua (reporter)
2013-04-22 14:23

Hi,
After installing hotfixes dated 2013-04-21, the issue seem to be gone.
Thank you

- Issue History
Date Modified Username Field Change
2013-03-12 11:31 owohlfarth New Issue
2013-03-12 19:23 fman Note Added: 0018421
2013-03-12 19:23 fman Assigned To => fman
2013-03-12 19:23 fman Status new => feedback
2013-03-25 08:21 piotrgrzybowski Note Added: 0018568
2013-03-25 08:21 piotrgrzybowski File Added: Screenshot.png
2013-03-25 09:06 fman Note Added: 0018569
2013-03-25 09:15 owohlfarth Note Added: 0018571
2013-03-25 09:15 owohlfarth Status feedback => assigned
2013-03-25 11:24 grinder Note Added: 0018573
2013-03-25 13:20 fman Note Added: 0018575
2013-03-26 21:25 denjolras Note Added: 0018584
2013-03-26 21:25 denjolras File Added: Color_Test.tiff
2013-04-12 14:25 lbracqua Note Added: 0018676
2013-04-14 14:33 fman Note Added: 0018686
2013-04-16 14:28 grinder Note Added: 0018703
2013-04-16 14:52 lbracqua Note Added: 0018704
2013-04-22 14:23 lbracqua Note Added: 0018747
2013-04-22 16:49 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-04-22 16:49 fman Status assigned => resolved
2013-04-22 16:49 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-04-22 16:49 fman Resolution open => fixed
2013-05-22 20:58 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker